Jump to content
Bronxteck

New voodoops2controller.kext out by ANV aka Andyvan

Recommended Posts

New Update On Voodoops2controller NO DEBUG OUTPUT Yay... But Takes getting use to.. Oh well, Here it is

Oh and here's The link for "Feedback/ bugs .. Cough... Cough" and source code

http://osx86.co/f36/...nd-tiger-t6814/

I can adjust the setting's from trackpad prefpane like 2 finger scrolling.. more like 1 finger but its very sensitive to touch so don't hurt it's feeling ok. :lol:

 

Please test and give your opinion

 

Slice: Sorry for disturbing at non my topic but I made better driver and do not want to create new thread.

Changes:

1. Keyboard: works with multimedia keys (that missing at Latitude :( but present at Inspiron). Button >

2. Trackpad

- run smoothly

- scroll more slow

- dragging by hard touch can be switched on/off by Trackpad.prefPane

- side scrolling can be switch on/off by the prefPane

- speeds can be adiusted

TODO. trackstick is still dead.

PS2drivers_v116.zip

 

The attachment below is very old... use the one above... slice's trackpad is the latest working build

VoodooPS2Controller.kext.zip

Share this post


Link to post
Share on other sites

Just tried this, its very fiddly don't know if I can get used to it :blink:

If you add any weight into your touch it doesn't register your movement. Btw I tested it on D430 so might be different on the larger latitudes.

 

I'm currently on EDP 1.4 so was stuck in debug mode before this which was super slow, has this problem been fixed in 1.5RC? Been putting off the update since I've got pretty much everything else running smoothly.

Share this post


Link to post
Share on other sites

This might sound crazy but I took this 2nd version, installed it then overwrote part of the kext in the plugin folder with appleps2trackpad.kext from the version in edp (v0.98 debug on). It actually worked .. the trackpad has settled right down and no debug messages but... no scrolling either so wondered if the orig ver had scrolling?

 

Here's my modified version and you can see the tracking is way smoother.

 

VoodooPS2Controller.kext.zip

Share this post


Link to post
Share on other sites

Hey Thund3r you have to turn it on from trackpad prefpane it's working for me like a Mac trackpad light slide of finger mouse moves add pressure to pad it scrolls

 

BTW I deleted the third option it worked but it would panic at the drop of a hat. Truthfully I thought it was the AMD tscsync but that seems to be working great on my Intel machine

 

I will try your modified version when I get home

Share this post


Link to post
Share on other sites

Ok I took a look at the file you have Ps2 controller inside Ps2 controller but trackpad kext is missing. Without trackpad kext you loose functionality of trackpad and it just defaults to mouse function... so no scrolling

Share this post


Link to post
Share on other sites

Ok I took a look at the file you have Ps2 controller inside Ps2 controller but trackpad kext is missing. Without trackpad kext you loose functionality of trackpad and it just defaults to mouse function... so no scrolling

 

 

 

Okay fixed it ..scrolling works .. but debug is back on ... gah .. okay at least now we know that it's the actual voodoops2trackpad that has the debug set to on. Too bad u couldn't just edit the plist.info to <key>debug</key> <string>FALSE</string> to shut it the hell up.

 

Thanks for you help BT

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...