Jump to content
Bronxteck

New voodoops2controller.kext out by ANV aka Andyvan

Recommended Posts

Do you use any voodoops2 prefpane, or something?

 

Or only VoodooPS2.kext from post #4 without AppleACPIPS2NUB.kext?

 

Yes, I'm afraid all I did was replace the EDP rc5 VoodooPS2.kext with the post #4 version.

 

What else should I do?

Share this post


Link to post
Share on other sites

I see. But there is one thing that we need to fix: side-scrolling. It's too sensitive and glitchy, but it worked well with voodoops2 in the EDP - that's in debug mode :huh:

 

Do you have any idea how to fix the scrolling?

Share this post


Link to post
Share on other sites

Now I begin to work on PS2 Trackpad. What I see:

Feb  5 16:04:11 MacDell kernel[0]: ApplePS2Controller: Timed out on mouse input stream.
Feb  5 16:04:11: --- last message repeated 1 time ---
Feb  5 16:04:11 MacDell kernel[0]: [ApplePS2ALPSGlidePoint] getModel
Feb  5 16:04:11 MacDell kernel[0]: [ApplePS2ALPSGlidePoint] E7: { 0x63, 0x03, 0xc8 } E6: { 0x00, 0x00, 0x64 }
Feb  5 16:04:11 MacDell kernel[0]: [ApplePS2ALPSGlidePoint] ALPS Device? No

 

It is not ALPS?! blink.gif

0x63, 0x03, 0xc8 -- for ALPS it must be 0x02!

I need information from private drivers for Windows. Anybody?

Share this post


Link to post
Share on other sites

.. and here is the tech. specs for the diffrent models..

 

http://www.osxlatitu.../Documents.html

It is not a datasheet , it is datashit. wink.gif

Touch Pad - PS/2 compatible, Track Stick - PS/2 compatible

 

Nontheless, I made a new driver.

VoodooPS2Controller.kext.zip

 

Touchpad:

tapping works, controlled by Vanilla Trackpad.prefPane (10.6.6).

Side scrolling at right - vertical, and at bottom - horizontal.

Trackstick: not working.

Sleep/wake - don't know yet.

 

May be other models has another trackpad ID, so look into kernel.log with DEBUG version.

VoodooPS2Trackpad.kext-DEBUG.zip

 

To install you HAVE TO DELETE all other PS2NUB, PS2Controller etc.

CLEAR CACHE, and reboot with -f (ignore cache)!

Share this post


Link to post
Share on other sites

Works but a few notices:

 

1. Its extremely sensetive, even if i set tracking speed to slow

2. How can i disable tapping in the pad (its over sensetive), changing it in the prefs. pane does not change it .. and as it is now, it makes it pretty useless.. i'm literally tapping all the time... :(

 

Scroll works.. _nice_...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...