Jump to content

Lenovo X1 Carbon OS X 10.9


Recommended Posts

  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

I have it running on a X1 Carbon Touch.  It works great save for the fact that unless you swap out the wireless card, you'll never be able to connect to the app store, use iCloud, iMessage, etc.  This is because there is no built-in ethernet.  USB to Ethernet dongles won't work because the IONetworkingFamily.kext code won't let a USB based ethernet device show up as "built-in".  I've tried everything that's ever been written on this subject, trust me none of them will work on a laptop that lacks built-in ethernet.  Though I haven't tried hacking the binary for the line that directs it to be false.  That's next.


So if you're OK with that, it makes a nice hackintosh.  Disable USB3 in the bios, or it will never sleep.


Follow any of the uni beast/My Hack boot instructions to get through the installer.


Note: You may have to boot the installer with safemode (-x from the boot option) you'll know if you get the spinning beach ball of death once past the Apple boot screen.


Install as normal.  On second boot, you may again have to use the safemode option.


Install the bootloader and fakesmc via the guides, also any ps2 mouse keyboard support, depending on the tool you choose to create the installer.


Then go grab the latest Chameleon, r2266 and install it.


Add a line to /Extra/org.chameleon.Boot.plist that reads




Now you can boot with and you'll have full QE/CI.  I've attached my boot.plist so you can see all the options I use.




You're display port won't work, because the "4" is just one port.  3 is correct, but it has the LCD and the DP backwards.


Install the attached kext that I edited the binary on and then change the IntelCapriFB value to 3, repair permissions and rebuild the cache using Kext Wizard and on the next boot you'll have both the LCD and the display port.  Both with full QE/CI.   If you don't care about the display port, then don't do this as it will screw up your audio, requiring DSDT edits.


For network, you'll want to get a USB wifi dongle, Ralink 2870 is what I use.  I use a mini-adapter from Panda.  It's nice and less than $20.  Make sure you go get the latest drivers for Mavericks, otherwise, the 10.8.5 driver will prevent it from shutting down or rebooting.  A dongle will work for internet access, just to be clear.  I just won't let you get to the app store, icloud, etc.

Bluetooth will work with the edited attached kext, install it, repair, rebuild, etc.  This just changes the product ID to match the broadcom in the X1.


Latest Voodoo 2.8.4 for audio, but there are some DSDT edits because when you fix the video issue, it enables HDMI audio, which isn't going to that useful on a laptop without HDMI out.  Not sure if we have the same mobo, but I can post my DSDT that has many fixes for power management. 


Grab rehabman's latest trackpad code, that will enable your trackpoint and give you some gestures on the ultranav.


If you have the Carbon Touch, google eGalax Touch screen.  The OSX driver is free and works great.


Install the attached ACIP and Battery Kexts to get the battery meter working.


Let me know if you decide to try it.  I have a few other custom kexts, like for the Lenova USB to Ethernet dongle (which, like the apple branded one, still fails to get you to the app store).


Link to comment
Share on other sites

  • Create New...