Jump to content

Dell Latitude E6500 - Mavericks


Recommended Posts


I having difficulties with some of the hardware drivers on my Dell L. E6500. Could someone help what I might be doing wrong? TIA!

I am running Mavericks on Dell Latitude E6500.

These are the steps I took:

I used the following to install the OS.

Had problem with boot, was receiving error "missing bluetooth controller"
fixed the boot by following https://osxlatitude.com/index.php?/topic/5894-solved-wont-boot-without-f-hang-at-missing-bluetooth-controller/?hl=%2Bmissing+%2Bbluetooth+%2Bcontroller

Once system boot and in the windows
> installed EDP and selected Dell Latitude E6500 and components. Received multiple errors regards to "*.myHack/*" not installed correctly...
> Installed myHack, and run "fix" selected "/", reboot the system.
> Re-ran EDP and selected my laptop, still receiving same error messages regards to "/S/L/E//myHack" not installed correctly...

As of now that I am aware of the following doesn't work
- sound
- wireless card (DW 1397)
Cairo Dock? when you select an item, it doesn't pop, not a big deal :-)

Dell Latitude E6500 Spec:
- Core Due P8400, 4G RAM an d160G HDD
- NVIDIA G. Card.
- IDH Sound
- not sure need to list the rest of the hardware.



Link to comment
Share on other sites

Hello Jrushcme,

Thank you for your suggestions.

I've tried installing that drivers under EDP and I kept getting varies error "

While when I try to update the driver, I kept getting the following messages one at a time:

System Extension cannot be used
The system extension "/System/Librariy/Extension/myHack.kext/Contents/Plugins/
- Intell82566MM.kext
- DellBluetoothHCI.kext
- ApplePS2Mouse.kext
- bunch of Apple message

- myHack.kex

- and bunch more...
was installed improperly and cannot be used. Please try reinstalling it or contact product's vendor for an update

After reboot, system doesn't boot, have to interrupt normal boot, and select "boot ignore caches" to start windows...


any suggestion?



Link to comment
Share on other sites

Thanks Darvinko and Jruschme!


On the first built flash drive, I've included "Extra_10_9".


Just built another new flash boot driver, and system freezes on the initial boot "bridges 8 devices 19"  https://osxlatitude.com/index.php?/topic/1324-e6500-hang-booting-hd/?hl=bridges.  They suggested to reset the BIOS and set SATA to AHCI, mine is already set that way...


- after creating flash drive, I checked the file permission, everything seem OK.

- I am going to run myHack again and include "Extra_10_9"... and check the file permission on /Volumes/usb xxx / ls -l to see anything changes.



Link to comment
Share on other sites

sorry, didn't see your messages earlier.

- re-do everything (build new flash drive from *.IOS/DMG), re-install OS.  Not sure what went wrong on the couple of the previous attempts.

- everything seems functioning OK.  It seems loading OS much faster too.


now I need to download some apps :-).  Where do you get games? Apps Store or? Thanks for your help everyone!



Link to comment
Share on other sites

  • Create New...