Jump to content

[SOLVED] Crazy screen on E6430 & 10.9.1


Recommended Posts

Hi All,


just got starting on OSX and setup like in Jake Lo's tutorial. Perfect, went all OK.


Weren't it for the constant running into an unreadable screen with small digital noise alike bars all over the screen. Flickering at pretty much any keystroke and mouse scroll. Even not doing anything it still fluctuates with these bars. I guess this is a driver problem but since this is my first go into the OSX world I've got no cpu. Replaced the kext as per Jake Lo's instruction to replace the AppleIntelFrambufferCapri.kext but nothing changed to the positive all the same. Even after a reboot.


Any ideas ??? Any help would be great !!!!





Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Oh yeah,


Forgot all About that, sorry.


E6430 - i5 3320m - 4GB - Samsung 840 Evo Ssd - Hd4000


Audio - Working

LAN - Working in gb, pretty fast I must admit

WiFi - .... Yet to check ....

Build-in keyboard & mouse - Working

USB 2 - Working

USB 3 - ... Yet to check ...

Externals - ... Yet to check ...


Updated from Snow Leopard, screen working ok, but that's pretty much it, the basics worked als well of course, like USB 2 left port, lan.


Even during install from myHack, screen was ok, but after reboot in Mav the whole scren went bananas ....


No EDP used, prepared the USB stick with myHack, added the extra folder and got the screen problems, Updated the ....capri.kext but no change at all. HD4000 is mentioned in the HW with 1366 x 768 @ 60 Hz






Link to comment
Share on other sites

Wel, since I do not have the original kext anymore (so far for backup) I took your advise and remove the kext file from the E/E folder, ran myfix with the quick option and finally rebooted (with the patched for 10.9.0 kext in S/L/E). A slight diff but the disturbing bars are all over the screen but more on a on/off cyclic thing and reacting on every keystroke or mouse move. Sometimes it stays clean for a little while, flashes than to a screen will a lot of bars and after while switches back to a normal screen etc. etc.


This text I typed with the on-board keyboard, using the mouse pad sometimes and used the LAN connector to get to the internet. Just working .... even my NAS (synology) based iTunes server was listed immediately as nasTunes and avail for all the media on it. Playing just fine, audio hearing good. Do not know what quality though got quite a collection of hires aac files a full TB in the range from 48 kbps - 192 kbps .... still testing ... but first need to get that nagging screen working ....


so if you got a default AppleIntelFramebufferCapri.kext for an e6430 w/ hd4000 at the above mentioned resolution would be just grand !!!!

Link to comment
Share on other sites

.... got it to stop to display these digital noise bars, with positive and negative side effects though.


Positive = if starting with the -x option the bars are gone.


Negative = by hand copy the AppleIntelFramebufferCapri.kext to the S/L/E with or without myfix the system hangs on boot  


Just after the copy action, a message with the text, the kext is not correctly installed or so and I needed to contact the vendor etc. This message was showing during a myFix run too.


So I probably messed up my install a bit. Any idea how to correct this, since as said b4, I'm pretty new to OSX. Actually, this is my very first one.


BTW: At boot time a message 'Invalid Partition' is permanently displayed on screen, after pressing enter it goes away and normal boot is proceeding ... is there anything to correct this since myhack does not run in save mode as either the sound card makes a noise .... there is always something ....

Link to comment
Share on other sites

  • Moderators

if you read my entire guide, there's a fix at the bottom to remove the "invalid partition" error.

To restore the unpatched file, look at "/Applications/Install OS X Mavericks.app/Contents/SharedSupport", you find InstallESD.dmg. If you mount that dmg (disk image), you should find the file. Install it back to SLE, run myfix (full).

Link to comment
Share on other sites

  • Create New...