Jump to content

[SOLVED] Crazy screen on E6430 & 10.9.1


Recommended Posts

... Good news, downgraded to A12 Bios, copy the kext of Robertostudios to S/L/E and did a full myfix and all the screen artefacts were gone ............... And the rest of the screen as well ..... So I've got now a running system but a complet black screen even in safe mode that ran before ....


Any suggestions ??


re-install would not be the preferred one ...

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

..... I'm an inpatient guy so re-installed mav again, but without erasing the ssd .... somehow the system succeeded in obscuring my password (still showing digital artifacts and BIOS on A12) ... so I could not get into my system ... all pwds typed in were refused ....


Next try, using bios a12, will be to:

  1. boot from USB
  2. clean the ssd with the disk utility
  3. install mav
Link to comment
Share on other sites

Well, did so and all worked except the screen of course. Still digital artefacts .....


Removed the Apple....Capri.kext from E/E and performed a quick myfix and a reboot but still no luck artefacts are insisting on their présence, as can be seen. The left part is a getinfo from the S/L/E Apple...Capri.kext, do not know what those yellow dots mean though these are from the E/E folder ...


Even the rightside USB with an MS wireless mouse does functioning as Well as the rest that I've testend so far ......


But the screen nags, any suggestions are more then welcome ....



Link to comment
Share on other sites

  • Administrators

if you have HD4000 graphics check the chameleon help file at boot. they have flags to enable the graphics. and i think there is a dual link flag as well you might need that too. you would need the original graphics kexts and use IntelCapriFB= This is for Intel HD 4xxx, value range's are 0-11

you can try IntelCapriFB=3 first if that does not work then try from 0 all the way to 11 one might fix your error.

Link to comment
Share on other sites

Thx for the hints, but since i'm just beginning with osx, i've got no idea how to get that help file and definately not how to get to the kext. Do you mean the one in the S/L/E folder and directory change that one and do a quick myfix ?

For what it's worth, if running in save mode, the screen is just perfect no nasty artefacts.

And yes, i'm using a hd4000. The AIFBC. Kext in the right of the picture is the one from E/E, with or without didn't loose the artefacts.

Some assistance would be greatly appreciated

Link to comment
Share on other sites

First updated chameleon via the wizard, than i've tried all IntelCapriFB settings from 0 - 11, the dual line and the gfx-enabler as well, could not get it working, changes were noticeble in it took longer to mess up the screen or did not do it at all but kicked-in when moving the mouse or using the keyboard. The only way to get it gone was to run in save mode.


as something completely wacko i removed the extras folder and bootet again and the artifacts were gone as all other settings as well. Changed the screen res to match `cause it was not set yet according to the chameleon wizard but found out the hard way that some things re-act a bit nervous about that, so now i'm stuck with a totaly screwed 10.9.1 osx not being able to boot, hangs when issueing the bt messages and as far as i've read sofar that's most likely due to screen/display issues. 


What I noticed as well is that the boot pack is for an i7 3520m with a 1600x900 res. I've got only an i5 3520m with a 1366x768 res, can it be that there are some timing diffs between the two systems and the i7 3520m bootpack just won't work for my setup ?


If so, is it possible to get my setup in the boot pack covered as well ?? What would it take to get it, if so ??





Link to comment
Share on other sites

  • Create New...