Jump to content

Precision M6300


Recommended Posts

I was curious as to whether anyone else here is running OS X on a Precision M6300. If so, are you running a "recent" (ML or Mavericks) version of OS X?


When I started trying in earnest on the M6300 in my signature, I did a lot of Googling and read a number of posts which claimed the system was a bit of a beast to Hackintosh and nothing later than some 10.7 installation info. My system is only running SL which seemed the easiest route based on the comments.


FWIW, my install was a combination of a generic myHack install of 10.6.3, a generic EDP laptop config, a DSDT from somewhere on the 'Net and a bit of experimentation. I was able to upgrade to 10.6.8, though I did replace two kexts with their 10.6.7 counterparts per various posts.


As for the system, pretty much everything works- sleep, emulated SpeedStep, audio (except possibly the microphone), wired and wireless networking, two-finger and edge scrolling and accelerated video. Bluetooth would probably also work, but my card seems to have gone bad.


If anyone is interested, I'll post my Extra directory.



Link to comment
Share on other sites

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

  • Administrators

Why run emulated SpeedStep when you can easily get native mode, especially on a T9500? Your graphics performance would have much to gain too. You know where to look and what to do, right?


I see no reason why you would not be able to run any of the more recent OS X versions, from Lion to Mavericks.

Link to comment
Share on other sites

Personally, I agree that it should be able to run a newer OS. I would have expected it to be about the same as a D830 install, given that the two are of similar vintage.


Using a myHack Mavericks USB installer with generic Extra, boot hangs at or around configuration of the PCI buses. It stops in the same place if I include the DSDT of unknown origin.


Going on a limb, I decided to follow what appears to be the canonical Lion install wisdom and replaced /S/L/E/AppleACPIPlatform.kext and /S/L/E/AppleACPIPlatform.kext on the installer with their 10.6.7 counterparts. This gets me an installer which appears to run, but the installation fails.


Next idea... a clean myHack Mavericks installer, but with the M4300 bootpack (which includes a version of AppleACPIPlatform.kext) but minus the DSDT. Hangs at or soon after PCI bus configuration.





Link to comment
Share on other sites

That was my next step... made no difference.


There was a typo in my previous message. The second kext was supposed to be /S/L/E/IOPICFamily.kext.


From what I can see, the problem is actually pretty common with a number of systems.


I won't be able to try again until tomorrow. I've seen one post which suggests adding "npci=0x2000" to the bootflags (though I suspect that should be npci=0x3000). That will be the first thing I try.

Link to comment
Share on other sites

Tried your advice with a clean 10.9.1 installer.


npci=0x2000 or 0x3000 gets me further an nothing, but still hangs

PciRoot=1 has no effect

The DSDT edit seems to have little or no effect

Swapping the kexts gets me further, but now it hangs at "DSMOS arrived"


Since the last part points to the graphics drivers, I tried "GraphicsEnabler=no"... no effect


I think the trick is in finding the right combo of replacement kexts since the first time I did that was the furthest I ever got.

Link to comment
Share on other sites

  • Create New...