Jump to content

Precision M6300


Recommended Posts

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Hello again....


I'm not having much luck here...  i've got a nice pile of hair next to my keyboard now i'm afraid (ha ha). Here's where i'm at:


I've tried adding/replacing the EXTRA files in my 10.8.4, 10.8.5, and 10.9 OSX images via TransMac, but i still cannot even get to an install screen. (I only alter the files in that folder, i never touch any of the files from the System/Library/Extensions folder.)


I've also just created a VMware OSX 10.9 - i've tried unifail and myHack tools with the above images as well, and then tried replacing the files in the Extras folder with your attached replacement files - no joy.


For my clarity (sorry, I'm new at this) the "Bootpack.zip" attachment is intended for the original creation/installation and the "Extra.zip" is for using with multifail after it's booted up correctly once, right?  I have tried getting to the initial install with one pack and then the other (because i wasn't sure), but neither seem to get me to an install screen.


I've also tried all the boot parameters suggested, and have even tried adding the  <key>DSDT</key><string>/Extra/DSDT.aml</string> to the org.chameleon.Boot.plist in the Extras folder... still no joy.


It's very possible i'm missing something simple here, but i promise i've read and read and tried and errored on this process many many times...


Please and thanks for any advice you can provide!

Link to comment
Share on other sites

I think the problem is that you are trying to build the installer under Windows (with TransMac). The preferred method (here, at least) is to build the installer from a within OS X using myHack.


I think you're on the right track with the VMware install. Can you get to the point where you have a running system? If so, then you should be able to install myHack and use that to build the installer.


The other alternative I've seen mentioned here it to bootstrap the installation by installing 10.6 (SL) from a retail disk using the Nawcom ModCD. This would set up a minimal OS X on your m6300, but it would be enough to install myHack and make the installer including the bootpack.

Link to comment
Share on other sites



I really appreciate that, and by using myHack with my VMware OSX, I've now been able to successfully get OSX10.9 to install and actually reboot correctly.


I will, in turn, write up a full HowTo on what I've done to get to this point - a few tweaks here and there, but 90% using your guide and files.  (For others interested, i'll be sure and include all the details.)


Not sure yet if all the hardware is doing it's thing correctly (example: WiFi simply doesn't want to turn on), but i imagine the correct KEXT applied to the right place in the right method may fix this kind of issue.  I'm still learning how to do that, so i'll have to keep trial and error and error until i get it right.


Thank you again for the advice!


-Update:  STILL trying to reproduce the steps I took to get 10.9 running.  I'm having a lot of trouble getting a consistent step-by-step going for this process.  I seem to be very hit-or-miss on getting through the initial boot and then through the initial installation, depending on which 10.9 DMG file i use when i first setup everything with myHack.  I do promise to post something as soon as i have it, if anyone else is working on this now, it would be great to hear your input!  Thanks!

Link to comment
Share on other sites

i'm on a similar mission as i have 2 m6300's and the wifes 2008 15" mackbook pro just died 


so i took a retail 10.9.2 and made a unifail boot using the bootpack for the m4300 dsdt and /e/e ... needed -v -f cpus=1 PCIRootUID=0 and graphicsenabler=no to get it installed ... then multifail with the dsdt from the bootpack 


so from that point i dug up the sound card, and ethernet kexts and that gave me a 95% functioning machine 


what is working:




wired ethernet

boot and shutdown (most of the time)


whats not working:



shutdown (sometimes have to hold power button down to complete shutdown)


my main concern that i'm working on now is:

chimera (chameleon, stolen and rebranded) and osx only sees 2gb of memory when the machine has 4gb in it 

from about this mac and memory info it shows only one memory slot populated when both have 2 gb chips in them 


windows sees all the memory so its not a hardware issue 

from what i have read it seems to be either a system definition issue or something like that but i cant seem to find anything on how to set this part up or which one i should be using on this machine 


anyone have any ideas or pointers for me on this one?

Link to comment
Share on other sites

actually it was a hardware thing 

turns out it was a loose memory chip that happened after the last time i booted into windows 


and i got sleep working 


last on the list startup/shutdown

it works 90% of the time flawlessly 


but then both on startup and shutdown i get the black screen with no hd activity ... only way out is the power button ... and then it boots fine 


any thoughts

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...