Jump to content

Inspiron 3520 Maverick problems


Recommended Posts

Well, after getting Mountain Lion to run almost perfectly, I thought I would give Mavericks a shot. I'm not using any ML kexts. I used Mountain Lion to build a Mavericks boot USB disk. And, I am using the default myHack kext pack.


Specs of the machine (From CPUID in Windows, which I'm using because I wasted the OS X partition and only have Windows now.)

















Dell Wireless 1515 (Atheros card. Should work oob)



So far, I haven't had any luck at all. It hangs here:

setWOW_PARAMETERS:wow events = 2(1)
ATHR: unknown locale: 60
ATHR: unknown locale: 60

Sometimes booting with -v -f -x will get me past that, but it will then eventually hang here:

BIOS Settings:
SATA is set as AHCI. 
Intel VT-x is disabled (I've tried with it enabled also.)
Legacy boot is enabled. (UEFI is disabled)
Speedstep is enabled.
I don't have an edited DSDT/SSDT. I haven't ever had one for this machine, even on Mountain Lion.
What am I doing wrong? Can someone give me some help, or point me in the direction that might at least get me to install Mavericks? Once I get there, I'm positive I can get this machine working great.
If you need more info, I can provide it. Just let me know.
Link to comment
Share on other sites

Small success. I added the ALPS touchpad driver from https://osxlatitude.com/index.php?/topic/2545-new-touchpad-driver-for-e6520-alps/, rebuilt kext cache and ran myFix. And that got me to the installer screen. But after selecting English as the main language, I was shown the "The OS X installation could not be completed".




Ok, I just cannot get this damn installer to start. I've rebuilt the myHack installer USB until I was blue in the face, and I always hang at the above picture. (Minus the ApplePS2ALPSGlidePoint Dictionary problems. I figured that out.) I've waited an hour each time, and it never goes past that.


Someone, anyone, chime in please. I'm stumped.

Link to comment
Share on other sites

Some more info with things I've tried:


-Creating the myHack installer on a GUID partition

-Creating the myHack installer on a MBR partition

-Standard myHack /Extra

-My /Extra from ML

-Boot pack's of similar models (E6220 and E6520 models are very similar)


Nothing has worked. It always hangs here (Can be seen in the last picture of my first post):

setWOW_PARAMETERS:wow events = 2(1)
ATHR: unknown locale: 60
ATHR: unknown locale: 60

Also, it IS Mavericks downloaded from the Apple App Store. I downloaded it before I got rid of Mountain Lion.

Link to comment
Share on other sites

does it have vt-d in bios? if so shut it off or boot with dart=0 flag. 

Ok, I had tried shutting off VT-d (Virtualization), but I haven't tried "dart=0" flag. I assumed that disabling VT-d would basically do the same. I see now that it does.


I have already tried this. :(


It seems to be hanging with the Wireless card, so I might just yank it out and see if it boots. If it does, maybe I can install OS X and then replace it and have it work.




Well, I pulled out the wireless card, and that didn't seem to help. Here's an updated picture of where it hangs:



Some things I noticed: 


OSMetaClass: Kext com.apple.driver.AppleIntelSNBGraphicsFB class HDCPCtrl is a duplicate;kext com.apple.driver.AppleIntelIntegratedFramebufferCapri already has a class by that name.

Kext com.apple.driver.AppleIntelSNBGraphicsFB start failed (result 0xdc00400a).

Kext com.apple.driver.AppleIntelSNBGraphicsFB failed to load (0xdc000017)


Are those in /S/L/E? I don't have them in /E/E. Could those be what is causing me to hang?

Link to comment
Share on other sites

It's hanging at graphics initialization; that's where your trouble lies. You need to sort out the handling of your HD3000. Tried boot option GraphicsEnabler=No?

I've tried GraphicsEnabler=Yes, but not "No". I'll give that a shot and get back with you guys. 


Many thanks!




Same result. :(

Link to comment
Share on other sites

Ok, I know its not supported, but I grabbed the Pandora's Box installer from over at InsanelyMac and it worked. It booted to the OS X Mavericks installer. I think removing all video kexts from /S/L/E would have probably worked on a myHack installer also, so I might give that a shot.


At least I'm making progress.

Link to comment
Share on other sites

I have. There isn't much, other than enabling HDMI audio and VGA. Helpful later, but not so much right now. 


I got kind of busy today, so I haven't tried removing the video kexts from a myHack boot USB drive yet. Will doing that also remove them when I install OS X, thereby forcing me to reinstall them after OS X is installed? If so, I'm ok with it. If not, will I face the same problem upon first boot?

Link to comment
Share on other sites

  • Create New...