Jump to content

Optiplex 760 - No boot after install


Recommended Posts



I've a Dell Optiplex 760 and try to install Mavericks with myHack.


I made the USB Stick with myHack and also copied the Extra files uploaded by MacsRTheBomb in this topic:



The install went fine, I located my ExtraOpti760 Folder when asked to Supply my Own Extra and I replyed Yes everytime to remove problematic extensions.

When the install was finished (I suppose), the PC restarted (without asking, is it normal?) but stay on:

Initializing Intel® Boot Agent GE v1.3.52.1

PXE 2.1 Build 089 (WfM 2.0)


It doesn't boot on the HDD.

Even if I press F12 for the Boot Options and then Select SATA0, nothing happen.


What should I try ?


My system:

Dell Optiplex 760

Core 2 Duo E7500 @ 2.93GHz

4x1GB DDR2

No Additional Card, using onboard Video Controller

BIOS Version: A13


Link to comment
Share on other sites

in bios see if you have the sata option of ahci


SATA is on AHCI.


When I made the myHack USB Drive, I didn't put the MBR Patch and when I use the DiskUtility to create my MAC OS Extended Partition, it create a GUID Partition Table.


I think the Optiplex 760 can't boot on GPT so I try to recreate the MyHack USB Drive and select Yes to Patch for MBR.

I reuse the DiskUtility to create a MBR with a single MAC OS Extended Partiton.


But this time, just after selecting the language, I have the following error:

"The OS X installation couldn't be completed"


The only difference is this MBR Patch I think.

Do I absolutely need this patch to install on a Dell Optiplex 760 ?

Link to comment
Share on other sites

I tried to remake a myHack USB Drive without the MBR Patch and with this one the install go to the select destination drive menu.

So the "The OS X installation couldn't be completed" error come only with MBR Patch.


Should the Optiplex 760 boot to a GPT disk ?


I also try to update my BIOS, now it's version A16, but still no boot on the SATA Drive if the partition is GPT.

Link to comment
Share on other sites

Did you format your HDD as "Mac OS X Extended (journaled)" ?


Yes I did format my HDD as Mac OS X Entended journaled.


But I'm still not sure if the Optiplex 760 can boot to a GPT style disk or if I need a MBR style disk.

Link to comment
Share on other sites

Try this guide.


Thanks, I tried this guide before using myHack but It didn't boot, so I tried with myHack.


I'm a bit further yet, I started again to install with MBR patch, but this time, I made a myHack drive without the patch and I applied the patch from this source:



The install went fine on a MBR disk with a Mac OS Extended (journaled) partition, but after the install, the PC don't boot to the HDD.


If I boot to the USB Drive and then select to boot on HDD hd(1,1), the gray screen with Apple Logo is comming but it stay like that.

If I add -x -v to the boot options, it works 8-)


So now, how can I make it to boot on the hdd without booting on myHack stick first ?

Link to comment
Share on other sites

So now, how can I make it to boot on the hdd without booting on myHack stick first ?


I've found myself, something went wrong during the installation of Chameleon.

I installed it again and now I can boot from the hdd.


Thanks for the help

Link to comment
Share on other sites

  • Create New...