Jump to content

Vostro 200 Cannot Install


pongc
 Share

Recommended Posts

Hi All- After my failed attempt to setup my Dell D620- I am trying this again with a Vostro 200 (Slim)

 

Problem: Cannot perform initial install

 

Specs

- BIOS 1.0.16 (unmodified)

- Intel core 2 Duo E4500 /2.2 Ghz

- 4Gb RAM

- 80Gb Drive (Configured as RAID in BIOS)

- NVIDIA GeForce GT 610 / 2Gb

post-52979-0-43665900-1400337137_thumb.jpg

post-52979-0-23689600-1400337170_thumb.jpg

- Monitor connected via HDMI port

 

Steps taken

1. Configured BIOS per https://osxlatitude.com/index.php?/topic/2143-bios-settings-vostro-200/. Note that there were many settings listed which I did not see so I skipped them.

2. Built USB startup using myHack 3.3.1 / Maverick 10.9.3. The OS image was retrieved from a VMWare image under "/Application/Install OS X Mavericks.app" after requesting upgrade via apple app store. I had to partition the USB as MBR since the vostro 200 did not seem to boot with GUID.

3. Extracted "Vostro200ST_ML-Mav_bootback.zip" from post #9 in https://osxlatitude.com/index.php?app=core&module=attach&section=attach&attach_id=3617 as "Extra2" folder on the install media

4. Ran myhack and ran "install extra" on the installer USB stick and pointed at the extra2 folder as source

5. Tried to install with no startup options, get ablank screen after selecting the installer (see logo/spinning wheel, then monitor changes to "no signal", system is still on so lead me to think resolution issue)

6. Tried to install with GraphicsEnabler=No, same thing

7. Tried with GraphicsEnabler=No -v -x, same thing. Below is the last messages before the screen goes blank

post-52979-0-01340100-1400337216_thumb.jpg

8. Swapped out the video card with a Radeon HD 5450/1Gb. Now I get to the installation screen to select language

9. After selecting language- I get message that "OSX install cannot be completed" and the install log is displayed

post-52979-0-28828100-1400337080_thumb.jpg

 

My next step is to maybe try the custom BIOS, though the thread indicated this was not mandatory..

Any help would be appreciated!

 

Link to comment
Share on other sites

  • Administrators

The BIOS thread shows 2 sets of settings: 1 for the modded BIOS and 1 for the standard BIOS below (both v1.0.16), check it out again.

 

After you got to the installation screen, did you go to Tools->Disk Utility to partition your target HDD in GUID and format it "OS X Extended (Journaled)" before proceeding with installation? That is required, unless you opt for MBR partitioning in which case you need your USB installer to be built with the MBR patch.

 

Please note that I can vouch for the guide with a myHack USB installer created under a Hack or a Mac, not under Virtual Machines. These are often found to be problematic for some reason. The Vostro200 should not have any problem booting the myHack USB installer created on a GUID/GPT partition; in fact I've never used myHack installer any other way (i.e. on an MBR disk)... I guess Chameleon was probably not installed on it properly or the VM caused something to go wrong. Or it's the USB key itelf (I've had a 32Go USB key once that simply would not work when attempting GPT on it).

Link to comment
Share on other sites

Thanks for the quick reply.

 

Matched my BIOS with the standard set. Everything matched except for Advanced BIOS Features > Virtual. Technology which did not exist.

 

Yes I did create a single partition using disk utility formatted as OSX extended. I tried both partitioning it as MBR and GUID but neither helped (still get install failed error after selecting language). Being that the error comes up before the prompt for target partition it may not be related.

 

Using my VM, if I build a boot using GUID partition, the USB stick does boot up on the Dell D430, but would not on the vostro 200, which would only boot if I change partitioning scheme to MBR. Unfortunately I cannot test the theory to create the USB stick on a real mac/physical hackintosh as I dont have one so its kind of a catch-22.

Link to comment
Share on other sites

  • Administrators

Well, I'd say your USB installer is duff. If all you have is a VM at the moment, maybe you should try ModCD + retail SL as a temporary (basic) OS X installation on your D430 and make a proper myHack USB installer from that.

Link to comment
Share on other sites

  • Administrators

if your using myhack mbrpatch then that is what is causing the installer to get stuck at language selection most probably. make the installer without that option. but you will have to then install with guid partitioning. or google for an mbr patch and apply that instead.

Link to comment
Share on other sites

Update- bought a different make/model USB stick- that seems have solved the issue of needing MBR. (Sandisk Cruzer 8Gb(good) vs Centon Datastick 64g(only boot via MBR, however boots fine via GUID on a Dell D430))

 

1. Built myHack 3.3.1 with 10.9.3 and bootpack on EDP page

2. Installed OS/applied same bootpack as step 1

3. After OS install/reboot, the logo stayed stuck on screen.

4. Booted up with -v, got stuck after message "considerREbuildOfPrelinkedKernel prebuild rebuild has expired"

post-52979-0-00053100-1400722031_thumb.jpg

5. rebooted with -x -v, got to initial setup screen

6. Completed install process,

7. Rebooted with -v, got stuck after message  "Waiting for DSMOS"

post-52979-0-26959800-1400723966_thumb.jpg

8. Rebooted with USB, applied bootpack from post 9

9. Rebooted with -v, went a bit further, but finally displayed "Resetting IOCatalogue". There does not seem to be any errors immediately before, outside the SMC related ones earlier..

post-52979-0-74240000-1400724376_thumb.jpg

 

I may try to start from scratch and install with the post 9 bootpack. Any other suggestions?

Link to comment
Share on other sites

  • Administrators

Yes, the bootpack for Mavericks is the one in post #9 of the guide.
 
The bootpack from the compatibility chart/bootpack page is the old initial one that derived from my very 1st Snow Leopard installation. It still has kexts for ATI X1300 graphics and the outdated DSDT. It's not good for Lion, Mountain Lion or Mavericks. This needs to be revisited, sorry...

Link to comment
Share on other sites

Update -

 

Re-attempted from scratch using post#9 bootpack - getting stuck at same point where login window would not come up. Last message is "considerREbuildOfPrelinkedKernel prebuild rebuild has expired". System boots up fine if I use -x.

 

I also tried a 10.9 image instead of 10.9.3- This seems to have resolved the issue where the screen would blank out when the nvidia card was used, however post install/initial setup, it would still get stuck with the same "considerREbuildOfPrelinkedKernel prebuild rebuild has expired" message. if I use -x it boots up fine.

 

Does the instructions In post #2 still apply with the new bootpack? For step 3 - Attempting to apply the generic extra did not work as it resulted in a kernel panic.

Link to comment
Share on other sites

  • Administrators

You got me to doubt my own published pack so I tried a new installation of 10.9.2 on a USB external HDD. I made a USB installer on a 16Go SanDisk Cruzer with myHack v3.3.1 and created the Extra folder using the ML-Mav pack. That's all.

 

I installed Mavericks on a USB external disk with a GUID/GPT partition formatted Mac OS Extended (Journaled). At the end of the installation, I pointed to the Extra folder at the root of the myHack USB installer when prompted for the Extra folder (selecting my own, not generic) and removed all suggested kexts.

 

On reboot, I had a complete working 10.9.2 installation with nothing to add except stuff not supported by the pack (such as my wireless dongle for instance). No boot option or flag required.

 

I guess you're either doing something wrong or your Mavericks/myHack downloads are possibly corrupt.

 

If you can boot in safe mode (-x), do that, the open up Terminal and type myfix -qt /. That should rebuild kext cache and reboot.

Link to comment
Share on other sites

 Share

×
×
  • Create New...