Jump to content

Can't get Yosemite to install... help please?


KingPrawn
 Share

Recommended Posts

I've followed Herves guide here for the 630: https://osxlatitude.com/index.php?/topic/6731-d630-nvidia-yosemite/

Also these:

http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?do=findComment&comment=2019584

http://www.hackintoshosx.com/topic/21313-guide-yosemite-1010-usb-bootable-installerupdated/

 

I've used Herves 630 plist. and default plists. I've tried kexts for the 630 10.10, 830 10.9 and 10.10. and different DSDT's or none. copied the kernels etc.

 

I'm not sure what's going on. Any clover install I try doesn't even boot from the USB. it just has a blinking cursor and the flash drive light just blinks. Which is weird because its default is a slow pulse when inactive.

 

Chameleon sometimes gets to the install screen but then it stops. I've never gotten 10.10 to install yet. I've got 10.8 working fine on the 830 and 10.7.2 on a DC7900 which I'm  using to make the installers. I've also run the gamut of boot flags with any installer that would somewhat work. I was also getting halts at random times while watching it in verbose. If I would reboot it might stop somewhere else. Strange.

 

What could be wrong with clover that it wont even boot? I've followed the guides to the letter several times.

 

Thoughts?

 

Link to comment
Share on other sites

I got it installed! I used a combination of Herve's method (and tips from a few more guides) with Clover and then a Chameleon on top to actually make it boot.

 

I didn't get to check everything yet because I already broke it trying to install multifail so I could get it to boot from the HDD. Now it just hangs at the progress bar forever. It's all good though. I'm making progress. Reinstalling again.

Link to comment
Share on other sites

  • Administrators

There really is no need to use the multicrap/unicrap tools. It's proof enough that you broke your installation trying to install such tools.

 

  1. You create your USB installer using the provided Terminal commands. This is the manual process to create a standard OS X USB installer.
  2. You install Chameleon (v2.3 r2401 recommended) on your USB installer.
  3. You copy the kernel to /System/Library/Kernels under filename "kernel" on your USB installer
  4. You copy your Mavericks or ML bootpack to /Extra folder on your USB installer in order to get DSDT + boot plist + SMBIOS plist (Chameleon will look for these files in /Extra)
  5. You copy the kexts found in /Extra/Extensions to /Systems/Library/Extensions of your USB installer and adjust permissions so that they're taken into account (kexts in /E/E will not all be loaded)
  6. You boot your USB installer and install Yosemite on your targeted HDD partition
  7. You copy the /Extra folder of your USB installer to your freshly made Yosemite installation
  8. You install Chameleon (r2401) to your freshly made Yosemite installation
  9. You can then proceed with 1st boot of your freshly made Yosemite installation

 

Any subsequent kext modification on your Yosemite installation will absolutely require that you rebuild the cache with the following Terminal commands. Failing to do so may render your Yosemite installation unbootable and you will not be able boot without cache (i.e. -f boot flag).

sudo chmod -R 755 /System/Library/Extensions

sudo chown -R 0:0 /System/Library/Extensions

sudo touch /System/Library/Extensions

sudo kextcache -Boot -U /

 

All this is more or less what myHack/myFix does discretely behind the scene, the specifics of myHack.kext being excluded of course.

  • Like 2
Link to comment
Share on other sites

Thanks. I'll give it a shot. I did get it installed but booting is unreliable. Black screens etc. When it works it works really well, though. I'm going to rebuild the installer using your guidelines and try a different install. I had to do the 4k fix on my cloned drive, but I think I read that it's included with Clover.

 

Wish me luck and thanks for the help. I really love my 830 and didn't really want to go with a probook.

Link to comment
Share on other sites

Hi Herve

 

This is a very good summary and a great work as usual

 

In 3. above You copy kernel to System/---------

 

Could you please clarify the location and file that has to be copied to System/Library/Kernels under the file name kernel

 

Also if one can use the most current version of chameleon boot loader

 

Thanks

Link to comment
Share on other sites

Great thanks for the link excellent work so many to chose from

 

I wish I had read this earlier I was lazy in asking so I used the latest version of Pacifist to extract it from the Essential systemsoftware.pkg 

 

 

Also with the D630 NVidia bootpack link being down could please send me a link with Bootpack  for Yosemite chameleon installer support.

 

I would be grateful for any Heads Up as well such as complete supporting files that you have used for the recommended version. stable r2468.

 

My D630 test bed is currently running stable Maverick on Bios A19, [email protected] with 4GB DDR2 and nVidia Quadro NVS 135M with Yosemite OS X installation media from Apple Store

 

Thanks

Link to comment
Share on other sites

Sorry  and hope you don't really mind I am using D830 section to talk about D630 (cross platform) but I hope this may equally help someone 

 

I am typing this from the D630 test bed with Yosemite just install I have tried the vanilla kernel link and is quite amazing and light relatively to the one I extracted

 
Sorry I should have read a bit more from the forum but I have been absent for a long  time and now getting back on I 
 
I need to get the video and sound in the absent of the bootpack and EDP  Any heads up  would be good for my subsequent chameleon base HACKS
 
Thanks 
Link to comment
Share on other sites

 Share

×
×
  • Create New...