Jump to content

D630 Intel Snow Leopard - No sound, mouse, keyboard, video


pseudomaniac
 Share

Recommended Posts

Greetings. Great to find this forum!

 

15 year IT pro here, so hope to be able to contribute some, but relatively new to the underpinnings of the Mac OS. Speak Windows/UNIX/Linux very well though, so maybe someone can help translate. :)

 

I have A D630/2.2 Core2/4GB/72GB SSD/Intel X3100.

 

Used the SLD430USB image to build a bootable USB, and had to do the install with -x, because it would KP otherwise, but the install took.

 

After the install completed, I ran Chameleon RC5 on the local SSD, and then ran the EDP 2.1. On the inital boot, keyboard and touchpad work fine. After EDP runs, and it doesnt seem to matter what I choose, the local key and touchpad are non-existent. USB based keybaord and mouse work fine.

 

Even booting in -X, I get no local key and mouse.

 

I have 1024x768 graphics. It's the funky Dell 1400x whatever widescreen resolution that I need to add.

 

I have no audio.

 

Wireless is working

Bluetooth is working

 

I don't believe local LAN works.

 

USB works

Optical works

 

I am trying to understand the order/operations/file set/permissions adjustments/what files to use in order to:

 

1. Get my resolution working and have it boot properly. I tried another file I found and ended up with a funky display on a previous build attempt. Had to rebuild and start over.

2. Get my audio working.

3. Get my local NIC working

4. Get my onboard keyboard and touchpad working.

 

I understand there are kexts and DSDTs and AMLs and all this, but I don't know how they correlate to what pieces yet. I'm savvy to the logic, I just need the breakdown, and some pointers on what will work with D630.

 

I tried several guides to get Lion on the D630 initially, and none of the boot install environments were ever stable for more than a few minutes, but even then, unpredictable. Has anyone succeeded in upgrading a Snow Leopard working D630 to a Lion D630.

 

I own a 17" MacBook Pro that shipped with SL, and have since purchased Lion to update. I have install media LEGALLY obtained for both because of this.

 

I have a Windows Virtual Machine for XP and 7 I can work out of as well.

 

Thanks for any help you can offer. Hope to return the favors and will document my progress.

Link to comment
Share on other sites

Thanks for the clarifier.

 

I did a fresh install from the USB image, then ran Chameleon RC5 against my local drive, and then ran EDP 1.91 and chose the Option1 for Apple PS2 driver, but keyboard and mouse still don't work.

 

The thing that sucks, is they work fine on the initial boot. I KNOW they can work - but the EDP breaks them.

 

In the EDP if you make no choice there, will it retain the current setting?

 

How do you revert to the original key/mouse driver that was used @ boot?

 

I can hook up externals and they work fine.

 

Thank you again.

Link to comment
Share on other sites

The other thing I keep hitting a wall on is the display comes up after installing the SLIC packages, and it's like the screen is cross sliced incorrectly. An external monitor hooks up and works fine as a second display, but the onboard laptop display has a black bar running down the middle and is kind of visible in spots, but very very hard to make anything out with. I can get to the display panel and change the resolutions to no avail, and even booting -x it still works this way. I assume that means something has loaded a bad driver for the screen or the card, but odd that an external display works?

Link to comment
Share on other sites

Okay, no luck with doing anything 10.7. It KP's out of the gate no matter what I try.

 

With the SLD430USB image I can boot in -x to Snow Leopard Installer.

 

I can install Snow Leopard.

 

I can boot back to the USB, and boot -x from the hard drive.

 

Boots, works, stable. Detects CPU properly, RAM properly, bluteooth properly. Not sluggish - pretty snappy.

 

Keyboard, touchpad both work.

 

I put EDP 1.9.1 on it and do all the fixes, and then run the KEXT update with the Apple PS2 for the D630, using apple power management, and no additional speedstep or audio.

 

I have not installed Chameleon at this point.

 

I reboot to the USB, still have to boot to -x mode on the hard drive.

 

After reboot, I have NIC, and Wireless 1375.

 

No audio. Audio is kind of detected (push the volume hard keys on the laptop and you get the mac onscreen audio dialog - the system knows it's Intel HDA, but won't use it)

 

No true video. Video is kind of detected (the system sees the X3100 @ 1024x768x32, but is not using any kexts.

 

All I need are audio, video, and a stable boot for this to be working on Snow Leopard.

 

I have NOT installed Chameleon from the EDP yet.

 

 

I'm trying to find the proper STAC9205 / Intel HDA kext files to install and fix my audio/video.

 

When I boot -v, I see it griping about X3100 v 1.71 being loaded already so it won't load v2.0 in a few places.

 

I believe the reason it won't boot anywhere but safe is that it is getting the ACPI_SMC_PLATFORMPLUGIN timed out error. At least that's the last thing it shows.

 

I understand there's a kext you can install to fix this, but so much conflicting info without full details....

 

HELP! Lol.

 

I don't want to poke on it anymore - tired of 45 minute reinstalls to correct the damage.

 

Thanks for the great forum.

 

I'll try to write up a revised DIY for the D630 Intel Noob once this is figured out.

 

If there are any patches I should avoid, please lmk also?

 

Thanks!

Link to comment
Share on other sites

Did you ever get your onboard keyboard to work? I have a D630 with Intel graphics running 10.6.3. I can not get my keyboard to work either. Trackpad works somewhat. Audios also works. I used EDP 1.9.2. I am thinking of downgrading to earlier EDP but not sure if that will muck it up worse.

Link to comment
Share on other sites

 Share

×
×
  • Create New...