Jump to content

D630 with Intel Graphics Kernel Panic on install boot?


TechieJustin
 Share

Recommended Posts

comparing the 2 d630's i find the nvidia to have a brighter screen. Also only the intel has a brightness slider. Which one should i keep for me ,the other is for my son.and the d620 my daughter now has. My son took the nvidia d630....

Link to comment
Share on other sites

So you have a resolution of 1440x900? Have you tried the dsdt ive posted?

 

If not, this version is especially for this resolution so goto post 20 download the dsdt.

 

Copy it to your USB-drive into the Extra folder - replace existing one.

 

Retry with this DSDT. If it works install Snow again - run EDP and befor reboot replace dsdt in your HDD root/Extra

 

 

Whoops, I missed your post, I didn't realize it applied to me as well.

 

It worked! Thanks!

 

I still don't have sound though.

provolonesiculo got his sound working by using EDP 1.9.2. I'll download the bets and see if it works,.

 

I have a new wireless card on order from eBay ($3.50) Broadcom unit that should work under OSX. In the meantime I'll run all the updated using the ethernet.

Link to comment
Share on other sites

I tried rebranding the Broadcom 1390 - here is what happens...

 

SSB_SPROM=$(find /sys/devices -name ssb_sprom)

echo $SSB_SPROM

cd ~

sudo cat $SSB_SPROM > ssb_sprom_copy

ssb-sprom -i ssb_sprom_copy -P

ssb-sprom -i ssb_sprom_copy –subv <NEW VENDOR ID> –subp <NEW PRODUCT ID> -o new_ssb_sprom_copy

 

Could not open --infile new_ssb_sprom_copy

 

for some reason new_ssb_sprom_copy is not being made. I'm guessing there's a mistake somewhere, but I don't know where...

Link to comment
Share on other sites

OK guys,

if I boot with -V flag screen remain black... :) but :) if I connect external display and switch with fn+f8 to external display I can read error:

 

ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized

 

What we must do now? :)

 

Sorry to bump this up...i honestly tried not to get to this point :D

 

So anyways, i've got Osx installed on my D630 (intel graphics). Osx will boot ok, the only problem is i've lost the mousepad/keyboard. I can plug in a usb keyboard and mouse and they will work.

 

I ran a -v and caught the same above error just before it went to the home screen.

 

'ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized'

 

 

Edit: keyboard and mouse no longer working in Safe boot.

 

-Osx SL installed from USB image

-Chameleon 2.0 RC5 r665

-EDP 1.9.1

 

If anyone can be of assistance that would be great!

Link to comment
Share on other sites

LIke to bump in as well, same issue for me...

https://osxlatitude.com/index.php?/topic/803-newbee-try-to-install-on-d630/

 

 

 

When i boot it will end here, see attached screenshot, lpcdriver failed - C-state power management not initialized.

 

Intel® ICH8/ICH8R Family LPC Interface Controller, in normal mode the boot stuck on this controller - so i cant go on, it is a part f the chipset!So what i need is a expert on DSDT / SSDT hacking!

 

read this, the solution?

http://www.osx86.net/general-discussion/6618-full-working-powermanagement-native-appleintelcpupm-kext.html

 

How to

http://ipis-osx.wikidot.com/forum/t-178392

 

Sorry guys this is to much for me I'm a Noobe... able to install but on this level i do not have any idea...Went back to previous Dell bios roms for test and after all a black screen, that is where i start.

--------------------------------------------------------------

 

So in the meanwhile, i'm lucky to have the whole Dell D series line available, i completed successfully and update to 10.6.8 my Dell D620 - OSX gma bios, Intel core duo processor 1.83 GHz, Intel 945GM..

Link to comment
Share on other sites

c-states error is normal for older dell laptops.... you might have other issues.... your sata might be set to ide instead of ahci.... your catches might be corrupted, or edp was not installed correctly.

 

 

On a D430 and a D620 i get it all working with the same USB pen! EDP 1.9.1

 

With the D630 I'm not even able to setup / start with installation normal? have to run in -x mode... otherwise my screen will turn after a few seconds into black. after the first installation i have to boot in order to install EDP, but it stuck / hangs on what i describe...

Link to comment
Share on other sites

 Share

×
×
  • Create New...