Jump to content

E6400 OS X 10.11 DP Installation


krzysztofc10
 Share

Recommended Posts

Hello! 

I'm trying to reach the installation of OS X 10.11 DP. But I'm ending on Still waiting for root device and error occured.

 

My laptop Specs:

 

Intel Core 2 Duo 2,8Ghz, 6MB Cache
4Gb DDR2 800MHz
160GB HDD
Nvidia Quadro NVS 160m 256mb
Display 1440x900 res
Dell Wirelles 1510 card

 

I format my pendrive to GUID OSX Journaled. Then restore basesystem.dmg. Delete Package alias in the System/Installation and replace with  the Packages folder. Copy Payload and Basesystem.chunklist to root of my bootable USB. Install Clover Clover_v2.3k_SpecialEdition from InsanelyMac and copy my board id folder to /EFI/CLOVER/OEM. Then Im trying to boot osx but it gives me the error "Still waiting for root device" and screen flicker. Any suggestions ? I tried to run it with only fakesmc but the same error. 

0X574R.zip

post-5519-0-92145100-1433844954_thumb.jpg

post-5519-0-10082800-1433844958_thumb.jpg

Link to comment
Share on other sites

  • Administrators

El Capitan DP was only released last night. Give people a little more time before asking for support. No-one's probably even had time to work out a validated installation procedure...

Link to comment
Share on other sites

Creating an OS X 10.11 El Capitan Beta 1 USB Install is verbatim identical to Yosemite save the one extra step: copying over the "Payloads" folder along with the invisible BaseSystem.dmg & BaseSystem.chunklist files...thats it.   Not very encouraged with the E6400 and OS X 10.11 as I mentioned on my Yosemite guides, I figured out Yosemite right from the get go and it was relatively straight forward.    This is not making much sense as I have gotten Clover v r3215 to boot this release on my Mac Pro 2,1 which also requires a legacy boot.   I would say it is the Nvidia Quatro NVS 160M though any graphic card capable of running Yosemite is also supposed to be compatible with El Capitan.

 

 

 

 

 

 

 

Link to comment
Share on other sites

Decided to ditch creating the installer and instead installed OS X El Capitan Beta 1 on a real mac.   Installed Clover via the exact same method (in the "ESP") in the EFI partition using all same kexts as Yosemite (EXCEPT upgrading the FakeSMC.kext to the very latest).   Used the same config.plist as well and doing it this way presented no issues whatsoever.

 

post-56137-0-91572300-1434082077_thumb.jpg

 

Link to comment
Share on other sites

Hello! 

I'm trying to reach the installation of OS X 10.11 DP. But I'm ending on Still waiting for root device and error occured.

 

My laptop Specs:

 

Intel Core 2 Duo 2,8Ghz, 6MB Cache

4Gb DDR2 800MHz

160GB HDD

Nvidia Quadro NVS 160m 256mb

Display 1440x900 res

Dell Wirelles 1510 card

 

I format my pendrive to GUID OSX Journaled. Then restore basesystem.dmg. Delete Package alias in the System/Installation and replace with  the Packages folder. Copy Payload and Basesystem.chunklist to root of my bootable USB. Install Clover Clover_v2.3k_SpecialEdition from InsanelyMac and copy my board id folder to /EFI/CLOVER/OEM. Then Im trying to boot osx but it gives me the error "Still waiting for root device" and screen flicker. Any suggestions ? I tried to run it with only fakesmc but the same error. 

Copy your "kext/10.10" folder and rename it to "10.11", or copy the files to "other" folder, then edit your dsdt, search for EHCI and replace wit EHC1

  • Like 3
Link to comment
Share on other sites

This is the working solution.  The panic/circle with a line in the middle was occurring due to the fact that the USB Installer was losing its connection as the E6400 has no working USB ports in OS X 10.11 El Capitan without making this edit in your dsdt.aml. Once the edit is made, the Installer will boot and the E6400 works just as well in El Capitan as it does in Yosemite.
 
PS. Renaming the Kext folder is unnecessary and using Clover v2.3 r3215 is sufficient also.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...