Jump to content

Latitude E6500 El Capitan no sound


Recommended Posts

Hey guys, another slight issue I've come across, and I'm wondering what I can do.

I got back on the OS X train about a week ago, and I've gotten El Capitan running on my E6500. However, I have no sound for the thing. I'm using VoodooHDA for the sound, and I do have the disableapplehda kext or whatever it is in my 10.11 folder for Clover.

Clover is completely up to date, and so is El Capitan (10.11.3)

OS X doesn't recognize any audio devices (except my AppleTV), and neither does the VoodooHDA settings panel.

I've tried the latest version of VoodooHDA - 2.8.8, and I've also tried using 2.8.4 as I've read elsewhere. No dice.

If anyone has any ideas or input, that would be greatly appreciated! 

Link to comment
Share on other sites

  • Replies 25
  • Created
  • Last Reply

Top Posters In This Topic

Okay, I did that and rebuilt my caches. Now whenever I try to boot my El Capitan, I get a kernel panic for com.apple.driver.usb.AppleUSBEHCIPCI

I had the USB_injection kext from here loaded and in my 10.11 folder for Clover. I tried deleting my cache, booting -f, and tried finding the kext in my /S/L/E folder, but no dice.

Let me know if I need to make a new thread for this problem.

Link to comment
Share on other sites

Oh, it worked before. Yeah, MBP 5,1. It was working until I rebuilt my kext cache with Kext Wizard. I didn't put it in /S/L/E, though. Should I drop it in there and rebuild?

I still have Yosemite and Mavericks on my backup drive to work with, so I'm not stuck with just Clover.


I've tried to boot without caches, remove the IOUSBFamily kext, rebuild permissions, delete the cache, replace the IOUSBFamily.kext from the recovery partition that El Capitan was so kind to put on my drive, and I can't even boot -s.


EDIT: Also, the USB_Injector is just something to change how the USBEHCIFamily kext maps the USB ports. It changes it to match my DSDT. It'll work on any system, as long as it's made for the proper DSDT usage for the system its installed on.


EDIT 2: I did check /L/E. Nothing there except for the VoodooHDA, AppleHDADisable, and the random kexts that Apple has in there.

Link to comment
Share on other sites

  • Administrators

Only compressed files can be attached.


kext-dev-mode and rootless are defunct/useless boot parameters with ElCapitan. You have to use the CsrActiveConfig parameter to disable SIP or none of your add-on kexts will load...

Link to comment
Share on other sites

Oh dear. I knew kext-dev-mode was dead, but I need it for Yosemite (different drive, same loader). I didn't know about CsrActiveConfig.

I edit the variables for Clover as BooterConfig 0x28 and CsrActiveConfig as 0x67, correct?


EDIT: If that is correct, the system still isn't booting. Same KP. Also, I didn't try a file upload, I hit the picture button and linked that imgur picture. It still wouldn't let me do that.

Thanks for your guys' help so far. I think I might just cut it and try with a re-image. I made a image of the disk when I installed and got it running, but I'd really rather not do that.

Link to comment
Share on other sites

  • Create New...