Jump to content

E6220 Herve's installer question


Recommended Posts

I just got a e6220 shipped with 32bit win7 pro. If you close the lid and reopen it, it crashes by default:) Although a driver and a firmware update solve the problem, I decide to switch to OS X. That's my purchase really for.


I followed Herve's instruction (thanks a lot Herve) creating the usb installer for EI Capitan 19.11.4, tried twice but didn't get a bootable usb drive. I didn't alter the bios of my E6220 but my old snow leopard (D430) installer can boot to the boot menu, so I'm not sure if there anything need to change in my bios setting.


I copped Enoch-rev.2795.pkg to the root dir of usb but not rename it, don't know if that's matter of not. In my iMac, this pkg cannot be open, says the developer is not recognized...


I did a fdisk check, the usb is active.


I put the kernel (10.11.4) to /System/Library/Kernels/


I copped Extra dir from E6220_i5-2520M_HD3000_EC-Pack.zip to the root dir of usb.


I don't know if the file/dir ownership matters or not.....


Don't know what to do/check, ....., Please help


Thanks in advance


=============== The contant of the USB ==========

HMac:OS X Base System elim$ ls -la

total 940408

drwxrwxr-t  24 elim  staff        884 Apr 11 16:30 .

[email protected]  6 root  admin        204 Apr 11 16:52 ..

[email protected]  1 elim  staff       8196 Apr 11 18:35 .DS_Store

drwx------   5 elim  staff        170 Apr 11 16:03 .Spotlight-V100

d-wx-wx-wt   2 elim  staff         68 Mar 12 00:46 .Trashes

drwx------   7 elim  staff        238 Apr 11 16:49 .fseventsd

drwxr-xr-x   2 elim  staff         68 Aug  1  2015 .vol

drwxrwxr-x+  4 elim  staff        136 Mar 12 00:44 Applications

[email protected]  1 elim  staff       1948 Apr 11 16:21 BaseSystem.chunklist

[email protected]  1 elim  staff  477579745 Apr 11 16:25 BaseSystem.dmg

[email protected]  1 elim  staff    3620763 Apr  9 19:48 Enoch-rev.2795.pkg

[email protected] 11 elim  staff        374 Apr  9 15:20 Extra

drwxr-xr-x   3 elim  staff        102 Mar 11 18:27 Install OS X El Capitan.app

drwxr-xr-x+ 11 elim  staff        374 Mar 12 00:44 Library

drwxr-xr-x+  5 elim  staff        170 Apr 11 16:47 System

drwxrwxrwt   2 elim  staff         68 Aug  1  2015 Volumes

drwxr-xr-x  35 elim  staff       1190 Mar 12 00:46 bin

dr-xr-xr-x   2 elim  staff         68 Feb 11 19:12 dev

lrwxr-xr-x   1 elim  staff         11 Mar 12 00:44 etc -> private/etc

drwxr-xr-x   5 elim  staff        170 Mar 12 00:44 private

drwxr-xr-x  57 elim  staff       1938 Mar 12 00:46 sbin

lrwxr-xr-x   1 elim  staff         11 Mar 12 00:44 tmp -> private/tmp

drwxr-xr-x   8 elim  staff        272 Mar 12 00:43 usr

lrwxr-xr-x   1 elim  staff         11 Mar 12 00:44 var -> private/var

Link to comment
Share on other sites

  • Administrators

I literally just posted revised packs in my thread with an updated DSDT. The revised 10.11 pack also includes Dr Hurt's VoodooPS2Controller which does not trigger KP on startup. Make sure to follow the guide rigorously.

Link to comment
Share on other sites

Thanks Herve, I replaced the extra folder in the usb drive with new one from E6220_i5-2520M_HD3000_EC-Pack_#2.zip. 


It still cannot boot for some reason. Below are some info about the usb, Does it look like a correctly created one? BTW, Enoch-rev.2795.pkg doesn't run on my 10.11.4 iMac.





Link to comment
Share on other sites

  • Administrators

It would seem you copied the Enoch installation package on your USB installer (that's for a future use once OS X is installed on your disk partition) but you did not install the bootloader on your USB installer ! It's never going to boot without that key step.


Ok, so your iMac reported the app could not run because from an unknown developper but you can't just ignore that message. On your iMac, go to your Security PrefPane and either authorise the app to run once or modify your security settings to allow downloaded app from anywhere.


Do think of calling on OS X built-in help if you encounter error messages that you don't fully understand. It's kinda basic...

Link to comment
Share on other sites

Thanks Herve identified the key problem. I boot my iMac to snow leopard partition, where Enoch-rev.2795.pkg runs but installing it to the usb failed. I then turned to my D430 lion, this time the pkg can be successfully installed to the usb installer.


I still copy the pkg to the root dir of the usb without rename it.


Now E6220 didn't report boot failure but keeps reboot. I don't get a change enter -f -v.


I changed my bios settings according to Herve's detailed guide. But no success.


Maybe I just need to type -f -v even if I don't see any screen output from the usb?

Link to comment
Share on other sites


I'm using similar instructions for setup.  I think you can edit the Kernel Flags settings to your benefit.

Showing a delta here.    I hope this helps you.


--- Extra/org.chameleon.Boot.plist    2016-04-10 07:56:44.000000000 -0400
+++ /Volumes/OS X Base System/Extra/org.chameleon.Boot.plist    2016-05-05 09:12:35.000000000 -0400
@@ -13,7 +13,7 @@
     <key>Kernel Flags</key>
-    <string>darkwake=0 rootless=0</string>
+    <string>rootless=0 -v -f</string>

Link to comment
Share on other sites

  • Administrators

I would discourage the permanent use of -f -v flags on any installation by adding those to the boot plist... I recommended sticking to the method of manually adding those flags at boot time as/if necessary.


rootless=0 is deprecated and not required these days; it certainly ain't present in the boot plist of my posted pack... The pack is meant as a definitive one, not just for USB installer purposes.

Link to comment
Share on other sites

Hi. Having some trouble with El Capitan installation on e6220 i5-2520M model.


I followed Herve's guide to create the USB installer and it seemed to finish correctly, but when I boot the e6220 from USB the boot starts normally, with the Apple logo, then the progress bar, which progresses to the end, BUT then stops there. The progress bar is full, but the boot stops at that point. I've left it for hours but it doesn't go past that point. 


I've tried 2 different USB drives so I don't think they are the problem. I've prepared the installer 4 different times, following Herve's guide. I've tried with both Enoch 2795 and the most recent one. Bios settings are the standard ones listed on the site. 


Any tips greatly appreciated. Thanks. 


P.S. I also tried Jake Lo's guide using Clover, but I couldn't get it to work either, just got KPs. 

Link to comment
Share on other sites

  • Administrators

Boot in verbose mode (-v flag) to try and grab where the boot process hangs. But if you have same hardware + same BIOS version + same BIOS settings, I'm failing to think of anything specific.

Link to comment
Share on other sites


  • Create New...