Jump to content
PayPal donations: [email protected] ×
taddeusz

macOS Sierra on E6420 HD3000

Recommended Posts

Upgraded my E6420 to Sierra. Got my BCM94352 working after some difficulties. For some reason Clover's FakeID is not working and had to switch to the FakeID kexts.

 

One of the problems I ran into while upgrading is that the VoodooPS2Controller.kext needed to be updated. Was getting a panic on it. That resulted in the touchpad ceasing to function. That and I need to figure out how to get the audio working again.

 

Other than the trackpad and audio I have a functioning system. Fortunately Bluetooth never stopped working and I have a Magic Mouse until I can get the trackpad working again.

Share this post


Link to post
Share on other sites

Just curious becauee I have the same computer, what did you upgrade from El Capital 10.11.6 ?   Or an earlier version.  Because I believe the audio issues stems back from 10.11.3 and there was a fix for that using AppleHDAIDT.kext    Hopefully some of the pros can shed some light on the upgrade soon.  

Share this post


Link to post
Share on other sites

I just downloaded it from the App Store and ran the install.

 

I discovered that I first had to install the latest Clover. I tried running the install but when it rebooted the Installer partition wasn't available for boot. After updating Clover it booted fine until I encountered the VoodooPS2 error. It went by so quick I had to take a picture with my phone to see what it said.

 

I did actually fix my audio problem. Previously I hadn't been able to get the Clover kext patches to work to fix audio so I was actually using a patched AppleHDA.kext. This time I seem to have found the right combination of patches. And there's also an additional patch that has to be applied for 10.12. Here are the patches I have, all are for AppleHDA:

 

8B19D411 => E7761D11

8419D411 => 00000000

8A19D411 => 00000000

 

And then install the DummyHDA.kext.

 

So now all I have to to is figure out how to get the touchpad working.

 

I found the only other caveats are that the volume and mute buttons are not yet working and the caps lock doesn't function reliably with the new VoodooPS2.

Share this post


Link to post
Share on other sites

Hmmm I'm just in the process of making a new usb with the latest clover.  I will probably try to upgrade tonight, since I already backed up my system and if things dont go well I'll just switch back.  Ok thanks for letting me know.  Ill post here if I get my system up and running.   I tried to upgrade once already yesterday but I realized something wrong with my usb and that maybe why it wasn't booting.

Share this post


Link to post
Share on other sites

the caps lock issue happens on my real mac you have to click it twice to turn off

as for trackpad i think there was an updated or alternate one to avoid KP's on this forum

Share this post


Link to post
Share on other sites

I've had some doubts about those above AppleHDA patches/patch combination because they've never worked on my E6220. Yet, it's fitted with IDT 92HD90 audio, i.e. the same as the other E6x20 models.

 

I don't use Clover so I patch my AppleHDA kext directly and here are the details of what I use for Sierra:

Find: 8B19D411
Replace by: 00000000 (2 occurrences)

Find: 8419D411
Replace by: E7761D11 (2 occurrences)

I cannot find any instance of 8319D411 in AppleHDA v276.26...

 

For those who want to try, here are the dummy HDA + pre-patched AppleHDA kexts.

AppleHDA_IDT92HD90.kext.zip Patched_Sierra_AppleHDA_v276.26.kext.zip

Share this post


Link to post
Share on other sites

Yeah, this is the first time I've ever gotten the Clover kext patches to work with AppleHDA on this system. Not sure why they're all of a sudden working. But They are. I only have the three patches I listed enabled. I have the 8319D411 in my config.plist but I have it disabled.

Share this post


Link to post
Share on other sites

Ok, finally able to get back to it. Downloaded that new VoodooPS2Controller.kext and the trackpad is working now.

 

Now if I can only get Tunnelblick to stop popping up it's preferences every time I boot up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...