Jump to content

Dell Latitude E6430S - it that 'S' important?


DaFrigN
 Share

Recommended Posts

Firstly I'd like to thank Leon and everybody here for creating this site!

A few years ago (4 or 5?) I bought a Latitude 630 (X3100 high-res) and it's been great, the casing has taken a severe beating and still keeps running perfectly, running 10.6.8 and 10.7.5.
Now that it's way past time to move on and I'm a bit out of touch with the current state of hackintosh-ing. I need to run at least 10.9.x now.
So after some research I got on eBay to buy a E6430 and new battery for it, but I mistakenly purchased an E6430S (battery doesn't fit!). I tried to follow guides for E6430 anyway since one would think they are relatively the same hardware. They do not seem to be.
I have bios A12, I have a choice of of Legacy BIOS or UEFI.

I have installed 10.9 and updated to 10.9.5

I was able to boot in safe mode at first, verified that the Camera works, the Atheros Wifi works (after Vendor / Device ID patching), I can not get the sound to work with AppleHDA patches (haven't tried VoodooHDA yet).

Most importantly I can not seem to get the Intel HD4000 (1366x768) to work properly! I've tried various versions of Chameleon with different IGP settings. I had it recognized at certain points, but it would severely glitch out on certain web pages.

I'd like to try different bios versions but I already wiped the Windows 7 install from the machine.

It's driving me mad!
 

Any advice would be much appreciated.

Thanks
-=D=-

Link to comment
Share on other sites

  • Administrators

It's obviously similar specs to the regular E6x30 Series. Afaik, the E6430s is an ultra-portable version (i.e. a little smaller) of the E6430. Why don't you post the /Extra folder you've used? With Chameleon or Enoch, I recommend you stick to legacy BIOS mode.

 

VGA won't work (no support for it under HD4000 graphics) but HDMI will with the usual Capri FrameBuffer patch.

 

HD4000 should work OOB as long as you inject the correct Capri FB #3/layout-id 0x01660003. This is usually done through DSDT patching of the iGPU device defined at address 0x00020000.

 

BIOS would normally display the exact type of audio chip fitted to the laptop. Look up in System Information page. On the E6x30 Series, it's usually IDT 92HD93 for which the AppleHDA patch details are fully known and available. You can easily double check the codec with DPCIManager app. Audio will be listed as Intel HDA (8086:1e20) with IDT 92HD93 codec (111d:76df). You'd normally inject audio layout-id 12, again through DSDT patching.

 

If your laptop runs the latest BIOS version, you'll probably have to revert to an older one to avoid graphics corruption with HD4000 like on the other E6x30 models. You do not need Windows for that, just make a bootable USB disk with UnetBootin from which you'll simply run the BIOS exec downloaded off Dell Web site. The downgrade process normally requires to 1st revert to the oldest possible version like A01/A02/A03 before upgrading to the last known version with which graphics are Ok (often A11 or A12).

 

If you can post your extracted/raw DSDT, we can certainly patch it for you.

  • Like 1
Link to comment
Share on other sites

Here's my un-patched DSDT
 

 

Here's screenshots of DPCIManager tabs
 

post-1717-0-70620200-1478983507_thumb.png
 
post-1717-0-71230800-1478983540_thumb.png

 

 

BIOS System Information:
Audio Controller = IDT 93HD93
and in case it helps also:
Processor Type = Intel®Coreâ„¢[email protected]
Core Count = 2
Prcessor ID = 306a9
Minimum Clock Speed 1.2 GHz
Video BIOS Version = 2158v12

 

Very grateful for help patching. I've never quite gotten the hang of DSDT edits.

Thank you!

E6430S_A12_DSDT.zip

 

Link to comment
Share on other sites

Also my Extras folder on my looks something like this (but I've been trying different mixes for trackpad, battery etc)

VoodooSDHC.kext.bak
AppleHDA.kext
ACPIBatteryManager.kext
VoodooPS2Controller.kext
AppleIntelFramebufferCapri.kext (not sure which guide I got this from but its 1366x768)
GenericUSBXHCI.kext
Patched_10.7_AppleRTC.kext
AppleIntelCPUPowerManagement.kext (having AppleCPUPower Panics now unless I boot with flags)
AppleIntelE1000e.kext
AppleKextExcludeList.kext
DisableTurboBoostBattery.kext
FakeSMC.kext
AppleSmartBatteryManager.kext
lspcidrv.kext
NullCPUPowerManagement.kext
AppleACPIPlatform.kext

Also the bootloader on my flash drive is currently: Chameleon 2.3svn r2538
Link to comment
Share on other sites

  • Administrators

  1. Remove the AppleACPIPlatform + VoodooSDHC kexts, they're not needed and will cause harm.
  2. If you use the patched AICPUPM kext, you can also put NullCPUPM aside (keep it somewhere but don't use it). 
  3. You should not need the GenericUSBXHCI kext for USB3.0. the USB3.0 port of my E6230 works OOB with the right DSDT settings.
  4. You should use only one battery manager, so you must choose between AppleSmartBatteryManager and ACPIBatteryManager. I recommend you use Dr Hurt's latest kext Release R4.
  5. Remove Patched_10.7_AppleRTC kext, it's obviously not applicable to Sierra. There a thread about this in the Support->Apple OS X folder.
  6. Patched AppleHDA.kext will only load from /S/L/E so...
Link to comment
Share on other sites

Just to post an update, I downgraded the bios to A11, I'm still trying to get 10.9.5 (my target OS) up and running on this thing, about to give up soon and go up to Yosemite or Sierra, I hate to give up now because I sort of had it several times but keep borking it up. I'm thinking I should try Clover (never used it before) in non-legacy UEFI mode, it seems a lot of people think it's better then other bootloaders.

Link to comment
Share on other sites

 Share

×
×
  • Create New...