Jump to content

Help with Dell Latitude E6430s on 10.12.1 Sierra


itjedi42
 Share

Recommended Posts

I have a Latitude 6430s that was working perfectly under 10.11.6. The only things not working are multitouch and audio under 10.12.1. 

 

The 10.11.4+ AppleHDA kext is in place in /L/E

Audio patches are 

AppleHDA 8B19D411. DF761D11. AppleHDA IDT

AppleHDA 8419D411. 00000000. AppleHDA IDT

AppleHDA 8319D411. 00000000. AppleHDA IDT

AppleHDA 9A19D411. 00000000. AppleHDA IDT

 

 

Couldn't boot with voodooPS2controller (was using the only that previously worked on 10.11.6). Removing it fixed boot, but killed keyboard and trackpad. Using ApplePS2 now. 

 

 

Using Clover r3922.

 

Thanks in advance. 

Was built under 10.11.6 using Jake Lo's guide here: https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-el-capitan-clover-guide/ updated using AppStore. 

post-99899-0-25618800-1479050307_thumb.jpg

post-99899-0-72975900-1479050335_thumb.png

Link to comment
Share on other sites

  • Administrators

Yup. Above patch is obsolete for Sierra and patched El Capitan AppleHDA will not work under Sierra. For VoodooPS2Controller, you're now supposed to use Dr Hurt's version; I recommend Release 4 on the E6xxx series and it's available in Dr Hurt's thread in R&D section or in my recent E6220/E6230 Sierra guides.

 

For audio, the correct AppleHDA patch for IDT 92HD93 is:

Find: 8419D411
Replace by: 00000000

Find: 8A19D411
Replace by: 00000000

Find: 8B19D411
Replace by: DF761D11

There are no instances of 8319D411 in Sierra's AppleHDA. The patched kext must go to /S/L/E; the IDT definition kext can go to /L/E. Repair permissions and rebuilt cache after your kexts modifications.

  • Like 1
Link to comment
Share on other sites

I believe I have also tried that voodoops2 kext with a similar KP issue.

 

Here is whats in my /EFI/CLOVER/Kexts/Other folder. Possible theres a conflict? and not necessarily the AppleHDA_IDT or VoodooPS2controller.kext causing it?

 

Edit: Ignore VoodooPS2controller.kext in screenshot, took the screenshot from the backup of EFI I took before upgrading to 10.12.1

post-99899-0-47354600-1479059098_thumb.png

Link to comment
Share on other sites

  • Administrators

You're gonna have to post a picture of your KP or tell us what it says...

 

If you use Clover, make sure to select AsusAICPUPM or you'll get KP on CPU power management. That's mandatory on all Sandy Bridge and Ivy Bridge laptops. If you re-use the Clover config.plist from a previous version, the existing set of binary patches may also be the source of the KP. It'd be a good idea to post your complete EFI folder.

Link to comment
Share on other sites

 Share

×
×
  • Create New...