Jump to content
dpw95

[FIXED] Help to install Sierra on E5520 with Legacy Clover

Recommended Posts

I am working with my first laptop that will not permit me to use Jake Lo's guide below:  

 

https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/

 

When using a USB staged for EFI boot, the BIOS on this unit is not able to navigate the EFI partition.  The directory structure displays with some odd looking characters, so it's not possible to navigate to the BOOTX64.EFI file.

 

So this will be my first go round with using Clover in Legacy mode.

 

I staged a Sierra USB installer using the createinstallmedia method, and then installed Clover to this USB drive.  I added the bootpack posted for Sierra/E5520 from the above guide. 

 

The installer will begin to boot, but it drops to a crossed-circle icon.  I tried verbose mode, but the text on the screen distorts to the point that I cannot view what the issue is.

 

Any advice for a different way to go about approaching a successful Sierra installation on an E5520?

Share this post


Link to post
Share on other sites

I recorded a video of the boot installation boot attempt.  Here is the last frame that's legible before the screen glitches out and the process halts.

post-85038-0-42156500-1499562654_thumb.png

Share this post


Link to post
Share on other sites

I had noted in the guide that UEFI won't work easily, so use Legacy instead for the Exx20 models.

 

:excl: Note1:  

For Exx20 (SandyBridge models), use Legacy - GUID Scheme. Not UEFI

Install Clover with the following settings in 1: Prepare Bootable USB Drive step 26 above:

  • Install Clover in the ESP
  • Bootloader/Install boot0af in MBR
  • CloverEFI/CloverEFI 64-bits SATA

 

 

From your description, it sounded like it's an USB issue. Make sure you copied the bootpack, files into the Clover folder and not into the EFI folder. The bootpack should have the USB injector that fixes this issue.

Share this post


Link to post
Share on other sites

UEFI booting on machines with problematic bios boot entries.

 

 if clovers built in EFI shell option works on your machine you can try the code in the code boxes below.

if clovers shell does not work then you can use a bootable copy of EFI shell like whats used for fixing DVMT allocation. and use the code below.

 

the EFI Shell command is

bcfg boot add 3 fs0:\EFI\BOOT\bootx64.efi “Clover”

  You must then type 

bcfg boot mv 3 0

This second bcfg command moves your new entry to the top of the boot list

3 being the clover entry you just made and 0 is destination 

 

if you can confirm this works for your model then I am sure Jake will add it to the guide

I use it on a machine that does not even allow a boot entry in bios menu. like many locked down OEM machines my bios boot path is hardcoded to only boot windows so installing clover can be a bit of a pain. need to rename windows efi binary and such.

Share this post


Link to post
Share on other sites

Thanks Jake and Bronxtech....

 

Jake:  I tried altering the approach as mentioned, but I am still not making it past the installation boot attempt.  I'll post an update shortly on where this is falling off.

Share this post


Link to post
Share on other sites

Other odds and ends tried:

 

- updated my BIOS to A14

- reset BIOS to defaults & then verified SATA mode for AHCI

- after staging my USB drive for CLOVER Legacy booting as called out in Jake's guide, I went to its EFI partition, deleted the EFI folder there, and replaced that with the contents of EFI_4077.zip file from Jake's guide and then added the contents of the E5520_A14.zip file to the CLOVER folder that was extracted from the EFI_4077.zip file

- tried booting with every USB port that the system has

- tried booting with both CONFIG.plist files that are offered as part of the E5520_A14.zip file

 

To recap:

- I can boot from the USB drive to the CLOVER boot loader

- Choosing to boot to the OS X Sierra Installation boot choice results in the crash posted in the screenshot above

 

Should I try a different boot pack, perhaps?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×