Jump to content

Dell Latitude E6520 nVidia - High Sierra Install Issues


Recommended Posts

So this time around using the terminal to install HS for HFS+ executed without any error though I still get 'OSInstall.mpkg not found' as the result.


Been trying a bunch of other methods and started from scratch again though no luck.

Changed SMBIOS again to a MBP 10,1,reset BIOS time which was 2 minutes ahead



Going to try a different HDD for the sake of it and check if downgrading BIOS to A19 is possible.


Since we've ruled out the EFI folder, I'm not sure what could be the issue hardware-wise.

Link to comment
Share on other sites

I'm trying to download the package again, that's 10.13.4 from the app store.

When I launch the installer and need to select the drive, all drives are greyed out (flash drive, current VM hard disk, other HDD) as I hover over any I get the message 'You may not install to this volume because the computer is missing a firmware partition'. WTF


This is a Sierra VM that installed the macOS installer version 13.3.01 just fine.


Attempted a High Sierra VM and that allowed the installer to start fine.

Link to comment
Share on other sites

So I'm STILL struggling to hackintosh my E6520 in this OP.


I've re-downloaded HS as the last suggestion for me and that also didn't help resolve my issues.

Also lost the last EFI folder setup that got my into the installer and completed an installation and haven't been able to replicate it.

Haven't got anywhere using clover for either legacy or UEFI boot.



On the E6520 I went back to a distro and I'm able to boot to the installer though when installing to a HDD, I get an 'assertion failed' error at almost 90% of the installation then the pc reboots.

I've cleaned up my folders in EFI as well as the kexts, also verified that I've got the latest HFSplus.efi files.


When I get back to clover using the same flash drive, I only see the installer and disk utility shows that HDD has approximately 9GB used space out of 1TB.


I've attached the current efi\clover folder now used on the Latitude E6520 and would appreciate it if someone could take a look at it (E6520, i7-2620M Sandy Bridge, Intel HD 3000, NVidia NVS 4200M). I'm sure there will still be a lot of things wrong with it and with the config.plist as well. Still can't wrap my mind around all the different configurations required for the Hackintosh.


Running HS in a VM is still not very performance efficient.



Link to comment
Share on other sites

Holy .... Just switched that config.plist file and I was able to boot into HS. 


I used UEFI boot to install the disk though there was no boot option when going back to the Clover when booting using UEFI.

Using Legacy boot it it boots directly into HS.


Thanks so much for looking into it.


Trying to put together necessary kexts to run normally and will try to boot with a non-distro.

Link to comment
Share on other sites

  • Moderators

all the kexts in /E/C/k/Other should be enough, remember to install kexts from /E/C/k/Other/LE to /Library/Extensions

Repair permission and rebuild cache.


The Clover as is right now can be use on non-Distro

Link to comment
Share on other sites

To get back to E6520 installation issues on High Sierra,


I had the setup working and backed up the working clover config at that time (attached, I believe this is the combined folders of the base clover+  E6520_Optimus_A19.zip from the Guide. I am on A20 and HS which are the differences though previously worked) though I'm lost with this again.

UEFI was used to install the Hackintosh though used Legacy boot to get into HS.


I got assistance with Hackintoshing a different notebook using Mojave (Gigabyte Sabre 17 with HD 630) that does not support dedicated GPUs, only discrete GPU whereas this Latitude only worked with the dedicated Nvidia GPU (though by boot flags included 'nv_disable=1').



With Optimus enabled,

What should the boot flags contain?

What drivers are essential?


If possible, what changes are needed to use Mojave?


Currently I'm trying to reinstall HS and get the error  on the installer window "OSInstall.pkg appears to be missing or damaged"

Installer is using UEFI boot.


Only with Optimus enabled am I able to reach the installer windows that shows the error above, 

Tried boot flags with and without "nv_disable=1" and both get the windows above


EMUVariable is not present in driverUEFI64 and drivers64.


My Google-foo hasn't got me any further with other troubleshooting, any assistance is appreciated.


Link to comment
Share on other sites


  • Create New...