Jump to content

DSDT Patch Request for GPIO Pinning

Recommended Posts

Hey mate!


Sorry but I can't help you if you don't follow the things I ask you to do. Things you've effectively ignored are:

  1. I asked you to not to apply any i2c patches except Windows 10 patch but you have modified TPD1 and GPI0 methods in your DSDT.
  2. I had asked you the BIOS name of your Trackpad from Windows Device Manager but you didn't provide me with the same.

Please provide me with the things that I need and then expect me to help you!



Link to comment
Share on other sites

Hi @black.dragon74, are you still available for assistance? 

Mom getting a strange bug were my mouse cursor keeps moving the last direction I went after lifting my figure off the trackpad. I’ve been directed to pin GPIO by the Voodooic gitter and can’t resolve the issue.

spcs are below;


Razer Blade early 2016


I can provide the debug tomorrow 

I the voodoic2 interrupt  guide 



Link to comment
Share on other sites

Hey @black.dragon74 I would like some assistance if you are still available.

I have an i7-8750h and the trackpad uses widows precision drivers.

As mentioned in the voodooi2c guide I should use the satellite HID kext which I tried and works fine. However for some reason maybe because it is in polling mode, when on battery my laptops cursor kind of lags when sliding on the trackpad from side of side but it does not happen when plugged in. Gestures work nice so I want to get it working in interrupt to reduce CPU usage and see if it also solves the cursos lag. I have been trying to understand patching and error fixing but I haven't tried patching it myself as my knowledge right now is very limited. I read somewhere that you should delete the AppleIntelLpssI2C[Controller].kext which I haven't done, should I do it?


If possible I would like to have the GPIO pinning with an SSDT as I do not have a patched DSDT I am only using patched SSDTs.



Link to comment
Share on other sites

Hi and thanks for helping Jake. I am using your files but I am not currently sure how to check if the trackpad is now working in interrupt mode. However I am still getting the cursor jumping on screen when fast moves on the trackpad.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...