Jump to content

E7270 - Can't boot High Sierra installer


ufdlim
 Share

Recommended Posts

I've tried all night reading through the forums and the guide to try to boot the High Sierra installer without luck. I've followed the guides at Dell Latitude E7x70 - Clover UEFI Only and Dell Latitude / Inspiron / Precision / Vostro / XPS - Clover Guide for creating the install media, installing Clover, and replacing (not merging) the generic EFI and high sierra bootpack.

 

Things to note:

  • I did not do not set DVMT to 96MB (0x3) - according to FireWolf's guide DVMT needs to be 96MB or more and I see it is 128MB in Windows. Or am I misinterpreting the need to do this?
  • Specs: Core i5-6300U, 8GB DDR4, Intel 520 graphics, 1080P matte non-touch, 256GB Hynix SC308 M.2 SSD (non NVMe), Broadcom Atheros QCA61x4A WLAN (although when I opened up the laptop, it says this is a DW1820 chip; its okay if I don't have wifi, ethernet is fine), Intel I219-LM ethernet, fingerprint sensor, and NFC device
  • BIOS: 1.19.4
  • BIOS settings: BIOS defaults, then TPM = Disabled, Secure Boot = Disabled, UEFI = Enabled, SATA = AHCI, = Wake on LAN = Disabled, and Legacy ROM = tried both Enabled and Disabled
  • Clover settings: UEFI booting only, Clover in the ESP, add AptioMemoryFix

 

Step considered:

  • Clover R4586, replace generic EFI, add E7270 bootpack - stuck at "creating RAM disk for /var/log" (consistent)
  • Reset /EFI, Clover R4558, replace generic EFI, add E7270 bootpack - random freeze at various points
  • Replaced AptioMemoryFix with AptioMemoryFix-64 at some plint - didn't work
  • Reset /EFI, Clover R4586, replace generic EFI, add E7270 bootpack, replace patched ACPI from various forum posts: 1, 2, 3 - random freeze at various points
  • Was reading that the bootpack might have some outdated files, so - Reset /EFI, Clover R4558, generic EFI, E7270 bootpack, upgrade to Clover R4586 - stuck at "restore environment starting" (see image below)

MVIMG_20180706_004943.jpg

 

What am I missing? The DVMT fix? Attached is my origin dump from Clover.

Thanks for any help!

 

Origin ACPI files: origin.zip

CLOVER folder: CLOVER.zip

Link to comment
Share on other sites

Hey Bronxteck - thanks for the suggestion. I noticed they were already in my e/c/k/o folder but went ahead and updated them to their latest releases. However, I am still stuck - seemingly randomly at this point.

 

Also, I apologize - realized i put this topic in the Guides forum. Please move or I can delete and re-post.

Link to comment
Share on other sites

Check if this option in your config.plist:

<key>SystemParameters</key>
    <dict>
        <key>InjectKexts</key>
        <string>Yes</string>

https://clover-wiki.zetam.org/Configuration/SystemParameters#systemparameters_injectkexts

Link to comment
Share on other sites

@Jake Lo Worked beautifully! Booted, installed, and installed locally perfectly. System sleeps and wakes from sleep just fine. Sound works great. Able to get a working dual boot with Windows 10 as well.Thanks so much! 

 

Still need to do the post-install Karabiner. Wi-Fi doesn't work but I'm not surprised because its 168C:003E, which is an Atheros card I've not seen compatible anywhere. Weird because the sticker on the actual card says its a DW1830.

Link to comment
Share on other sites

 Share

×
×
  • Create New...