Jump to content

Dell Latitude 7490 - Mojave


micheajp
 Share

Recommended Posts

Hello!  Using your wonderful site I've been able to install Mojave 10.14.2 on my 7490.  I'm even booting off an external USB-C NVME caddy until later when I can swap the internal NVME out. (still need the os on there for the time being). I'm also using a USB AC600 until purchased DW1830 appears.

 

However, I'm still struggling to get the trackpad and the sound working. 

 

Assistance is requested, thanks in advance.

Link to comment
Share on other sites

Intel Graphics 620

PCI\VEN_8086&DEV_5917&SUBSYS_081C1028&REV_07

i5-8350u
ACPI\GenuineIntel_-_Intel64_Family_6_Model_142

Audio
INTELAUDIO\FUNC_01&VEN_10EC&DEV_0256&SUBSYS_1028081C&REV_1000

Intel Display Audio
INTELAUDIO\FUNC_01&VEN_8086&DEV_280B&SUBSYS_80860101&REV_1000

Pointing Devices
HID\VEN_DELL&DEV_081C&Col01

Dell Touchpad
HID\VEN_DELL&DEV_081C&Col03

HID Compliant touch pad
HID\VEN_DELL&DEV_081C&Col02

I2C Device
ACPI\VEN_DELL&DEV_081C

wifi/bluetooth -(unsupported correct?)
PCI\VEN_168C&DEV_003E&SUBSYS_03101028&REV_32

Bluetooth (works)
USB\VID_0CF3&PID_E007&REV_0001

SATA Controller
PCI\VEN_8086&DEV_282A&SUBSYS_081C1028&REV_21

EFI.zip

Edited by micheajp
added attachment
Link to comment
Share on other sites

 

Very cool, thank you, huge improvement!

 

Graphics and HDMI now good. Will test USB-C shortly.

 

USB atheros NIC is missing from USB hub now. Is this a PCI remap issue?

Trackpad is also working, however in a way I'd describe as jumpy.  How do I tune this?

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...