Jump to content
micheajp

Dell Latitude 7490 - Mojave

Recommended Posts

On 1/14/2019 at 9:57 PM, micheajp said:

 

Very cool, thank you, huge improvement!

 

Graphics and HDMI now good. Will test USB-C shortly.

 

USB atheros NIC is missing from USB hub now. Is this a PCI remap issue?

Trackpad is also working, however in a way I'd describe as jumpy.  How do I tune this?

 

 

7490 too, maybe use the same setting and ELF file.

Perfect sleep and graphics.

Not work:

   Trackpad Jumpy too and the click buttons did not work.

   Cannot use a earphone, but the built-in speaker is OK.

Share this post


Link to post
Share on other sites
9 hours ago, Jake Lo said:

try with these, then post new IOReg with displays connected

-cdfon -igfxnohdmi

 

Attached are two versions. I tried SwitchResX and was able to bump up resolutions, but not to native 3840x1400.

micheajp-v2.1.ioreg

Share this post


Link to post
Share on other sites
5 hours ago, persistz said:

7490 too, maybe use the same setting and ELF file.

Perfect sleep and graphics.

Not work:

   Trackpad Jumpy too and the click buttons did not work.

   Cannot use a earphone, but the built-in speaker is OK.

 

Graphics on laptop screen good, but I have a big monitor and it's not working at optimum res. As you say, the trackpad works but jumpy and no buttons. Focusing on monitor, then will go into audio and trackpad.

Share this post


Link to post
Share on other sites

Another problem is about CPU frequency, I used Inter Power Gadget as a monitor and found the frequency is maintain about 3.1Ghz, which may caused the fan always rotating fast. 

Share this post


Link to post
Share on other sites

Update: I think the reason is ssdtPRGen.sh, in this repo, there is no info for i5-8250u, i will try to find the related info and run it.  

 

Update +: Generated ssdt.aml and place at paych,  it did not work, the CPU frequency also maintain at 3.1G. 😔

Share this post


Link to post
Share on other sites

Hi guys,

firstly I just want to thank osxlatitude! They have been an amazing help.

I also own an DELL 7490 i5 2.7, 16GB, Intel HD 620.

Mojave is running on my DELL 7490, after cloning the SSD from an E7270 :-)

Touchpad is not working (Keyboard works with VoodooPS2Controller v191, WiFi Intel (ofcourse it isnt working) and the Graphics works, due to Clover-Injection

I am glad if I can be any help to give you information, so we make this machine work!

e18df496-ba7a-4692-8493-9656727eaf62.jpg

d0536242-f4f5-43b9-98b4-51dbc020367a.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...