Jump to content

ioncatana

Members
  • Content Count

    25
  • Joined

  • Last visited

  • Days Won

    1

ioncatana last won the day on December 24 2017

ioncatana had the most liked content!

Community Reputation

4 Neutral

About ioncatana

  • Rank
    Corporal

Profile Information

  • Gender
    Not Telling

The recent visitors block is disabled and is not being shown to other users.

Enable
  1. Hello Jake, thank you for the precious input from above, I have understood how it works and did all the steps that are required for the I2C Touchpad. a) Extracted and fixed DSDT ( so I get a success compilation ) b) Added the patched from VoodooI2C c) Installed the VodooI2C kexts --- BIOS-Version: 1.7.2 (11/26/2018) --- I have also provied screenshots with information about the TouchPad (Windows Device Manager: Hardware-IDs, etc) and also IOReg-Screenshot with what I can see under Mac. Can you please have a look in the DSDT and give me some input, for some reason I feel like I am missing smth DELL7490_DSDT_I2C-Touchpad-Info.zip
  2. Hi JakeLo, thank you for your fast reply. I have tested your boopack and here are the results: a) I get kernelt panic in VoodooI2C.kext b) I replaced the kext's with mine and I could boot into OS (Problem: TrackPad is working very poorly | no buttons from trackpad are working and the sound isnt working) c) I have taken a few of your patches from the config and the ACPI-contents The state is still the same: + Sound OK, GPU OK (FullHD), Bluetooth, Keyboard, USBs - Trackpad isnt working / and the buttons from Trackpad are not working - WiFi (will replace it with an atheros or smth) --- Info of my Trackpad: Alps Virtual HID HID\Vid_044E&Pid_1212&Col01&Col01 I2C HID Device HID\VEN_DELL&DEV_081C&Col01 HID\DELL081C&Col01 HID\VID_044E&UP:0001_U:0002 HID_DEVICE_SYSTEM_MOUSE 7490_EFI_CLOVER.7z
  3. Hi guys, firstly I just want to thank osxlatitude! They have been an amazing help. I also own an DELL 7490 i5 2.7, 16GB, Intel HD 620. Mojave is running on my DELL 7490, after cloning the SSD from an E7270 Touchpad is not working (Keyboard works with VoodooPS2Controller v191, WiFi Intel (ofcourse it isnt working) and the Graphics works, due to Clover-Injection I am glad if I can be any help to give you information, so we make this machine work!
  4. I have made another copy to a GUID-Partition and installed Clover in UEFI-Modus. Pressing F4 worked! I have uploaded the origin content on the first page under the name: ACPI-origin-2350-Inspiron.zip Please have a look and give me a bit of input. Thx!
  5. Just like I said, there is no further partition, I have installed everything on a single partition bash-3.2# diskutil list /dev/disk0 (internal, physical): #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *32.0 GB disk0 1: Apple_HFS Mac 32.0 GB disk0s1
  6. >>EFI-Partition<< OK so I need the EFI-Partition I will do this tomorrow then, cuz now I dont have the computer at home. I am not using the EFI, just normal Legacy BIOS settings with EFI-Folder in the same partition as the Mac-OS installation. Will change this tomorrow and do as you told. >>Audio<< The AppleHDA.kext file from the "Dell Optiplex 9030 AIO bootpack" did not work Thank you again for the support.
  7. It did not work at all. I have been pressing F4 on the Clover boot menu during boot and nothing
  8. The folder "origin" is empty. Do you want me to extract the DSDT + SSDT from Windows and attache it here?
  9. I have been trying all your suggestions regarding the Graphiccard, the only one that worked was from Herve. I have full QE/CI now, the only problem is that the bar in the top left corner ( the apple logo ) looks very fuzzy will upload images Is there any solution for the Audio to make it work? AppleHDA injection/patch for ALC3661? Regards
  10. First big thx. to osxlatitude! I have now a new Machine, and I am quite far with the installation. I have installed the Mac OS 10.11.6 so far and I still need some input from you guys: >>Hardware<< CPU: Intel Core i5-4200M Chipset: Intel HM87 Express Chipset / PCI\VEN_8086&DEV_8C4B RAM: 8 GB DDR3 1600 MHz Graphics: HD Graphics 4600 ( Intel Haswell-MB GT2 ) / PCI\VEN_8086&DEV_0416 Ethernet: RealTek Semiconductor RTL8168/8111 PCI-E Gigabit / works OOB Audio: Realtek ALC3661 ( VoodooHDA doenst work -> kernel panic ) WiFi: Atheros/Qualcomm AR9565 Wireless Network Adapter / needs patch Bluetooth: Works OOB >>Audio<< Jake Lo is right, the Audio is also regarding the realtekALC-100-script: ALC668 >>What is working<< Graphics: QE/CI works with FakeID-Injection (+kext files) / still the image in the upper left corner looks a bit fuzzy Ethernet: OOB WiFi: kext Injection / pci168c,36 Bluetooth: OOB >>Graphics<< (normal window with fuzzy text in the bar) (fullscreen window and the text in the bar shows correctly) >>Attachment<< I have uploaded the DSDT ( original & patched ) together with the config.plist and the HWINFO64 extraction of the machine. In the mean time I will check the other hardware parts to make them work: WiFi + Sound Thank you in advance! config.zip dsdt.orig.aml.zip dsdt.zip DELL_Inspiron-2350.htm ACPI-origin-2350-Inspiron.zip
  11. First a very big thx to osxlatitude! Without them, none of these could be done! This installation of El Capitan 10.11.6 is based on Clover (EFI). I have downloaded the bootpack for D630 from EDP, still the USB were not working at all. After patching the DSDT the Bluetooth stopped working. Now two of the USB ports are working and bluetooth as well. The only thing that is missing, is to make the other two USB ports work. Here I will need your DSDT patching experience / skills The Dockingstation works very good even with Hot Plug (in & out) while the system is running. >>Hardware<< CPU: 1,99 GHz Intel Core 2 Duo RAM: 2GB GPU: nVidia Quadro NVS 135M 128MB LAN: Gigabit Sound: Sigmatel 9505 Bluetooth: 2.0 WLAN: Atheros AR5B91 >>What Works<< GPU: Clover Injection LAN: BCM5722D Bluetooth: DSDT-Patch USB-Ports: DSDT-Patch ( right side: upper | back side: left ) Battery: ACPIBatteryManager.kext Keyboard+Touchpad: AppleACPIPS2Nub.kext & ApplePS2Controller.kext Audio: VoodooHDA ( still the noise here is a bit strange sometimes ) Dockingstation: all 3 USB on the back works Dockingstation: DVI Connector on the back works Dockingstation: LAN Port on the back works Sleep: works ( closing the LID ) >>What Doesn't Work<< USB-Ports: right side: lower | back side: right ( perhaps you can help me here with a DSDT path ) Other Features and Components I have not tested! >>Attachments<< config.plist ( MacBookPro5,1 ) DSDT.aml ( no need for USB-Injection / USB-Fix ) D630-HwInfo.html ( Hardware Information of my machine ) Dockingstation with DVI: USB on the Laptop: USB on the Dockingstation: Bluetooth working + LAN-Dokingstation working: D630-HwInfo.htm config.plist.zip DSDT.aml.zip
  12. I dont have any installer any more, due to the fact that I have now 10.11.6, isnt another version of kext for this? In case nobody from you has those 2 kexts then I will have to create the installer again and then install all updates up to the 10.11.6
  13. Alright! Will check it out and report back I would need the original kexts for 10.11.6 AMD5000Controller.kext AMDRadeonx3000.kext I dont have them anymore Only the patched ones
  14. It only worked with ACPIBatteryManager.kext! ( AppleSmartBatteryManager.kext didn't work at all )
  15. Bloody! It works Thx Jake Lo! will upload the new DSDT.aml together with the SSDT.aml ( so no need for the NullPowerManager.kext )
×
×
  • Create New...