Jump to content

Mojave + e5420 = no audio


Grubinho
 Share

Recommended Posts

Greetings. 

Installed 10.14 Mojave on E5420, but can't get audio to work. 

On High Sierra used AppleAlc + Lilu and everything was fine. 

Tried to change layout id, changed HDAS to HDEF in ACPI section. 

Still no luck. 

 

I'm not sure what my codec is (only "Intel High Def Audio under Windows description), but I think that it may be around: 

IDT 92HDxxx HD Audio; IDT 92HD93 HD Audio.

 

Any solution? 

Link to comment
Share on other sites

I messed up with patch AppleHDA.kext and reinstalled 10.14. 

Can't create debug also, beacouse of: "You forgot to press F4 or Fn+F4 at clover boot screen.

Please reboot and press F4 or Fn+F4 to dump ACPI origin files." 

(I pressed f4 and Fn+f4 on clover boot and don't know why it is not dump debug - maybe it is related with external drive install?) 

 

What I have is only bootlog from Clover

Link to comment
Share on other sites

Audio is not presence in system preferences. No "in" , no "out". 

Boot log shows: 

"3:031  0:000  No AudioIoProtocols, status=Not Found"

 

I'm not able right now to post debug file with described method. Must change drives from internal to external and opposite.  

Link to comment
Share on other sites

 Share

×
×
  • Create New...