Jump to content

[SOLVED] Dell Latitude 5580 (Kabylake i7-7600U) No Touchpad


Recommended Posts

Hello guys, I have installed macOS Mojave on my Dell Latitude 5580. I had also installed the boot loader on my HDD. Now there are two main problems, the first one is that my trackpad isn't working. I had tried I2C kexts and patched the DSDTs but remain unsuccessful. It maybe due to some error. The second issue is that there is no audio. Kindly help me out as attaching an external mouse is not feasible for me :(

My EFI Partition is attached



P.S: I have excluded ""themes" and Microsoft folder from the attached EFI (due to total size restrictions)


Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

Hi. :)


You can try my attached VoodooPS2 KEXT to get your trackpad working.

For getting Audio to work you need to know which type of Audio-Codec is used in your system. After you know about this you have to download and put "AppleALC.kext" into you kext folder and add the "alcid=xx" line to the boot arguments (where xx is you layout id).


You can refer here to get the correct layout id for your Audio Codec.


Link to comment
Share on other sites

You have to put both KEXT into your  "/EFI/CLOVER/kexts/other" folder.

And you have to remove the other "VoodooPS2controller.kext".


You don't have to "install" them. Just copy them into that folder.

Edited by eC//FrEaK
added "to" in the last sentence
Link to comment
Share on other sites

Thank You. I have tried putting the kext from the link you send to EFI/CLOVER/kext/Other but trackpad still isn’t working. 

As for the audio front. Yes thank you. My audio is working now. 

Kindly help me regarding this touchpad. Let me know which files I can provide. 

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...