Jump to content

[SOLVED] Dell Latitude E6230 Mojave - Wifi DW1510 no longer working correctly and USB errors


JohnSandesh
 Share

Recommended Posts

Hi-  Two more issues with the Dell Latitude  E6230 Mojave installation -

1)The Wifi adapter ie DW1510 is not working consistently. Wifi Icon appears on the top however I'm unable to turn it on and always stays off. 

2) Unplugging USB device is sometimes causing an error - "USB Accessories Disabled"  error screenshot attached. 

Could you kindly help, please?

 

usb-accessories-disabled-on-mac.jpg

Link to comment
Share on other sites

  • Administrators

Make sure you've got your ACPI patches, Clover config and add-on kexts all right. You may refer to my E6230 guide:

 

Naturally, all will work with a vanilla installation; no such guarantee with a distro...

Link to comment
Share on other sites

Right, I've used the exact guide and all is working except reliable wifi. It works sometimes like 2 out 6 times on average if I unplug and plug USB devices randomly and restart the laptop. I initially thought it could be bad wifi card and was able to swap to another working DW1510 card with no joy. I can see wifi card in sys report however it is in off status. 

 

Link to comment
Share on other sites

Hi Herve, I now moved my WiFi Card from WLAN slot to 1/2MINI Labelled slot it seems to be working okay so far. I have two E6230 laptops and I experienced the same WiFi issues on both,  After changing the Mini-PCIe slot, they both seem to be working as expected. But could I request you keep this thread open for 1 more day to fully test this, please? I will send with error reporting files. 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...