Jump to content
malikabuzar

Lenovo G40-80 (i3-5005U + Intel HD Graphics 5500): help with macOS High Sierra

Recommended Posts

Hi there,
I have a Lenovo G40-80 running with macOS High Sierra (10.13) with working Ethernet/Bluetooth/Audio/USB 3.0/2.0. 
I am unable to make the Graphics/Battery Status/Touchpad working. 
Using clover as boot loader and dual boot with Windows 10 (EFI) and clover is installed in SSD EFI partition.
Screen flickers after login and login screen in grey. Graphics Memory is displayed as 4 MB and System Information shows no kext loaded for Graphics. Graphics DVMT prealloc is 128 MB. (Determined with the help of a tutorial which says that if your Dedicated Graphics Memory in Windows is shown to be less than 128, your DVMT prealloc is Dedicated Memory + 32 and if it is 128 or greater then DVMT prealloc is equal to the Dedicated Memory. My Dedicated Graphics Memory is 128 MB, so...). I am using ig-platform-id=0x16160006.
-----
What I have tried from different tutorials with no success.
1. Changing ig-platform-id to 0x16260006 and 0x16160002 results in Kernel Panic and system restarts.
2. Enabling Legacy Support has no effect.
-----
Can anybody help please. 

My system configuration is:
Manufacturer: Lenovo
Model: G40-80 (80E4)
Processor: Core i3-5005U
Graphics: Intel HD Graphics 5500
RAM: 4GB
SSD: INTEL SSDSC2BF180A4H
Ethernet: Realtek
Wifi: Intel Dualband Wireless AC-3160
Touchpad: ELAN 

My clover config.plist is attached.

config.plist.zip

Share this post


Link to post
Share on other sites

Keep a backup of your current config (just in case), then open your Clover config in Clover Configurator app and try the following :

  1. in Devices section, remove that id faking you've configured for your iGPU
  2. in Devices section, inject the required DVMT adjustment properties:

DVMT_properties.jpg

  1. in Graphics section, remove "Inject Intel" + ig-platform-id 0x16160006
  2. in SMBIOS section, change your profile from incomplete and unsuitable Haswell MBA6,2 model to Broadwell MBA7,1 or MBA7,2 or MBP12,1 model
  3. in Kernel & Kexts Patches, you may also remove the AppleIntelCPUPM patch which is irrelevant to Broadwell platforms (it's only for Sandy & Ivy Bridge systems)

 

Then, let latest version of Lilu + WhateverGreen kexts take care of graphics.

For battery monitoring, use Rehabman's latest version ACPIBatteryManager kext.

For your ELAN TouchPad, you may give this a try (no guarantee).

 

NB: in, case you ignored it, your Intel wireless card is not supported and will have to be replaced by a support model (compatible with your Lenovo) or a USB dongle. See here.

 

Share this post


Link to post
Share on other sites

Thanks for reply. I am going to configure graphics first. I made all the changes you asked. No difference except "About this Mac" shows only "Display" instead of "Intel HD Graphics 5500" but with same 4 MB. Attached is the modified config.plist file, screenshot of "About this Mac" and kext folder of clover.

Screen Shot 2019-09-01 at 2.40.05 PM.png

Screen Shot 2019-09-01 at 2.44.45 PM.png

config.plist.zip

Share this post


Link to post
Share on other sites

You can and should get rid of NullCPUPowerManagement kext. That kills all CPU SpeedStep and affects performance...

 

I'm a little lost because i3-5005U carries the same HD5500 id 0x1616 as the i5-5300U I recently played with on a Dell Latitude E7250 and for which graphics worked OOB with the above arrangements.

 

Can you please post:

  1. a zipped saved output from IORegistryExplorer
  2. a zipped copy of your Clover EFI folder (when you boot, press F4 at Clover main menu in order to dump all your raw BIOS tables)

Which version of Clover are you running with?

 

In your 1st post, your Clover config showed that you were incorrectly trying to fake id 8086:1626 for your HD5500 iGPU (you entered "0x016268086") and injecting BDW (Broadwell) layout-id 0x16160006; that's an unknown layout to me and I would have expected that you'd inject layout-id 0x16260006 instead, as recommended in Cover Configurator. That certainly is the layout I saw reported in IOReg on the E7250 I had and I was not injecting anything, just letting Lilu + WEG do their job...

BDW_layouts.jpg

 

But, by all means, you may try to fake id 8086:1626 by entering "0x16268086" and injecting recommended BDW layout (ig-platform-id) 0x16260006.

Share this post


Link to post
Share on other sites
6 hours ago, Hervé said:

You can and should get rid of NullCPUPowerManagement kext. That kills all CPU SpeedStep and affects performance...

Deleted the said kext....

6 hours ago, Hervé said:

Can you please post:

  1. a zipped saved output from IORegistryExplorer
  2. a zipped copy of your Clover EFI folder (when you boot, press F4 at Clover main menu in order to dump all your raw BIOS tables)

Both zip files attached. I obtained Registry Output output by save as option in IORegistryExplorer.

 

6 hours ago, Hervé said:

injecting BDW (Broadwell) layout-id 0x16160006; that's an unknown layout to me and I would have expected that you'd inject layout-id 0x16260006 instead

The id 0x16160006 was obtained from some forum/guide (I don't remember which one) and use of this id gives the name of "Intel HD Graphics 5500" in "About this Mac". No other id I tried has given me the name of my Graphics Hardware, so I supposed this id might be the right one. 

 

6 hours ago, Hervé said:

I was not injecting anything, just letting Lilu + WEG do their job...

Not using any fake id or platform id, as you advised in previous reply.

Already using the SMBIOS id as MBA7,2, as advised in previous reply and reply on other forum.

 

Thanks for your help, sir. I am looking forward to get a working Graphics with your help.

Regards

CLOVER.zip Registry Output.zip

Share this post


Link to post
Share on other sites

A layout in a Framebuffer kext can be described as a table that defines display output's properties throughout many parameters including, video memory, number of output ports, type of outputs, etc. You can find these tables in the binary files of framebuffer kexts through a simple Hex editor such as HexFiend for instance. You can then search those layouts in hexadecimal reverse order. For layout 16260006, which is what you would normally use for a laptop with HD5500 graphics, you would conduct a hex search on "06 00 26 16" which would lead you to the following code:

06002616 01030303 00002002 00005001
00000060 D90A0000 D90A0000 00000000
00000000 00000000 00000800 02000000
30020000 01050B00 00040000 07050000
02040B00 00040000 07050000 FF000000
01000000 40000000 0B0B0000 01010500
00000000 05000000 00000000 04000000
00000000 00000000 00000000 00000000
00000000 C8000000

 

If you were to conduct a search for "06 00 16 16",  you'd get nothing because it's not an existing layout; as such, injecting ig-platform-id 0x16160006 in Clover (or trying to) will not lead anywhere. I'm surprised you find it referenced in a guide on a forum because that's totally incorrect....

 

Anyway, try the attached Clover config.

config.plist.zip

Share this post


Link to post
Share on other sites

System restarted after half loading (apple loading bar half filled) when using the config.plist you provided. Starting in verbose mode shows Kernel panic. Here is the panic report, if it may help. 

Spoiler


Quote

*** Panic Report ***
panic(cpu 2 caller 0xffffff7f81beea74): assertmsg@/Library/Caches/com.apple.xbs/Sources/GPUDriversIntel/GPUDriversIntel-10.28.26/Common/IONDRV/Intel/BDW/AppleIntelFramebuffer/AppleIntelController.cpp:21408
Backtrace (CPU 2), Frame : Return Address
0xffffff90ac6a3ac0 : 0xffffff800026d366 mach_kernel : _handle_debugger_trap + 0x516
0xffffff90ac6a3b00 : 0xffffff8000398494 mach_kernel : _kdp_i386_trap + 0x114
0xffffff90ac6a3b40 : 0xffffff800038a429 mach_kernel : _kernel_trap + 0x5e9
0xffffff90ac6a3bc0 : 0xffffff800021f190 mach_kernel : _return_from_trap + 0xe0
0xffffff90ac6a3be0 : 0xffffff800026cd8c mach_kernel : _panic_trap_to_debugger + 0x26c
0xffffff90ac6a3d10 : 0xffffff800026cafc mach_kernel : _panic + 0x5c
0xffffff90ac6a3d70 : 0xffffff7f81beea74 com.apple.driver.AppleIntelBDWGraphicsFramebuffer : __ZN22AppleIntelFBController13FBMemMgr_InitEv + 0x194
0xffffff90ac6a3dd0 : 0xffffff7f81bec421 com.apple.driver.AppleIntelBDWGraphicsFramebuffer : __ZN22AppleIntelFBController5startEP9IOService + 0xd0b
0xffffff90ac6a3e40 : 0xffffff800087e18d mach_kernel : __ZN9IOService14startCandidateEPS_ + 0x6d
0xffffff90ac6a3e80 : 0xffffff800087ded1 mach_kernel : __ZN9IOService15probeCandidatesEP12OSOrderedSet + 0x941
0xffffff90ac6a3f00 : 0xffffff800087d3f7 mach_kernel : __ZN9IOService14doServiceMatchEj + 0x2c7
0xffffff90ac6a3f50 : 0xffffff800087f006 mach_kernel : __ZN15_IOConfigThread4mainEPvi + 0x1a6
0xffffff90ac6a3fa0 : 0xffffff800021c4f7 mach_kernel : _call_continuation + 0x17
      Kernel Extensions in backtrace:
         com.apple.driver.AppleIntelBDWGraphicsFramebuffer(10.2.8)[C3660F9C-CB82-3D1F-959C-BD4DAA79F296]@0xffffff7f81bcc000->0xffffff7f81d6afff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[DF1517A2-32C4-328E-9890-03E6C546604A]@0xffffff7f80a94000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[8794C760-FDD9-3664-ADED-4A9BBEC6E517]@0xffffff7f80b1f000
            dependency: com.apple.iokit.IOAcceleratorFamily2(373)[AC1A34E9-9E45-3D8E-BE76-C420370D2852]@0xffffff7f81b26000
            dependency: com.apple.iokit.IOReportFamily(31)[D2F2FBDF-4EE4-38BA-99F5-B699F886F413]@0xffffff7f815c4000
            dependency: com.apple.AppleGraphicsDeviceControl(3.16.19)[35BE1077-5D56-3353-BFC5-F6026B931F81]@0xffffff7f81539000
            dependency: com.apple.iokit.IOGraphicsFamily(517.17)[05FC87E8-B78E-319E-AF08-0EBDA16094CE]@0xffffff7f81278000

BSD process name corresponding to current thread: kernel_task
Boot args: nv_disable=1 dart=0 -v  keepsyms=1 debug=0x100 slide=0 

Mac OS version:
17A405

Kernel version:
Darwin Kernel Version 17.0.0: Thu Aug 24 21:48:19 PDT 2017; root:xnu-4570.1.46~2/RELEASE_X86_64
Kernel UUID: B84FDEFC-9081-35CE-8C51-25A9583AACDE
__HIB  text base: 0xffffff8000100000
System model name: MacBookPro12,1 (Mac-E43C1C25D4880AD6)

System uptime in nanoseconds: 5348970454
last loaded kext at 4925177130: com.apple.driver.AudioAUUC    1.70 (addr 0xffffff7f8275b000, size 32768)
loaded kexts:
org.voodoo.driver.VoodooHDA    2.8.8
com.joshuawise.kexts.HoRNDIS    6
org.rehabman.voodoo.driver.PS2Mouse    1.8.28
org.rehabman.voodoo.driver.PS2Trackpad    1.8.28
org.rehabman.voodoo.driver.PS2Keyboard    1.8.28
com.insanelymac.RealtekRTL8111    2.0.0
net.osrom.kext.Disabler    1.0.1
org.rehabman.voodoo.driver.PS2Controller    1.8.28
org.netkas.driver.FakeSMC    1787
com.apple.driver.AudioAUUC    1.70
com.apple.driver.AppleGraphicsDevicePolicy    3.16.19
com.apple.AGDCPluginDisplayMetrics    3.16.19
com.apple.driver.AppleHV    1
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.driver.pmtelemetry    1
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleIntelBDWGraphics    10.2.8
com.apple.AVEBridge    1.0.0
com.apple.driver.eficheck    1
com.apple.driver.AppleLPC    3.1
com.apple.driver.ACPI_SMC_PlatformPlugin    1.0.0
com.apple.driver.AppleOSXWatchdog    1
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.driver.AppleIntelBDWGraphicsFramebuffer    10.2.8
com.apple.driver.AppleFIVRDriver    4.1.0
com.apple.filesystems.apfs    748.1.47
com.apple.driver.AppleFileSystemDriver    3.0.1
com.apple.filesystems.hfs.kext    407.1.3
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.BootCache    40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.iokit.SCSITaskUserClient    404
com.apple.driver.AppleAHCIPort    329
com.apple.driver.AppleHPET    1.8
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleACPIButtons    6.1
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    183
com.apple.security.TMSafetyNet    8
com.apple.security.quarantine    3
com.apple.IOBufferCopyEngineTest    1
com.apple.driver.AppleGraphicsControl    3.16.19
com.apple.iokit.IOTimeSyncFamily    600.15
com.apple.driver.AppleSSE    1.0
com.apple.AppleGPUWrangler    3.16.19
com.apple.iokit.IONDRVSupport    517.17
com.apple.iokit.IOBluetoothHostControllerUSBTransport    6.0.0f7
com.apple.iokit.IOBluetoothHostControllerTransport    6.0.0f7
com.apple.iokit.IOBluetoothFamily    6.0.0f7
com.apple.driver.usb.IOUSBHostHIDDevice    1.2
com.apple.driver.AppleSMBusPCI    1.0.14d1
com.apple.driver.IOPlatformPluginLegacy    1.0.0
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.iokit.IOAudioFamily    206.5
com.apple.vecLib.kext    1.2.0
com.apple.driver.AppleIntelLpssUARTv0    3.0.60
com.apple.driver.AppleIntelLpssUARTCommon    3.0.60
com.apple.driver.AppleOnboardSerial    1.0
com.apple.iokit.IOSkywalkFamily    1
com.apple.iokit.IOSerialFamily    11
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.AppleGraphicsDeviceControl    3.16.19
com.apple.iokit.IOAcceleratorFamily2    373
com.apple.iokit.IOGraphicsFamily    517.17
com.apple.iokit.IOSurface    209
com.apple.driver.usb.cdc    5.0.0
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.AppleEffaceableStorage    1.0
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IOUSBFamily    900.4.1
com.apple.iokit.IOSCSIMultimediaCommandsDevice    404
com.apple.iokit.IOBDStorageFamily    1.8
com.apple.iokit.IODVDStorageFamily    1.8
com.apple.iokit.IOCDStorageFamily    1.8
com.apple.driver.AppleXsanScheme    3
com.apple.iokit.IOAHCISerialATAPI    267
com.apple.iokit.IOAHCIBlockStorage    301.1.2
com.apple.iokit.IONetworkingFamily    3.3
com.apple.driver.usb.AppleUSBXHCIPCI    1.2
com.apple.driver.usb.AppleUSBXHCI    1.2
com.apple.iokit.IOAHCIFamily    288
com.apple.driver.AppleIntelLpssGspi    3.0.60
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.iokit.IOSMBusFamily    1.1
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.iokit.IOBufferCopyEngineFamily    1
com.apple.driver.DiskImages    480.1.2
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleUSBTDM    439
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.iokit.IOUSBMassStorageDriver    140
com.apple.iokit.IOSCSIBlockCommandsDevice    404
com.apple.iokit.IOSCSIArchitectureModelFamily    404
com.apple.iokit.IOStorageFamily    2.1
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.2
com.apple.driver.usb.AppleUSBCommon    1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor    1
com.apple.iokit.IOReportFamily    31
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleACPIPlatform    6.1
com.apple.driver.AppleSMCRTC    1.0
com.apple.driver.AppleSMC    3.1.9
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread    1
com.apple.kec.Libm    1
com.apple.kec.corecrypto    1.0

EOF
 


 

 

Share this post


Link to post
Share on other sites

FB needs to be cache before it could be patch-on-the-fly.

So boot to Clover, go to Options and add to boot arg

-igfxvesa

 

Once you get to the desktop, you can repair permissions and rebuild cache. Then you should be able to boot normally.

If you still can't boot with the above arg, then go to Options

Go down to Graphics Injector and select it

Select both FakeID and platform-id and change them to 0x12345678

Repair permissions and rebuild cache. Then you should be able to boot normally.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...