Jump to content

[Solved] Dell E7440 Catalina kext error


Recommended Posts


 Today I upgraded to Catalina.  The update was successful but the kext's are not working properly.

 The display flashes in different colors under load.  When you increase or decrease the volume, everything sucks.  And anyway, it's very slow ...

 I tried to generate a debug file but unfortunately failed.
 Line 54 command prints an error.

 On my right call I packed the EFI partition to see if that might help.

 Can someone help me out what's wrong?

 Thank you in advance for your help!!!





Link to comment
Share on other sites

Hi @dctacsi,


first of all let me say to fill in your signature: basically it is important to know your hardware before trying to give an hand.

Secondly: why don't you use the EFI folder published by @Jake Lo? Your EFI seems quite different from that one.

You can find that link in Jake's main clover guide.


Please try first with those and then report.

Do you have any kext installed in /L/E?





Link to comment
Share on other sites

  • Administrators

Kexts folder is a bit of a mess:

  • Lilu + WEG but alongside, there is FakePCIID_Intel_HD_Graphics + AppleBacklightFixup
  • AirportBrcmFixup alongside AtherosWiFiInjector.kext + IOath3kfrmwr.kext
  • USBInjectAll + USBPorts_E7440 and SSDT-UIAC-E7440.aml in ACPI/patched folder

That ain't gonna work properly...


Clover config:

  • ACPI patch to rename ECDV to EC alongside a patched table SSDT-EC in ACPI/patched folder
  • Drop of CpuPm + Cpu0Ist SSDT tables without a generated CPUPM SSDT whilst PluginType is enabled


Methink things need to be cleaned up and the packs available in existing guides used... And, of course, installing the debug tool would require to unlock the protected file system...

Link to comment
Share on other sites

I realized the mistake!
After all, I apologize to everyone for all the many questions, it was entirely my fault. 😥😱
I'd rather write it before someone else is doing stupid things like that and hurrying ...
At the end of the installation, I hurriedly pressed the forward and backward buttons, leaving the Filevault disk encryption enabled.
That's why Clover couldn't see the boot disk ...
Thank you all again for your help and my apologies for your confusion!


I wish you a very Happy New Year!!!

Link to comment
Share on other sites


  • Create New...