Jump to content

E6330: Need some help dotting the i's


Semaj
 Share

Recommended Posts

My E6330 is near perfect apart from some minor niggles. Would love to get some input in how to fix them. 

 

- Brightness is somehow not remembered (seems to reset itself on boot somewhere).

 

- E-sata and optical bay hot plug isn't working properly. Ejecting works ok but sometimes it hangs when rebooting after ejecting, connecting them to a running system doesn't work at all. This worked on my Mojave install but I can't seem to track down what it is that made it work there.

 

- Side switch doesn't turn wifi and bluetooth off. It disconnects both but leaves the devices themselves on. When enabling them again with the switch only bluetooth devices get connected automatically. I have to connect to the wifi again manually. Turning either or both on/off manually works as expected.

 

Thats pretty much it! I'm attaching the debug logs. Any other improvements, fixes or efficiency gain that I could apply are also very welcomed. I'm striving for the best possible setup 😀

 

Thank you!

 

FWIW my dsdt has the following patches applied:

- Fix _WAK Arg0 v2
- HPET Fix
- SMBUS Fix
- IRQ Fix
- RTC Fix
- OS Check Fixes
- Fix Mutex with non-zero SyncLevel
- 7-series/8-series USB
- Brightness fix HD3000/HD4000 

debug_15508.zip

Link to comment
Share on other sites

  • Moderators

Remove EmuVariableUefi.efi from /EFI/Clover/driversUEFI

You already have AptioMemoryFix.efi.

Use one or the other, not both.

You need to enable "Drop OEM" in Config file since you're using a static DSDT.aml

 

Try adding this patch for the Caddy drive

Kext: AppleAHCIPort

Find:    40600200

Replace: 00000000

 

As for the side switch, that's as good as it'll get. There's no physical toggle switch on a real Mac.

  • Thanks 1
Link to comment
Share on other sites

The Drop OEM option seems to have sorted the brightness. No idea how I ended up with 2 NVRAM drivers haha. I removed one of them. 

 

On top of that hot-plugging e-sata now works again too. I would've never figured out to patch AppleAHCIPort to fix that, I wouldn't even know where to begin. Thank you so much 😃

 

The side switch is not an issue really. Was trying to get every single component to work in macOS.

 

I had to disable the external drive icon fix cuz it would show a network mounted icon instead of external disk icon. Now it shows the normal removable disk icon for caddy/e-sata instead of the internal icon but thats not a big deal. Both cosmetic and I prefer this over the network mount icon 😅

 

Thanks again!

 

PS: totally unrelated but could it be Cloudflare thats messing up the forums javascript somewhere that prevents me from removing old attachments? I tried different browsers and platforms, even tried over mobile data without any ad-blockers and still can't remove attachments somehow.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...