Jump to content

Snow Leopard on D630


tman
 Share

Recommended Posts

I'm trying to install Snow Leopard 10.6.3 (Retail Disc) to a D630, T9300, Intel 965 Video, Dell 1395 Wifi.

 

I can get a vanilla install using MyHack 3.1 to install but no wifi or ethernet. When I then install EDP 1.9.2 and run the edptool it causes the "please restart your system" after reboot.

 

So, next I tried to update the USB installer with a D630-Intel-Video bootpack. That kernel panics after IntelCPUMonitor and FakeSMC.

 

Can someone please tell me what are the correct files and/or sequence I should be running.

 

TIA. Tman.

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

I'm trying to install Snow Leopard 10.6.3 (Retail Disc) to a D630, T9300, Intel 965 Video, Dell 1395 Wifi.

 

I can get a vanilla install using MyHack 3.1 to install but no wifi or ethernet. When I then install EDP 1.9.2 and run the edptool it causes the "please restart your system" after reboot.

 

So, next I tried to update the USB installer with a D630-Intel-Video bootpack. That kernel panics after IntelCPUMonitor and FakeSMC.

 

Can someone please tell me what are the correct files and/or sequence I should be running.

 

TIA. Tman.

 

 

I use myhack 2.1 and it work, same spec as yours but I have the lower resolution screen. 3.1 never worked for me installing SL.

Link to comment
Share on other sites

  • Administrators

Try with ModCD (or ModUSB if you use a USB key) and make sure you copy the Intel_1440x900 DSDT file to /Extra before you reboot upon SL installation completion, otherwise you'll get a black screen at the end.

 

I expect you'll want to upgrade to 10.6.8, in which case I recommend downloading and using the Combo update rather than the on-line update. After combo update installation, install EDP 1.9.2. Launch EDP to install model specifc kexts + Chameleon. Then, copy Intel_1440x900 DSDT file again to /Extra directory because I believe it's replaced somewhere during EDP kexts installation.

 

You should then be able to reboot straight into SL 10.6.8.

 

DSDT file can be obtained here:

https://osxlatitude.com/index.php?/topic/88-dsdt-for-d630d830d530/page__st__20

 

I've detailed my successfull ModCD/ModUSB procedure here:

https://osxlatitude.com/index.php?/topic/1388-d630-intel-screen-goes-black-during-boot-to-install-snow-leopard/page__gopid__9358#entry9358

Link to comment
Share on other sites

Actually.. just test with newest myhack and replace the bootpack ( /Extra ) folder the usb with the right one from here:

 

http://www.osxlatitude.com/packs/?dir=Dell/Latitude

This seems to work for me installing OSX 10.6 but, the minute I run edp 1.9.2 or try to update to OSX 10.6.5 the whole thing goes belly up and I can't boot without a KP. I've been trying to get a working D630 Hackintosh for a couple of days now without any luck. I didn't have nearly as much trouble with my D620. :$

Link to comment
Share on other sites

  • Administrators

This seems to work for me installing OSX 10.6 but, the minute I run edp 1.9.2 or try to update to OSX 10.6.5 the whole thing goes belly up and I can't boot without a KP. I've been trying to get a working D630 Hackintosh for a couple of days now without any luck. I didn't have nearly as much trouble with my D620. :$

 

Use EDP 3.x instead.. its on the forum ;-)

Link to comment
Share on other sites

 Share


×
×
  • Create New...