Jump to content

[Closed] AppleHDA patching requests


plsh2me
 Share

Recommended Posts

  • Replies 390
  • Created
  • Last Reply

Top Posters In This Topic

We're getting somewhere now. v2 & v3 were the closest match.

 

- v1 had devices, but no sound output.

- v2 & v3 had devices, working microphone and internal speaker, but no hdmi audio or headphone jack.

- v4 didn't have any useable devices

 

Results are attached. I used the DSDT.aml from the above zip you posted.

 

Getting very close now. I appreciate your help mate.

Results_2.zip

Link to comment
Share on other sites

Getting really close now! - Just the HDMI to get working.

- v1, v2 & v3 all worked with internal in/out and external in/out, but no hdmi.

- v4, v5 & v6 did not work at all.

 

results attached.

 

When I post results for you, what information do you actually need? So I don't post stuff that you don't need and save some of my attachment space.

 

As seen in my signature, the iGPU is an Intel HD 3000 Graphics on a HM76 7-series chipset.

Results_3.zip

Link to comment
Share on other sites

Getting really close now! - Just the HDMI to get working.

 

- v1, v2 & v3 all worked with internal in/out and external in/out, but no hdmi.

headphone worked ?

 

i forgot to mentioned that no results are required , it was only required when nothing was working , don't worry will let you know what files and when they are required :)

 

HDMI :  apply Below patch in your Config.plist 

		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>HDMI-audio HD3000, 0x00010000, port 0205</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AgUAAAAEAAAHAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				AgUAAAAIAAAHAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>HDMI-audio HD3000, 0x00010000, port 0304</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AwQAAAAEAAAJAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				AwQAAAAIAAAJAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>HDMI-audio HD3000, 0x00010000, port 0406</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				BAYAAAAEAAAJAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				BAYAAAAIAAAJAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>HDMI-audio/VGA(0602) HD3000, 0x00010000, port 0406</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
				AAAAAwQAAAAEAAAJAAAABAYAAAAEAAAJAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				AQIDABAHAAAQBwAABgIAAAABAAAJAAAABQMAAAIAAAAw
				AAAABAYAAAAIAAAJAAAAAAAAAAAAAAAAAAAA
				</data>
			</dict>
		</array>
 
Link to comment
Share on other sites

External out (headphones) did work, yes.

all of three version ?? i have to make it final 

 

Just applied your patch above, but it did not work. still no HDMI.

post config.plist and DSDT 

 

PS: What was the DSDT patch you added earlier? I'm keeping a record of all DSDT patches that are done just in case I need to rebuild my DSDT, etc.

HDEF and IRQ Patch (its neccessary when AppleHDA won't load)
Link to comment
Share on other sites

Yes, the headphones worked properly with v1, v2 & v3.
With the config.plist patches, HDMI did not work with v1, v2 or v3.

Following is my config.plist. I am using the DSDT.aml that you last posted for me to use. I just dropped it in at "disk0s1/EFI/CLOVER/ACPI/patched/DSDT.aml"
 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ACPI</key>
    <dict>
        <key>DSDT</key>
        <dict>
            <key>Debug</key>
            <false/>
            <key>DropOEM_DSM</key>
            <false/>
            <key>ReuseFFFF</key>
            <false/>
        </dict>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <false/>
            <key>Generate</key>
            <false/>
        </dict>
    </dict>
    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>-v</string>
        <key>Debug</key>
        <false/>
        <key>DefaultVolume</key>
        <string>MacOS</string>
        <key>Legacy</key>
        <string>PBR</string>
        <key>Secure</key>
        <false/>
        <key>Timeout</key>
        <integer>3</integer>
        <key>XMPDetection</key>
        <false/>
    </dict>
    <key>CPU</key>
    <dict>
        <key>UseARTFrequency</key>
        <false/>
    </dict>
    <key>Devices</key>
    <dict>
        <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <false/>
            <key>Inject</key>
            <true/>
        </dict>
    </dict>
    <key>GUI</key>
    <dict>
        <key>Hide</key>
        <array>
            <string>Recovery HD</string>
        </array>
        <key>Language</key>
        <string>en:0</string>
        <key>Mouse</key>
        <dict>
            <key>DoubleClick</key>
            <integer>500</integer>
            <key>Enabled</key>
            <true/>
            <key>Mirror</key>
            <false/>
            <key>Speed</key>
            <integer>8</integer>
        </dict>
        <key>Scan</key>
        <dict>
            <key>Entries</key>
            <true/>
            <key>Legacy</key>
            <false/>
            <key>Linux</key>
            <true/>
            <key>Tool</key>
            <false/>
        </dict>
        <key>ScreenResolution</key>
        <string>1920x1080</string>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>Inject</key>
        <false/>
        <key>NvidiaSingle</key>
        <false/>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleRTC</key>
        <false/>
        <key>AsusAICPUPM</key>
        <false/>
        <key>Debug</key>
        <false/>
        <key>KernelCpu</key>
        <false/>
        <key>KernelHaswellE</key>
        <false/>
        <key>KernelLapic</key>
        <false/>
        <key>KernelPm</key>
        <false/>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>HDMI-audio HD3000, 0x00010000, port 0205</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AgUAAAAEAAAHAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                AgUAAAAIAAAHAAAA
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>HDMI-audio HD3000, 0x00010000, port 0304</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AwQAAAAEAAAJAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                AwQAAAAIAAAJAAAA
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>HDMI-audio HD3000, 0x00010000, port 0406</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                BAYAAAAEAAAJAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                BAYAAAAIAAAJAAAA
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>HDMI-audio/VGA(0602) HD3000, 0x00010000, port 0406</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
                AAAAAwQAAAAEAAAJAAAABAYAAAAEAAAJAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                AQIDABAHAAAQBwAABgIAAAABAAAJAAAABQMAAAIAAAAw
                AAAABAYAAAAIAAAJAAAAAAAAAAAAAAAAAAAA
                </data>
            </dict>
        </array>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>BiosReleaseDate</key>
        <string>04/22/11</string>
        <key>BiosVendor</key>
        <string>Apple Inc.</string>
        <key>BiosVersion</key>
        <string>MBP81.88Z.0047.B0E.1104221557</string>
        <key>Board-ID</key>
        <string>Mac-94245B3640C91C81</string>
        <key>BoardManufacturer</key>
        <string>Apple Inc.</string>
        <key>BoardType</key>
        <integer>10</integer>
        <key>ChassisAssetTag</key>
        <string>MacBook-Aluminum</string>
        <key>ChassisManufacturer</key>
        <string>Apple Inc.</string>
        <key>ChassisType</key>
        <string>08</string>
        <key>Family</key>
        <string>MacBook Pro</string>
        <key>Manufacturer</key>
        <string>Apple Inc.</string>
        <key>Mobile</key>
        <true/>
        <key>ProductName</key>
        <string>MacBookPro8,1</string>
        <key>SerialNumber</key>
        <string>C02JQ4DCDH2G</string>
        <key>Trust</key>
        <false/>
        <key>Version</key>
        <string>1.0</string>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>InjectKexts</key>
        <string>Yes</string>
    </dict>
</dict>
</plist>

 

 

Link to comment
Share on other sites

WE HAVE A WINNER!!!

The config.plist that you sent in that last zip caused issues with my graphics; It made the desktop appear 4x on the Laptop's LCD panel. So, I reverted back to using just the 4 patches you asked me to try earlier, but this time I did them 1 at a time. The first 3 all worked enabling HDMI audio, but the 4th one, the one with something about VGA in the comment, disabled my HDMI altogether (both Audio & Video).

I also updated the DSDT.aml and AppleHDA.kext to the ones in your latest zip. Sound seems to work well. Sounds clear, and no interference of any kind that I can detect.

Now all thats left to do is set it up so that I can load/patch the AppleHDA.kext from clover (Something like AppleALC.kext), leaving the stock AppleHDA.kext in place, keeping the system safe from updates. What ideas can you provide here?

Thanks for everything you have done.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...