Jump to content

Latitude E7270 - KP with OC Big Sur install


Recommended Posts

Hi everyone!

 

So I'm trying to upgrade my Latitude E7270 to Big Sur and I keep running into problems. I'm using Jake Lo's boot pack for the Latitude E7270 found here:

However, I keep getting kernel panics when I boot. I've kept the boot pack stock, with the exception that I changed the WiFi cards properties from:

<string>pci14e4,43a0</string>

to

<string>pci14e4,43b1</string>

to match my card

 

But it's a no go. I also tried to disable VoodooPS2* as they were causing earlier KP's. The laptop is running fine under Catilina with OC for the bootloader. I have tried using my current EFI, but it doesn't seem to work with OC.

 

Does anyone have any suggestions?

 

Thanks!

 

zog

E7270_kp_1.jpg

Link to post
Share on other sites
  • Administrators

Why change the device property for your wireless card to that of BCM4352 (14e4:43b1) which is not natively supported in Big Sur when your signature shows "BCM94360 w/ adapter" ? Given the mention of an adapter, I can only assume it's an Apple Card which is obviously supported OOB and would not require any property injection other than cosmetic ones to be listed in SysInfo (model & slot-name). But certainly no compatible statement required and not one to declare compatibility with any unsupported card.

Link to post
Share on other sites

Thanks @Jake Lo!

 

I went into my config.plist and then under "Quirks" I set "ReleaseUsbOwnership" to YES and I was able to boot and start the install. However, after rebooting, the basic install goes back to the install screen, without continuing the install. I think that I need to edit the config.plist, however I need to wait until tomorrow and use a friends Mac to edit, because my other machine is in Europe right now! :(

 

I'm attaching my EFI for Catalina, hopefully you will be able to do something with it.

E7270 Clover EFI.zip

 

Thanks!

zog

 

 

 Hi @Hervé,

 

I need to update my signature. I'm running a Lenovo 04X6020 / BCM94352Z for my WiFi card. It has a PIC ID of 14e4:43b1. I have 2 DW1820A's enroute from China to replace this card and the one in my E7250.

 

Although, it might make my life easier to cram the BCM94360 back in. As you say, it works out of the box.

Link to post
Share on other sites
  • Moderators

After the reboot, make sure to select the USB installer to boot. At the OC Picker select the new boot option "Install MacOS..." to continue the installation. Will 3-4 reboots before it's completed

Link to post
Share on other sites

@Jake Lo

 

I managed to open my EFI partition using Linux, here's the command for anyone else that needs to do the same:

sudo fdisk -l /// find your EFI partition
sudo mount /dev/sda1 /mnt

 

That's it. Go to you "/mnt" folder and grab your EFI.

Copy the config.plist and then edit it with the online editor. After that, copy it back to the EFI folder with the following command:

sudo mv /Desktop/config.plist /mnt/EFI/OC/

 

After that, I found an online OpenCore configurator here:

https://galada.gitee.io/opencoreconfiguratoronline/

 

That I can edit my config.plist with. However, I can't find the field to create a path to complete the install. 

 

online_oc_configurator.png

 

After I reboot, the USB dumps me back into the main install screen, it doesn't continue the install.

Link to post
Share on other sites

OK, so I had some time today to go back a fiddle with my E7270. The install not continuing didn't make sense, but then I remembered that some Western Digital NVMe drives have trouble with OS X. I swapped out my WD Black PCIe 512GB, (WD512G1X0C-00ENX0), with my 256GB Hynix SC300. The Hynix drive is SATA III and the installation went as normal.

 

Is there anyway to get the WD drive to work with OSX? It worked fine with Catalina, so I am a bit confused as to why it won't work under Big Sur.

 

 

 

Link to post
Share on other sites
  • Moderators

Looks like my post got deleted due to the storage failure.

Anyway, I looked at your Clover file and noticed you have an NVMe patch. I have not seen a new patch around for Big Sur but you could certainly try and see if it still work on Big Sur

Under kernel / patch:

Comment: IONVMeFamily patch for SSD Liteon etc. (c)jief_machak

Find: 0F834E01 0000

Replace: 90909090 9090

Identifier: com.apple.iokit.IONVMeFamily

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...