Jump to content

Latitude 7400 2-in-1: no graphics acceleration/Touchpad in Big Sur (OpenCore)


tommyluco
 Share

Recommended Posts

Hello,

I am trying for hours to even get the installer to boot and I am stuck here.

I even tried EFI folders from other people here in the forum with 7400s

Sadly I cannot get it to run.

I attached the EFI folder + logs and hopefully someone can help me to resolve that.

EFI and Log.zip

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

  • Moderators

You're mixing OC files..it's a NO NO.

Your drivers are from OC 0.6.7 but your Config file is below 0.6.6, major changes to the bootloader since 0.6.5.

Give this Config a try

Delete the Bootstrap folder

Go to the BIOS under Boot List, if OpenCore exist, delete it.

Boot to OC Picker, select Reset NVRam

After reboot, select the Installer

config.plist.zip

Link to comment
Share on other sites

  • Moderators

@tommyluco

Honestly, that log file tells me nothing or I don't know how to interpret it.

Best that you grab the screenshot before it reboots

add this to boot arg under NVRam, see if it'll help with the KP

-v keepsyms=1 debug=0x100 igfxonln=1 alcid=77

 

Also, might be a good ideas to update all the kexts to the latest especially these

  • Lilu
  • AppleALC
  • Whatevergreen
  • VirtualSMC + plugins (SMCBatteryManager, SMCLightSensor...etc)
Link to comment
Share on other sites

I was already thinking of just removing all the stuff just to the bare minimum to make it bootable and go from there, what do you think? 
i would need to know what the absolute minimum is to get it to boot (if you have any instructions about that that would be great)

and then add piece by piece to see where it fails. 

I just want to reduce possible point of failures to be able to make progress 

Link to comment
Share on other sites

  • Moderators

You can disable all the sensor kexts in the Config file, no need to delete from the Kexts folder.

If it's not enable in the Config file, it won't load.

QQ: Does system have an NVMe drive? If yes, which model. Please note, not all NVMe are supported. For example PM981 or PM981a, etc. Check FAQ for more info

Link to comment
Share on other sites

I finally got some time to "attack" this.

 

Thanks for helping me thus far (started from scratch with OC 0.6.9


I got Big Sur to install.

There are a few things I can't get to run.
1. GPU shows: Intel UHD Graphics 620 7 MB (followed dortanias instructions but I must've misconfigured something)

2. Trackpad isn't working (tried this l2C thingy but I must've done something wrong)

3. Keyboard isn't working (didn't try to fix that yet, but if anybody has a hint where to start, would be great)

I attached my entire EFI config so I hope someone can help me :)

EFI.zip

Link to comment
Share on other sites

Posted (edited)

I added it to my signature, I hope that is sufficient information, if not, please let me know what other information you need

I also changed the topic as I think the new one is a bit more descriptive

Edited by tommyluco
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...