Jump to content

Samsung Galaxy Chromebook Hackintosh


Recommended Posts

 @Hervé and @Leon With your help, we got Mojave working on the Google Pixelbook. I've since started on a new project, the Samsung Galaxy Chromebook. It's very similar to the Samsung Galaxy Flex, but I'm having some difficulty again with graphics acceleration and was wondering if you wouldn't mind giving this a look. Here are the specs of the machine:

  • CPU: Intel i5-10210U
  • GPU: Intel UHD 620
  • Catalina installed, with the following working: Wifi / bt, internal NVMe SSD, battery percentage. 
  • Touchpad, touchscreen, and audio not working but this is secondary. 
  • Custom DSDTs generated from DSDT.aml intead of prebuilts. I have also used OC guide prebuilts with same result below.


I've attached my ioreg and the current EFI I'm working with. Following the OC guide for Comet Lake, the platform-id 00009B3E gives 31mb VRAM. I've tried all of the framebuffers listed on Whatevergreen's wiki for CFL / CML. None result in full 1536 VRAM. This machine has a 4K screen, I've also tried the dpcd-max-link-rate of 14000000 but you'll see I have that commented out for now in the config. 


One peculiar thing is the device-id gives a kernel panic unless I use an invalid one. So the guide specifically states "An UHD620 in a Comet Lake CPU requires device-id=9B3E0000" however this results in a panic. If I use 12345678 or no device-id at all, it will boot with 31mb VRAM. 


My question is, like with the Pixelbook, are there specific framebuffer arguments for the UHD 620 on Comet Lake that would help me to get it to boot? Or any other tips for getting the UHD 620 to work on Comet Lake? Thanks so much! 

olm3ca’s SGC.ioreg EFI.zip

Link to comment
Share on other sites

  • Administrators

Your posted IOreg shows that your Comet Lake i5-10210U is fitted with Intel UHD for 10th ten processor iGPU with id 0x9B41. But is it its native id or just the result of the property you injected (please note that injecting any device's native id is totally pointless)?


According to the Intel specs which I tried to summarise here, iGPU id 0x9B41 is a 24xEUs iGPU model which can therefore be expected to be supported, but not OOB. As per the WEG user manual, I believe 2 x iGPU properties need to be injected, at minimum:

  • ig-platform-id 0x3EA50009, not 0x3E9B0000 which is for Coffee Lake iGPUs.
  • device-id 0x3E9B

and MacBookPro16,1 (or MBP16,3 why not?) SMBIOS alongside.

  • Like 1
Link to comment
Share on other sites

@Hervé Thanks so much for the fast response. I can report that, for the first time, I can use a device-id without a kernel panic! Unfortunately I still have 31mb, but just to confirm the following:

  • Yes, the hardware ID of the chip is 8086:9B41 => i5-10210U (Mobile UHD 620). Your post on this iGPU was really helpful.
  • I'm using SMBIOS MacBookPro16,3 as it seems to be slightly more aligned with my hardware
  • platform-id is 0900A53E and device-id is 9B3E0000. Boots with 31mb VRAM
  • I'm using the framebuffer args from the OC guide (fbmem, stolenmem). I can also boot without them, so they don't appear to be having any effect.

Any other suggestions are welcome! Getting closer, thank you again.

Edited by olm3ca
device-id typo.
Link to comment
Share on other sites

  • Administrators

Try and experiment with Whiskey Lake UHD620 settings:

  • ig-platform-id 0x3EA50009
  • device-id 0x3EA5


The only other alternative I could suggest would be Kaby Lake R settings but I somehow doubt it would work:

  • ig-platform-id 0x591B0000 or 0x59160009 for instance (I used latter on my previous KBL R/UHD620 Latitude 7490) or any other KBL mobile id
  • device-id 0x5916
Link to comment
Share on other sites

Thanks. It's being quite stubborn. I've tried a lot of combinations and thus far it remains at 31mb. Out of curiosity, @Jake Lo - how did you figure out the framebuffer args for the Pixelbook last time? Was it something you gathered from Hackintool or another method? 

Link to comment
Share on other sites

  • Moderators


Looking at your Config file, if you're using 00009B3E, make sure you set device ID = 9B3E0000 (fakeID)

I searched what others use to get acceleration with the same CPU. I've seen other have also use

AAPL,ig-platform-id =0000A53E 

device-id = A53E0000 

Macbookpro15,2 or MacbookAir9,1


Link to comment
Share on other sites

Really appreciate the reply @Jake Lo. I've tried these and still no luck. Another strange occurrence right now is that itlwm and Airportitlwm are failing. I used to be able to use Airportitlwm, but gave up and switched to itwlm with Heliport. Now itwlm is also failing. One thing about these Chromebooks is that nvram never works the way it should, so I wonder if something is up there.


Anyway, if you have any other ideas, I'll be trying as many combinations as I can think of for this iGPU. On a normal machine it would have worked by now, I'm sure!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...