Jump to content

Windows dualboot installation problem on Dell E7440


Marcobingo13
 Share

Recommended Posts

Hi, I have a Dell Latitude E7440 and have installed macOS Big Sur with Opencore 0.6.9, following this guide.

MacOS everything works fine, the problem I encountered is with installing Windows 10 in dualboot. Regardless of whether Windows 10 (UEFI) is on USB for installation or already installed on the SSD, starting it from Opencore Bootloader the Windows loading wheel spins for about a second then restarts the computer.

I also tried with previous versions of Opencore always from the same guide and it always reports the same problem.

I think it is due to a parameter in the config.plist.

Thanks for your work

IMG_1394.thumb.JPG.ce5756a640a01d5a73a7a6d6d5ffd31d.JPGIMG_1393.thumb.JPG.797c85d99164e8dada7f63ded9d9222c.JPG

Link to comment
Share on other sites

If Win 10 starts when you use the microsoft boot loader then your problem lies in the PlatformInfo, smuuid section of the config.plist. If windows doesn't have the proper UUID, it will do exactly what you describe.

 

To find Win 10 uuid, start it with the windows boot manager (so it runs) and then:

Open an administrator command prompt.

Type the command: wmic path win32_computersystemproduct get uuid.

Press the "Enter" key.

Only the UUID for the computer should be displayed.

 

It is in the form 1A2B3456-7890-1234-5678-C9D01E234567.  THIS IS NOT A REAL UUID it's just to give you an idea of what it looks like.

 

After that you put this number in the smuuid section of PlatformInfo in the config.plist. The only problem being that if you already have registered the platform info with Apple (via the Apple ID), it will be seen as a different machine. It happened to me but they let it go (meaning I still have IMessage, mail and everything working.

Link to comment
Share on other sites

I think I've tried them all, but haven't been able to fix it yet.

There is another thread with the same problem, but still no solution. Again this is a Dell notebook and an EFI folder made by JakeLo.
Selecting the Windows Boot Manager when starting with F12, Windows will start without problems, instead when I select Windows from the Opencore GUI, it stops after a second and restarts the PC.

 

Thanks everyone for your time.

 

Link to comment
Share on other sites

Hi everyone,

 

I enabled the SyncRuntimePermission quirk and this solution worked for my Z240 desktop: I have an HDD with Windows 10 and a PCI-SSD with Big Sur (with OC 0.6.9). OC lays, of course, on the SSD EFI partition.

I did not reset the NVRAM and Windows started directly from OC.

 

Thanks @Jake Lo!

Link to comment
Share on other sites

 Share

×
×
  • Create New...