Jump to content

Latitude 5510: unable to install macOS


Recommended Posts


I own a Latitude 5510 too. I've read this 5510 thread but sadly, all my try outs failed.

My system's specs:

10th gen. Comet Lake i5-10210U
UHD 620 graphics
8GB 3200MHz DDR4 Non-ECC
Intel Wi-Fi 6 AX201 2x2 802.11ax 160 MHz + Bluetooth 5.1


Could any of you point me to a working prep. for the macOS install and perhaps the EFI Folder with OC prepared? I'd be thankful. My last Hackintosh was not that hard :D

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Tried it with Big Sur Installer, but the error remains the same




seems not all opencore files are the same. I updated the the files and now get to:




I then tried 


On 3/27/2021 at 5:11 AM, murkie said:

@Jake Lo I got around to adding the files you posted. 


  • Trackpad works now, however it's laggy and when you first touch it the cursor jumps to a random spot on the screen
  • Trackpad buttons don't work, strangely when I left click and drag on the desktop it starts to drag out a selection square but disappears after about a second, none of the 5 buttons work for anything else though
  • SD card reader works 😀

EFI.7z 19.53 MB · 13 downloads


got to press install macos, the apple logo appears but it stuck there seemingly. 



With no error message, it stays there.

The fans begin to drive high but nothing happens for a very long time 

Link to comment
Share on other sites

I feel foolish to ask - but to which EFI?

The file you added that miss-matching open cores.. the ones from other ones don't install but I don't see where to add it.


Would you mind setting me up with an new EFI-Folder ? 

Perhaps @denkteichcan help, too? :)


So i took your EFI, updated opencore to match and added the comment. this is the error I get: 


the EFI as it stands it too big to attach 



Link to comment
Share on other sites

Hi you all, I installed Big Sur on my Latitude 5510.



  • Comet Lake i5-10310U
  • Intel UHD 620 / AMD Radeon RX 640 graphics
  • 16GB DDR4 3200MHz RAM
  • M.2 2230 NVME SSD (Gen3 x4)
  • Realtek ALC3204 audio
  • Intel I219LM Gigabit Ethernet
  • Intel AX201 wireless


I first installed Catalina via OpenCore. Then I updated to Big Sur via the AppStore. 


What works:

  • keyboard backlight, volume buttons, hotkey.  Fn keys for brightness
  • internal speakers, microphone and camera works
  • battery level
  • Ethernet


What does not work:

  • graphics acceleration
  • trackpad
  • headphone input
  • wifi & bluetooth
  • HDMI
  • sleep and wake


It's really weird, I never had this kind of problem with my other Hackintoshes.
Could someone please help me?
Thank you in advance for your answers.


Capture d’écran 2021-05-17 à 01.13.50.png


Latitude 5510 Hack.ioreg config.plist.zip

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...