Jump to content

Latitude 5510: unable to install macOS


Recommended Posts

  • Moderators

Did you try the file I attached here ?

or maybe try to integrate or adapt some of the stuff from it?

I should include touchpad, sdcard reader, HDMI, sleep / Wake

You'll need to add an SSDT-DGPU.aml to disable the DGPU, since it's not supported and will cause extra battery draining.

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Hello Jake,

Yes I tried it in the 1st place but no trackpad with it 😕

I got WIFI, Ethernet, Audio who's working with your files but the headphone input works strangely. The sound is extremely saturated.

Now I tried to add SSDT-DGPU but my screen stay black after Big Sur start to load. 

Link to comment
Share on other sites

@Jake Lo

I made a new fresh install.

I first installed Catalina with the OpenCore method. Then I upgraded directly to Big Sur with the AppStore.

Then I used the EFI Latitude 5510 folder you posted. I had a compatibility concern with OpenRuntime r12, r11 was required. 

Then I remembered that @murkie posted different EFI.zip. I took the last one he posted. I mix with your files to find the good settings. After several tries, I managed to make an EFI file that works well.
Everything works like a charm (Graphics, WIFI, Ethernet, Bluetooth, HDMI, Audio, Camera, Keyboard, Backlight, Hotkeys, Volume buttons, fn Key for brightness, Sleep/Wake).
Only the trackpad does not work at all.
It drives me crazy Ahahaha 



Capture d’écran 2021-05-18 à 01.20.33.png

Latitude 5510 HackBookPro.ioreg config.plist.zip

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...