Jump to content

7490: issues with sleep, power-off and wifi in Big Sur and Monterey


Go to solution Solved by Hervé,

Recommended Posts


I am getting a bit desperate trying to resolve sleep issues in 7490 in Monterey/Big Sur.

I would be grateful for help or pointing in the right direction.



* either fix sleep issues
* or mitigate these issues by disabling sleep completely
* understand why WIFI is so slow? Currently only getting 250Mb on DW1560 with all kexts and patches.


Due to COVID, I worked for 2+ years from home. I built myself a desktop Hackintosh workstation as that was really the only viable option long-term, without shelling $3000+
Now I am expected to work from the office twice a week. I need a Hackintosh laptop to maintain my workflow. I bought this 7490 two weeks ago with the sole purpose of converting it to a budget MacBookPro. 

Everything that is important works pretty much out-of-the-box. The only missing piece is:
* WIFI - got it working with DW1560 but slow. Can't make Intel 8265NGW working again at all. And I had much better speed (650Mb) when I tired initially in Monterey.
* SLEEP - this is in fact critical to me in a laptop, as I can't imagine sitting in the 3h meeting and when it goes to sleep - I need to hard-reset it to work again. Absolute showstopper. Even after installing CAFFEINE laptop still switches off the screen when closing the LID and the sleep problem occurs.
* Laptop also does not SWITCH-OFF, but that's like the least of my current problems. I however think it is linked to the sleep issue.

MacOS installed fine and booted OK. Pretty much all was working until I started testing sleep.
I tested by inducing the sleep mode using:
* the LID
* Fn+INS
* Sleep option in MacOS
* MacOS timeout when running on battery.

The behaviour was pretty much the same each time:
* The laptop's keyboard lights up
* CPU goes into overdrive
* The screen remains dark and I can only switch it off by holding the power button.
* It also does not switch off - when I shut down the OS, it looks like it's shutting down but the power light stays on - until, again, I hold the power button.

When the laptop is plugged in to the mains and the screen times out (goes dark) - it wakes up fine. I guess in never actually goes to sleep - it just blanks the screen.
Any other option: LID, Fn+INS, Sleep in the menu - same results as listed above, even when plugged in.

* I tried both BIG SUR 11.2.3 (to build my own USBPorts.kext) and MONTEREY 12.3.1. Same behaviour.
* I tested both BIOS versions: 1.24.1 and 1.16.0. Same results, although on 1.16.0 I can't make WIFI work after downgrade. (downgraded from 1.24.1 - some modules like Intel ME did not downgrade!). I reverted back to 1.24.1
* I disabled the hibernation as per @Jake Lo guide and followed @Hervé BIOS settings recommendations.
* I've seen a similar problem on the forum but the solution provided did not help (https://osxlatitude.com/forums/topic/17079-latitude-5490-no-sleepshutdown-under-monterey/)
* I tried in OC 8.0 (after updating all KEXTs). I then dialled it down and tried in OC 7.5 and OC 6.8 - updating KEXTs along the way as Airportitlwm refused to work without updating it (and LILO as well). I always cleaned NVRAM between reboots.
* I tried with both USBInjectAll.kext in Big Sur and with my own USBPorts.kext in Monterey - no difference.
* I have no devices plugged into the laptop except Logitech trackball (to navigate on the screen as sometimes touchpad was not responsive)
* I used various SMBIOS: from MacBookPro 14,2 to MacBookPro 15,2 - no difference.
* I tried several different EFIs and started to build my own - but that's way to many variables to consider. Would take me 6 months.
* Tried both Kabby Lake-R and Coffee Lake CPU IDs (recommended settings in Dortania guide) - same results.


Currently running on EFI with OC 0.8.0 from @Jake Lo, posted here:


My current EFIshttps://jarocki.cloud/index.php/s/HBLKnmRYCLMmsnC


Also tried the following EFIs:

* https://osxlatitude.com/forums/topic/16892-latitude-7490-unable-to-update-to-monterey/page/2/
* https://github.com/lohseng97/Dell-Latitude-7490-EFI-macOS-BigSur
* https://github.com/Swung0x48/Dell-Latitude-7390-7490-Hackintosh-EFI
* https://osxlatitude.com/forums/topic/17159-solved-latitude-7280-stuck-trying-to-install-monterey/page/2/
* https://osxlatitude.com/forums/topic/17142-latitude-7390-external-hdd-shown-as-internal/
* https://osxlatitude.com/forums/topic/17003-latitude-7280-sleepwake-issue/
* https://osxlatitude.com/forums/topic/16247-dell-latitude-7490-building-opencore-efi-for-big-sur/page/9/

Got pretty much same results on each. Sometimes had to change configuration to make the iGPU work or to make the WIFI work.


Latitude 7490
BIOS: 1.24.1
32GB RAM (2400MHz) - perhaps too much RAM?
Audio: Realtek ALC3246
SSD: Samsung 970 EVO Plus 1TB NVMe - perhaps incompatible NVMe?
WIFI: DW1560 M.2 WiFi 802.11AC. Working but quite slow. I also have Intel 8265NGW but can't make it to work anymore with Airportitlwm.

My IOReg file attached.


Link to comment
Share on other sites

  • Administrators

Quick answer before I get the time look at your posted EFI + IOReg.

Too much RAM (32GB) -> No.

Slow Wifi (capped at 250Mbps) -> you're probably on a 2.4GHz network; you'll have to hook to a 5GHz network to get beyond this and reach up to 867Mbps


I no longer have a 7490 but, during the time I had one, sleep/wake/restart never were a problem at all. Must be some incorrect settings or issues with the kexts you inject. I suspect ACPI patches and/or CPU power management. Start by disabling those CPUFriend kexts if you copied then from a repo rather than generate your own data (always a bad idea for the data kext, it has to match your CPU and desired power settings).

Link to comment
Share on other sites

Thanks @Jazzoo

I can't open that link. I got: 

"You cannot access this content because it violates our Terms of Service.

For more information on this topic, see the Google Drive Help."

Would you mind dropping it here: https://jarocki.cloud/index.php/s/DZXCAzRYgDjXcC6


Thanks @Hervé for the prompt reply.



Indeed I had some CPUFriend kexts there. I disabled them and reset NVRAM - no change. I fact when I started building my minimal EFI from scratch using Dortania guide - I had the same behaviour. It look like no matter what you throw at it - same results. When I was testing various EFIs, I stumbled upon one where sleep/wake worked but only once. The first boot was extremely slow and then sleep worked once. On the second boot - back to standard.

Also - power-off never worked.

The EFI that worked once is called EFI3.zip and it's here: https://jarocki.cloud/index.php/s/HBLKnmRYCLMmsnC



I do connect to 5GHz networks. That's were I get 250Mbps downstream and around 300Mbps upstream.

On 2.4GHz, I get half that: 100-120Mbps downstream.


Link to comment
Share on other sites

  • Administrators
  • Solution

I don't think it'd have any influence on Sleep/Wake but it certainly could on a boot time perspective but Samsung 970 Evo Plus was not natively supported unless firmware was updated; can't say which version but it'd be worth checking whether you run on the latest version or not:


Link to comment
Share on other sites

OK - will check. Thanks.


WIFI (Broadcom) In the meantime:

Did a check if perhaps I damaged my WIFI antenna cables or the card itself during network card replacement - I booted MX Linux from the USB and enabled Broadcom drivers. WIFI works and I get 640Mbps DOWN and 530Mbps UP on fast.com

So there must be something wrong with my kexts or one of the patches for Broadcom. If I disable all BCM kexts and patched and boot with vanilla drivers - the card works out-of-the-box but I get abysmal speeds - something like 45Mbps.


Link to comment
Share on other sites

It was the bloody SSD! Thanks @Hervé !!! Although the firmware was latest - it did not matter. I even installed Win10 and run Samsung Magician to be sure that it's the latest and it was. 

The problem is Samsung 970 Evo Plus!

Despite there are reports that it works with MacOS - it was actually the cause of all problems with SLEEP/WAKE and POWER-OFF.


I replaced the SSD with the original Intel-one that was shipped with 7490 and SLEEP/WAKE and POWER-OFF works like a dream. Even without disabling the hibernation.

The laptop is much quieter, and sleep just works using all methods (LID, Fn+Ins, Sleep option, etc.). I couldn't believe it!

It then wakes up super fast after pressing the power button. Behaves totally native.


Power-off also works and the shutdown takes a bit faster.




Ordered a new 1TB SSD (WD Black SN750).




I also have a suspicion about the BROADCOM WIFI.


This might be not relevant and I might be on a wrong path - but I think my USBPorts.kext is incorrect.

Broadcom HUB shows under the HS port and not the SS port. Screenshot from Hackintool attached.

HS is capped at 480Mbps and is most likely chocking the card.


I know there are issues with running USBInjectAll.kext under Monterey.

What would be your suggestion to map the ports?


@Jazzoo for the time being I would like to still troubleshoot the Broadcom card. And I think I already tried that EFI with the Intel card. That would be my last resort if the Broadcom troubleshooting fails ;-)


Screen Shot 2022-05-10 at 02.48.04.png

Link to comment
Share on other sites

  • Administrators

The Wifi part of the wireless card is PCIe based whilst the Bluetooth part is USB used. As such, slow Wifi performance cannot be linked to an issue with USB port mappings. What you see in Hackintool is normal, it's the speed of the USB devices, not the speed of the ports themselves.

Link to comment
Share on other sites

Thanks @Hervé  Good point.

What would be your suggestion to continue the Broadcom troubleshooting next?

Or should I just give up on Broadcom and try to resurrect the Intel card? It seems that it requires a lot less tinkering with kexts and patches.

I don't care about Bluetooth anyway.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...