Jump to content

[Solved] HP 650 g1: Display Port output under Monterey


mr.kasper
 Share

Recommended Posts

  • Administrators

Haswell framebuffer layout 0x0a260006 defines the following graphics properties:

ID: 0A260006, STOLEN: 32 MB, FBMEM: 19 MB, VRAM: 1536 MB, Flags: 0x0000000F
TOTAL STOLEN: 52 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 116 MB, MAX OVERALL: 117 MB (123219968 bytes)
Camellia: CamelliaDisabled (0), Freq: 2777 Hz, FreqMax: 2777 Hz
Mobile: 1, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[0] busId: 0x00, pipe: 8, type: 0x00000002, flags: 0x00000030 - ConnectorLVDS
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x00000087 - ConnectorDP
[2] busId: 0x04, pipe: 9, type: 0x00000400, flags: 0x00000087 - ConnectorDP
00000800 02000000 30000000
01050900 00040000 87000000
02040900 00040000 87000000

DP should work OOB off connector con2. HDMI requires to change connector con1's type to HDMI and pipe to 0x0A.

 

Check out your connectors behaviour in IOReg (using an app such as IORegistryExplorer) when you hook up your external screens.

Link to comment
Share on other sites

  • Administrators

System freeze on cable connection/disconnection was/is typical behaviour with HDMI on Haswell/HD4600 laptops; this is fixed by patching the connector con1 (0105) pipe value from 0x09 to 0x12; you need to do that same for DP connector con2 (0204) as described in this old Haswell HD4600 patching guide for reference.

 

Edit: Never mind, that's what Jake's done his the adjusted config file he posted just above.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...