Jump to content

Lenovo Thinkpad L570


CroJack
 Share

Recommended Posts

Hi :)

 

Is there an EFI pack for Monterey for this laptop configuration?

  • Mainboard: Intel Kaby Lake-U Premium PCH
  • Processor: Intel Kaby Lake Core i5-7200U 2.5-3.1GHz
  • Memory: 8GB DDR4-2400
  • Graphics: Intel HD 620
  • Display: 15.6" 16:9 1920x1080 IPS 
  • Storage: 250 GB Samsung PM961 NVMe SSD (MZVLW512HMJP, PCIe 3.0 x2), connected via M.2 on SATA Express adapter
Link to comment
Share on other sites

  • Administrators

Nothing here for this laptop afaik. You'll have to make one up, starting with basic usual settings for a regular Kaby Lake/HD620 laptop, then adding whatever may be required for your hardware accessories (LAN, WLAN/Bluetooth, audio, SD card reader, etc.).

 

Can't remember if Samsung PM961 SSD is supported, unlike its PM981/PM991 brothers which don't allow to install/run/boot macOS on them.

SATA Express? Wow, can't be many machines fitted with that.

Link to comment
Share on other sites

It worked :) . I've installed Monterey on am external HDD because I don't have a compatible Wi-Fi card yet. The Intel one doesn't work. I'll run IORegistryExplorer tonight and post IOReg file here. Thanks a lot Jake Lo. :)

Link to comment
Share on other sites

 

CroJack’s MacBook Pro.ioreg

 

 

 

684654244_Screenshot2023-01-03at00_20_29.thumb.jpg.4b490e78d861ee92f41ffc37d330628c.jpg

 

 

Wi-Fi (Intel dual band wireless ac 8265) is not working. I tried with itlwm.kext (for Monterey) and HeliPort.app, and removed Airportitlwm.kext, but no luck. HeliPort.app shows wireless networks and even that I am connected to my own network, but there isn't any real connection to the internet. Intel(R) Dual Band Wireless AC 8265 should be compatible with OpenIntelWireless, so I'm probably doing something wrong.

 

 

Brightness control doesn't work either.

Link to comment
Share on other sites

UPDATE!!!

 

Wi-Fi works now.

 

Had to delete Ethernet port in SystemPreferences/Network and

 

com.apple.airport.preferences.plist

preferences.plist

NetworkInterfaces.plist

com.apple.network.identification.plist

 

in /Library/Preferences/SystemConfiguration

 

After reboot Wi-Fi started working. :)

Link to comment
Share on other sites

  • Moderators

Looks like I placed the wrong kernel limit for the AirportItlwm_Monterey.kext

Fixed that, added patch for SD card reader, fix Powermanagement.

Give this a try. replace Config and SSDT. Put AirportItlwm_Monterey.kext back in kexts folder

Post new IOReg file after the update

Archive.zip

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...