Jump to content

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)

Recommended Posts

Hello, I have a really big problem. 

KEXT works, no problem with keyboard but with touchpad...

Any multigesture isn't working. Two fingers tap, two fingers scroll - not even talking about 3-4 fingers gestures.

Works only - 1 finger tap.


Can you help me please ? 

- My touchpad is Synaptics - HP Elitebook 840 G3.


Best regards,

Link to post
Share on other sites
  • Replies 1.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Last update: 17 Sep 2017   UPDATE: 17 - 09 - 2017 Just wanted to clear few things about my commitments to community, and development on my projects which has been going slow due to my personal life

@EMlyDinEsH It's been more than 2 years since last update of the kext and about 1,5 year since last update of the first post. Can you finally release the source code, so someone could finally improve

macOS Sierra: some Fn keys do not work and trackpad work only as mouse. Please fix.

Posted Images

Driver works very well on my XPS 9550 running macOS High Sierra, much better than Voodoo. However, when I use this driver, sleep no longer works, which is a must for me as I travel a lot with my laptop. Is this a known bug? I've tried googling but could not find any help!

Link to post
Share on other sites

Hi everybody,


I have an Elan touchpad in my ASUS K501UQ laptop and the latest beta and 4.6.5 kext didn't work for me on High Sierra - it said that it could not detect touchpad during boot ("not detect touchpad" to be precise). Does this mean that my touchpad model is not supported? How to extract touchpad model info? I tried using lspci from Linux but it only said "Elan", nothing more specific.



Link to post
Share on other sites

Fixed sierra OS X functions like Launchpad, Dashboard, Mission control etc., which are not working by redirecting to new keyboard shortcuts. (Needs to be configured at Keyboard shortcuts)

Hello, do any of you know what the mentioned new keyboard shortcuts are? how do I know if they're not written in the documentation?

Link to post
Share on other sites

By "needs to be configured at keyboard shortcuts" EMlyDinEsH means that when you make a trackpad gesture that is set to open launchpad (for example) it doesn't actually directly open it, instead it just do a keyboard shortcut, and you have to match that exact keyboard shortcut with launchpad in system preferences (if you set a different shortcut for launchpad in system preferences, the gesture doesn't work), but the documentation is not updated to v4.7 (as you can see in the part you quoted) and there is no mention of what these shortcuts he set as a workaround actually are (notification center is the only one mentioned but is wrong), I had to figure those out with a third party software that detected keys pressed when I made the gestures (ukelele).


For anyone actually interested in knowing it, this is what I found (QWERTY ISO layout):

1 - Applications Switch: command+"left arrow"

2 - App close: command+"right arrow"

3 - Launchpad: control+shift+command+L

4 - Mission control: control+up

5 - Dashboard: F12

6 - Left Space/Full Screen apps switch: control+"left arrow"

7 - Right Space/Full Screen apps switch: control+"right arrow"

8 - Application window: control+shift+command+A

9 - Minimize app: works as expected (command+M)

10 - Toggle Full screen Switch: alt+command+F

11 - Backward: alt+command+"["

12 - Forward: alt+command+"]"

13 - Desktop: F11

14 - Notification center (keyboard shortcut): control+shift+command+N (and not command+shift+N as stated in the documentation)
15 - Show Properties/Info: works as expected (command+i)
16 - Hide/Show Dock: alt+command+D (but it doesn't seem to work)
17 - Notification center (soft mode): doesn't work
18 - Zoom reset: works as expected (command+zero)
19 - Finder: alt+command+space (but I'm not shure what it should be doing, doesn't seem to work)
20 - Force Quit: work as expected (alt+command+esc)
21 - Right click: doesn't work as right click, instead it works as "20 - Force Quit" (alt+command+esc)
22 - Middle click: doesn't work

33 - should work as "F23" instead it's the real right click, but only when set to a tapping gesture

34 - should work as "F24" instead it's the real middle click, but only when set to a tapping gesture
35 - Left click: work as expected but only when set to a tapping gesture


The documentation really need to be updated, otherwise the kext cannot be configurated properly

  • Like 1
Link to post
Share on other sites

I've just installed the kext and I got the trackpad preferences panel working but I'm not able to use any kind of multitouch feature, for example I can't even use two fingers to scroll. Any idea or suggestion? 
Thanks in advance


I have a Lenovo 500s 13isk and it should have an Elan touchpad

Link to post
Share on other sites

Hi, I installed the latest version(4.7 beta 5) and got problems...


My touchpad isn't working at all... Though I can see the settings in the preferencepane. When I install voodooPS2controller, my touchpad works just as a mouse...And it doesnt recognized as a trackpad ethier.


Any suggestions? Thanks for the help

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...