Jump to content

ELAN and FocalTech (Smart Touchpad) driver Issues


EMlyDinEsH

Recommended Posts

I have an issue, i don't know if it is a bug or not.

 

When i click in a mouse the center button it show mission control , and click left and it exit from mission.

 

With elantech-v3 i click two buttons from trackpad (center button) and it show mission control , and click left  or right and it make a loop (like if i am pressing the two buttons to  show mission control), for left button central loop i need to tap (like click left in the touchpad) to exit the mission control. 

Link to comment
Share on other sites

I'm sorry, I already posted on this thread months ago but then I had to erase my Hackintosh

 

Now I'm here again, this time for good :D but my problem stands still:

the touchpad goes randomly. When I boot, sometimes it's on, sometimes it's off: if it's on, it stays on, if it's off it stays off.

 

The kext seems loaded, v3 recognized, if I go in touchpad settings I see all the options

The keyboard works as well, with fn combinations, numpad and all the stuff included perfectly

 

Just, I'm never sure if I can use the touchpad when I boot my hackintosh. Pretty annoying, as you can guess

 

 

 

 

 

Anything I can do to help you fix this problem?

 

Here's the kext loaded during boot, via Console

11/10/13 10:17:24,000 kernel[0]: Enhanced Apple PS2 Controller and Keyboard v2.8.3 by EMlyDinEsH(OSXLatitude) For Elan Touchpad (c) 2012-2013
11/10/13 10:17:41,000 kernel[0]: ElanTech Touchpad driver v2.8.3 by EMlyDinEsH(OSXLatitude) (c) 2012-2013
11/10/13 10:17:41,000 kernel[0]: Elan: Detecting the touchpad
11/10/13 10:17:41,000 kernel[0]: Elan: FirmWare Version 4525824
11/10/13 10:17:41,000 kernel[0]: Elan: Touchpad found, Assuming hardware version 3 (with firmware version 0x450f00)
11/10/13 10:17:41,000 kernel[0]: Elan: Successfully placed touchpad into Absolute mode
11/10/13 10:17:41,000 kernel[0]: Elan: Setting touchpad Range
11/10/13 10:17:41,000 kernel[0]: Elan: Touchpad Pad CentreX 1254, CentreY 660
11/10/13 10:17:41,000 kernel[0]: Elan: Touchpad range X_min 0 Y_min 0 X_max 2508 Y_max 1320
11/10/13 10:17:41,000 kernel[0]: Elan: MouseInformation { 0x20, 0x03, 0xc8 }
11/10/13 10:17:41,000 kernel[0]: Elan: Enabling the touchpad Success

This is from today's boot, and it DOES NOT work. As far as I can tell, when it does work the console shows pretty much the same

 

Thanks in advance and congrats, amazing work!

Link to comment
Share on other sites

I guess I found the problem: if I install a battery kext ( which replaces AppleACPIPlatform ) the touchpad stops working

 

I tried to uninstall the battery kext, and now it seems to work. Problem is, I'm without battery indicator now xD

 

Since I happen to be the only one with this problem, can you tell me which battery kext do you use on 10.8 ?

 

 

EDIT

I was wrong, touchpad still works totally randomly. Next time I booted without battery kext, it didn't work. So I reinstalled them, rebooted, didn't work. Now I booted and ta-daan, it works. Everytime I boot I'm spinning the wheel xD

Link to comment
Share on other sites

Hi there,

 

I would if you can help me. I managed to load the Elan driver on boot but the only thing that works is just the keyboard. I have to plug in a USB Mouse to be able to install OSX.

 

The version I am using is v2, for some reason v3 & v4 don't seem to load.

 

Do you know why this may be the case?

 

Also do you know if I can get v3 & v4 to load?

 

Thanks NSCXP2005

Link to comment
Share on other sites

Hi EMlyDinEsH i installed the Elan 2.8.3 on my Samsung NP900X3E ( a update (BT,Screen,touchpad,Processor ), version of X3C same ivy bridge platform ) i installed with no problem 10.9 using EDP and bootpack for X3C but no touchpad enable ( keyboard and just sound Fn keys works ) 

 

First i unistalled the kext from EDP installation 

and installed yours 2.8.3 driver, the result is this:

ElanTech Touchpad driver v2.8.3 by EMlyDinEsH(OSXLatitude) (c) 2012-2013
Elan: Detecting the touchpad
Elan: FirmWare Version 5725955
Elan: Unknown hardware version, aborting...

Any suggestion ? i have a V5 version ? thank you for this awesome driver in advance

Link to comment
Share on other sites

Hello Dinesh

 

The driver does not seem to work in Mavericks. 

 

It was working perfectly in 10.8.4 for an Aspire S3-951. 

 

The log says that the ApplePS2Controller.kext is not there, but it is not true. I'm using the kexts of the last 2.8.3 version

system.log:Oct 27 21:31:00 localhost kernel[0]: Kext com.apple.ApplePS2ElanTouchpad - library kext com.apple.ApplePS2Controller not found.
system.log:Oct 27 21:31:00 localhost kernel[0]: Can't load kext com.apple.ApplePS2ElanTouchpad - failed to resolve library dependencies.
system.log:Oct 27 21:31:00 localhost kernel[0]: Kext com.apple.ApplePS2ElanTouchpad failed to load (0xdc00800e).
system.log:Oct 27 21:31:00 localhost kernel[0]: Failed to load kext com.apple.ApplePS2ElanTouchpad (error 0xdc00800e).
system.log:Oct 27 21:31:00 localhost kernel[0]: Couldn't alloc class "ApplePS2ElanTouchPad"

/System/Library/Extensions kexts:

Extensions root# ls -ld *PS2*
[email protected] 3 root  wheel  102 Sep 12 17:20 ApplePS2Controller.kext
[email protected] 3 root  wheel  102 Sep 12 17:20 ApplePS2ElanTouchpad.kext

Thanks

Link to comment
Share on other sites

Not Works on Lenovo G580 device id ACPI\SYNO73B \4&1BC423EF&0 plis help or support 

 

the message shown when booting is : "unknown hardware version, aborting..."

You have Synaptics touchpad "SYNxxx", so try VoodooPS2Controller which has the support for your touchpad.

 

Hi, i have a notebook ASUS N71JQ. I've installed 2.8.3 versión over Mavericks.

 

EDIT:

 

Sorry, bad installation ;)

 

Now system boots a bit slow, touchpad works, but keyboard do not.

 

Preferences of the touchpad does not recognize it.

Perhaps you have conflicts with other kexts/kernel cache issues. Could you send me your system dump from windows/linux based on my dsdt/ssdt patching thread please? So i can give you recommended steps and kexts for your notebook and can add your model to our DB for future support. Also send me your System log from Console app with my kext installed so I can look for the cause of your problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...