Jump to content

keyboard not uk english


john67
 Share

Recommended Posts

when i installed osx 10.6.1 i chose english and british but my keyboard is in american? i mean if i want the @ icon i have to press shift and 2

ive been in system preferences and keyboard but cant see anyway to change it to uk?

any help appreciated

Link to comment
Share on other sites

You used a "distro", or a non-Apple sanctioned install disk, didn't you?

 

Apple only released 10.6, 10.6.3, and 10.6.8 install images/DVD's. Most "distros" of OS X usually strip out the fonts/keyboard layouts to preserve space and make the install disk fit on one single layer 4.7Gb DVD.

 

Reinstall using Apple sanctioned media. Thats the only way we can help you.

Link to comment
Share on other sites

  • Administrators

It's a common and well-known issue that the PC keyboard layout of a Hackintosh does not 100% match Apple's layout. It's not a problem of distros vs. legit' installation media. There are tools to circumvent that issue though...

 

Download a tool called Ukelele: http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=ukelele

 

Open the package folder (do not install it); you'll find a Logitech keyboard Layout directory. Select the 2 files appropriate to your EN-UK layout and copy them to "/Library/Keyboard Layouts" folder on your HDD. I attach screendumps for my FR keyboard as an example.

:Library:Keyboard_Layouts.png

Then open up the "Language & text" pref pane and go to the "Input Method" tab. Scroll down the list, select your newly installed layout and check the "Display input menu in menu bar" box.

Input_methods.png

You should then see the little language flag in the bar, usually next to the clock. Click on the flag and select your Logitech layout.

Language_selection.png

That will give you the correct keyboard layout.

 

You can then complete this with DoubleCommand tool: http://doublecommand.sourceforge.net/

 

Once it is installed, open up the pref pane and:

. select "Command key acts as Option Key"

. select "Option Key acts as Command Key"

. select "PC style Home and End Keys"

. click on "Activate", then save "User" + "System"

Double_Command.png

This is useful to be able to use the "Windows" key as "Apple" key for instance, or the Home & END keys as per on a regular Windows PC.

Link to comment
Share on other sites

Herve, it IS a problem of using a "distro" on this one though. Sure, most PC keyboards are different from Mac's, however its usually just a few keys, not every key. As soon as he said he has to use Shift+2 for the "@" symbol, that told me he was using an American QWERTY keyboard layout. The fact that he cannot change to a UK keyboard layout tells me that whomever built the install disk removed all language support and probably fonts. 

 

What happens when you remove all the language/keyboard packs? You get stuck with American QWERTY layout, with American English dictionaries because Apple caters to Americans, so its the default.

 

(I usually use Dvorak layout, and with "distros" I never got that option. Because it was removed.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...