Jump to content

Latitude E5430


driedger
 Share

Recommended Posts

Hi all, first post here.

 

Wondering if anyone out there has attempted OSX on the newer Dell Latitude E54x0 laptops? I just ordered an E5430 and it should be in next week. One of the first things I would like to do is attempt to get Lion (or potentially Mountain Lion) on this machine. I reviewed the specs and I think it should be possible, but the only hackintoshes I've built have been with known well supported hardware with a good user base and lots of guides to follow.

The specs for my machine will be as follows:

 

E5430

Intel Core i7 3520M - Ivy Bridge at 2.9ghz with 4mb cache

Mobile Intel HM77 Express Chipset

4GB DDR3 1600mhz

Intel HD 4000 Graphics

14" HD+ LED at 1600x900

Dell Wireless 1504 (I know there is little or no chance getting it to work)

Dell Wireless 380 Bluetooth 4.0

Internal English Backlit Dual Pointing Keyboard for Windows® 8

Integrated Dual PointingTouchpad without Fingerprint Reader

Light Sensitive Webcam and Noise Cancelling Digital Array Mic

 

I think that these specs would be very similar for a E5530 as well. Thoughts?

 

Mark

Link to comment
Share on other sites

  • Replies 49
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Hi all. My first post here too. My laptop is a dell latitude e5430 intel i5 with intel hd4000. Installed ML 10.8.2 and dual boot windows 8. It's working great except for bluetooth, sd card reader and wifi. Goh.

 

Hey there, good to know! Time for 1000 questions! ... Did you use the generic myHack install and Extra folder? Or another install method? Any complications with the install or custom kexts required? My biggest issues with my Lion install on my Asus 1201n netbook have been the trackpad and sleep, and I hope I have better success with the e5430 in those areas.

 

My E5430 is on a truck somewhere in the USA, my tracking number hasn't been updated in 2 days now, but Im really hoping it gets here by this weekend so I can dive right into this.

Link to comment
Share on other sites

I used myhack with generic extra folder. Need to install voodoops2 kext to USB installation in order for trackpad to work. Post installation, I used multifail to install other kexts.

Need to install to S/L/E: voodoops2controller, b5722d(network), voodoobattery, voodoohda, aicpupowermanagement, applesmartbatterymanager, caldigitfastio, caldigitusbxhcl, sleepenabler kexts.

Need to delete from S/L/e: applehpet (for USB to work properly), appleps2controller, appleacpips2nub, nullcpupowermanagement kexts.

for intelhd4000 to work, need to use efi injection string ig-platform-id: 01660004 . Use chemeleon bootloader, chimera (chameleon, stolen and rebranded) caused kp.

For "still waiting for root device problem", use the fix for ioahcifamily.kext from vahan's blog.

Org.chameleon.boot: usekernelcache=no, graphicsenabler=no

Touchpad 2 finger scrolling does not work.

sleep works..i think.

Link to comment
Share on other sites

I have installed wireless card into empty wwan slot using previous hackintosh laptop and i have wifi after that. however sd card reader still doesn't work with voodoosdhc.kext. Would really like to get multigesture to work though. Any ideas? 

Link to comment
Share on other sites

I received my laptop and have begun the journey to get Mountain Lion on it. I've hit a number of road blocks so far, but I think I am making a bit of process.

 

I have an OCZ 120GB Vertex SSD I wanted to put into the system, but it looks like a standard sized 2.5" drive doesnt quite fit with the bracket on it. My drive is a bit thicker than the seagate 320gb drive that shipped in it, but that was not the problem. With the bracket on the ssd, its like it does not insert all the way into the sata connectors, so the screws can't go back in to hold the HD cage in place. I've ordered a hard drive bay to replace the optical drive, and plan to put the SSD there instead.

 

I have found that there is only 1 USB port I am able to boot the myHack prepared 10.8 usb drive. It is the port located on the right side, close to the front. I had read that the rear usb port was the only USB 2.0, with the rest being USB 3.0 but that does not appear to be the case with my unit. Regardless, I had to boot with -x into safe mode to get the installer started.

 

I tried several VoodooPS2Controller.kext to try to get the track pad working in the install, but had no luck. I was putting the kext in the Extra folder of the myHack install usb, and then running myFix on it. The closest I got was to getting the trackpoint stick to work inverted, but the hard keys for left and right click did not work. To get a USB mouse working, it also had to be plugged into the right hand USB port, with a USB hub.

 

While waiting for the HDD bay adapter to come in, I opted to put the SSD in an external usb case to try the install that way. Disk utility would not see the drive unless it was also plugged into the hub on the right side usb port. I have ML installed on the external USB drive now, however, it is still not bootable unless I boot into safe mode. I tried  GraphicsEnabler=No but it did not made a difference. I found a thread on another site detailing someone's e5530 install with the same i7 processor and hd4000 graphics at 1080p, and have made changes to my org.chameleon.boot.plist to try to get the hd4000 graphics working, but ran out of time last night, and will need to resume tonight.

 

gohmac, what voodoops2controller did you use? And what trackpad do you have? When I ordered the e5430 there were 2 options, the standard trackpad and the Win8 trackpad. My unit has the Win8 Trackpad. Could you share your Extra folder?

 

Also, I followed the instructions in this thread to dump the dsdt/ssdt from Windows. Dont know if I should attach them to this thread, email them somewhere, or add them to the thread I referenced?

Link to comment
Share on other sites

  • Administrators
[...] Also, I followed the instructions in this thread to dump the dsdt/ssdt from Windows. Dont know if I should attach them to this thread, email them somewhere, or add them to the thread I referenced?

<_ do what it says in the thread:>

 

SEND US THE FILES WE'VE ASKED ABOVE TO THE FOLLOWING MAIL: [email protected]

AFTER SENDING THE FILES PLZ POST A REPLY HERE WITH THE MODEL OF YOUR SYSTEM.

Link to comment
Share on other sites

 Share


×
×
  • Create New...