Jump to content
PayPal donations: [email protected] ×

Bluetooth Firmware Uploader

Recommended Posts


I have a realteck bluetooth but with Azurewave vendor id. Is it possilble to work?


Detailed information is following.


Realtek Bluetooth 4.0 + High Speed Chip






I add the VID and PID by myself. I saw the log in the verbose mode. The BTFirmwareUploader says successfully patch the firmware and the PID and VID in the log is the same as my bluetooth.


However, at the last period of booting, the error log keeps bumping and bumping.

10/23/14 10:54:31.000 AM kernel[0]: BTFirmwareUploader :: Broadcom Standalone Bluetooth controller found
10/23/14 10:54:31.000 AM kernel[0]: Bluetooth Firmware Uploader v2.6 Final Copyright (c) 2012-2014 EMlyDinEsH (OSXLatitude).
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: [IOBluetoothHCIController][staticBluetoothTransportShowsUp] -- Received Bluetooth Controller register service notification -- 0x4000 
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][DeviceRequestCompleteHandler] -- Received 0xE000404F (kIOUSBPipeStalled) -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][DoDeviceReset] -- thread_call_enter1 (mReEnumerateOrResetThread) -- reEnumerateOrReset (0xffffff80d6c7be10) = 2 --  returned FALSE -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrResetThreadEntry] -- entering -- param0 = 0xffffff801da74000, param1 = 0x2 -- 0x4000
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- entering -- reEnumerateOrResetIn = 2 -- this = 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- in our workloop -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- parameter is valid -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- reEnumerateOrReset = 2 -- 0x4000 ****
10/23/14 10:54:31.000 AM kernel[0]: [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- calling myHub->ReEnumerateDevice() -- gEnumerateCounter = 1 
10/23/14 10:54:31.000 AM kernel[0]: [IOBluetoothHostControllerUSBTransport][ReEnumerateOrReset] -- exit; error = 0x0000 (kIOReturnSuccess)
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][ReEnumerateOrResetThreadEntry] -- exiting -- 0x4000
10/23/14 10:54:31.000 AM kernel[0]: [IOBluetoothHCIController::setConfigState] calling registerService
10/23/14 10:54:31.000 AM kernel[0]: **** [IOBluetoothHCIController][ProcessBluetoothTransportShowsUpActionWL] -- Connected to the transport successfully -- 0xf680 -- 0x0000 -- 0x4000 ****
10/23/14 10:54:31.822 AM sharingd[223]: 10:54:31.822 : SDStatusMonitor::kStatusBluetoothPowerChanged
10/23/14 10:54:31.823 AM sharingd[223]: 10:54:31.822 : SDStatusMonitor::kStatusBluetoothPowerChanged


Your device also does not need patches to firmware according to windows driver, so don't use my kext. Just inject the device ids in Broadcom kext to make it work.

Share this post

Link to post
Share on other sites

Hey thanks for the post led me to the answers for my wifi (on my bcm4352 combo card) but I am struggling with the bluetooth I have copied the firmware kext but unable to edit (not even sure if I am to edit let alone know what to put) to get my BT working (the manufacturer mentions Azurewave AW-CE123H on the invoice/packing slip).  If it looks like I am looking for someone to hold my hand I kinda am - I have spent weeks on my Asus g75vw turning it into a nice Mavericks Hackintosh and I don't want to wreck it... have been osx'ing since 10.4 but just for fun and I would break my install and just reinstall the next version but this is my xcode rig and there is too much to lose. I even bought a couple of used macs to ease my guilty conscience about the licensing.

Anyway good site and if ya can spare the time thanks in advance for your help!



Doug L.

Share this post

Link to post
Share on other sites


Dear Emly Dinesh,


I have used your firmware update for a machine that had the AR3011 and it worked very well. 


I have a Lenovo Thinkpad twist that has a Broadcom 43228 which is a combo containing the BCM20702A0. I have taken your updater and modified it to add a vendor ID of 0x0a5c (2652 decimal) and a product ID of 0x21f3 (8691 decimal). However, this is not working.


I may still be making a mistake. Can you let me know if there are any kexts I should remove while I add your updater? I didn't need to do it when I did the AR3011 but maybe you have some suggestions.


Thanks for your help.



Share this post

Link to post
Share on other sites

Anyone using AzureWave AW-CEH123H/ BCM943225HMB and not able to see the hardware in the System Info; it could be the whitelist in the BIOS. I had the issue using this one with HP Pavilion N15-204TX where the Wifi worked out of the box in Windows 8.1 and OS X 10.9.5 dual boot mode but could not detect the Bluetooth device in both. The solution is to defeat the while list disabling in BIOS by


-  Taping Pin 51 on the AW-CEH123H if  Bluetooth is whitelisted 

-  Taping Pin 20 if Wi-Fi is whitelisted


then use the plain vanilla Apple BT drivers applying the BT Firmware upload kext here  and the 5Ghz unlock patch. Rebooting the machine and Wifi (2.4 Ghz/5Hhz with Airdrop and Wake-on-lan) as well as Bluetooth works fine now. Thanks to  various members contributing here.


Here relevant System Info from my OS X 10.9.5 . 



       Chipset:[/size] [/size]20702A3[/size]


  Firmware Version: v14 c5270

  Bluetooth Power: On

  Discoverable: On

  Connectable: Yes

  Auto Seek Keyboard: On

  Auto Seek Pointing: On

  Remote wake: On

  Vendor ID: 0x13D3

  Product ID: 0x3404

  HCI Version: 0x6

  HCI Revision: 0x1496

  LMP Version: 0x6

  LMP Subversion: 0x220E

  Device Type (Major): Computer

  Device Type (Complete): Mac Portable

  Composite Class Of Device: 0x38010C

  Device Class (Major): 0x01

  Device Class (Minor): 0x03

  Service Class: 0x1C0


Bluetooth can also be enabled/disabled from the OS




Software Versions:[/size]

  CoreWLAN: 4.3.3 (433.48)

  CoreWLANKit: 3.3.2 (332.36)

  Menu Extra: 9.3.2 (932.35)

  System Information: 9.0 (900.8)

  IO80211 Family: 6.4 (640.36)

  Diagnostics: 3.0 (300.40)

  AirPort Utility: 6.3.2 (632.3)



  Card Type: AirPort Extreme  (0x14E4, 0x2123)

  Firmware Version: Broadcom BCM43xx 1.0 (

    Locale: FCC

  Country Code: US

  Supported PHY Modes: 802.11 a/b/g/n/ac

  Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165

  Wake On Wireless: Supported

  AirDrop: Supported

  Status: Connected



Hope this confirmation helps here someone  like me ( who struggled with it for a month ) and tried in vain to find a ROM BIOS whitelist hack without any success.


Someone asked what does taping a pin here means. Below is the verbose :

Basically, you take an electrical insulation adhesive tape. Using a scissor cutout a thin rectangular slice of this tape with a dimension slightly larger than the pin so that it will just fully cover this one pin on the combo card. Stick it on this pin #. Slide the card back into the PCI slot and you are good to go. So taping means just electrically insulating this specific pin# to make contact with its PCI female connector.

Share this post

Link to post
Share on other sites

Hi, I use the AzureWave AW-CEH123H/ BCM943225HMB and the wifi speed is extremely slow, like 10Kb/s.

I enabled the card in 10.10 using Clover by adding FakeID 0x43a014e4 and Airport_Fix enabled


Bluetooth is enabled after usage of BT Firmware upload kext 2.6


Disabeling bluetooth does not help resolving the issue. Is there anyone else that experienced this problem?

Have I forgotten a step?


Regards, relikwie.

Share this post

Link to post
Share on other sites



need help with my Azurewave ce123h Bluetooth. Yesterday I installed Yosemite with Ozmosis. Everything is working fine. Then I installed Toledas bcm4352 kext, bcm4352bt + btfirmwareuploader v2.6 and Wifi and BT was working perfectly.


2 hours later BT stopped pairing mighty mouse. I tried several things but nothing worked to re-pair it. Therefore I reinstalled Yosemite. 


Now BT isn't working at all. Could not see it in system information. Tried to reinstall all kexts but without success. Then I migrated a backup, now I can see the BT symbol but BT is still away from system information. 


Please, any advice what I have to look for? 


With Mavericks this card worked fine too, but pairing did`t work unless I disabled XHCI-Handoff in Bios. Therefore I tried the same for my current setup without success. 





Share this post

Link to post
Share on other sites

What is the device id for this bluetooth? 

here from About this Mac:


  Bluetooth faible énergie pris en charge : Oui

  Handoff pris en charge : Non

  Instant Hotspot pris en charge : Non

  Fabricant : Broadcom

  Transport : USB

  Jeu de puces : 20702A3

  Version du programme interne : v14 c5590

  Alimentation Bluetooth : Activé

  Détectable : Désactivé

  Connectable : Oui

  Rech. autom. du pointeur : Désactivé

  Réactivation distante : Activé

  ID du fournisseur : 0x04CA

  Identifiant du produit : 0x200B

  Version HCI : 0x6

  Révision HCI : 0x15D6

  Version LMP : 0x6

  Sous-version LMP : 0x220E

  Type d’appareil (principal) : Computer

  Type d’appareil (complet) : Mac Portable

  Classe d’appareils composite : 0x38010C

  Classe d’appareils (principale) : 0x01

  Classe d’appareils (secondaire) : 0x03

  Classe de services : 0x1C0

  Rech. autom. du clavier : Désactivé


The only trouble is: i'm not able to reconnect my mouse after sleep, i must remove it and reconnect it as a new one .

any help will be good !

Share this post

Link to post
Share on other sites



I managed that BT working again and visible in system informations. 


Only from time to time mighty mouse is visible but pairing impossible. 


Please, what can I do that to pair it? 



Share this post

Link to post
Share on other sites


the bt firmware uploader was working great on yosemite all dps but when i upgraded to yosemite finale the bt is not working anymore(version  2.6)

 my BT info:
VID: 0x0489 PID: 0xE032
i use combo card bcm4313
thank you

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...