Jump to content

Dell Latitude D830 myHack Install Issues


Recommended Posts

So I'm working on upgrading my snow leopard partition to lion on my Dell Latitude D830.


Last night I made a generic myHack installation onto a 16GB sandisk cruzer, and I booted my computer into the installer. However, after about 5 minutes in the installer, the computer completely froze, and I had to hold the power button to shut it off.


Then I formatted and recreated the myHack installer, this time using a bootpack for the high-res intel graphics card. It started booting with a kernel panic, which I resolved by using arch=X86_64. After it passed that point, it froze with the message:

Cannot alloc class Intel 965

My computer specs are:


-> Intel Core 2 Duo Processor

-> Standard Mobo

-> Intel Mobile 965 Graphics

Link to comment
Share on other sites

do you have tscsync kext in e/e? if your machine is intel 965 graphics it will have issues in arch=x86_64. you also might need your ioatafamily kext from snow.

Yea I have VoodoTSCSync.kext in the E/E folder. I'll try replacing the IOATAFamily kext with the one from my snow installation.


UPDATE: IOATAFamily.kext did nothing.

Link to comment
Share on other sites

I installed lion, it turns out I was using the wrong boot pack (I used the high res when I had low res).


But I need to use the myHack USB drive to boot to my OSX, whenever I try to boot from my main HDD I always get 

Sleep Image is too old by x. Use ForceWake=y to override.

"x" always varies. It stays at that message for about 5 seconds then reboots. I tried using ForceWake=y and it didn't do anything. I used Chameleon Wizard to install the latest chameleon to my mac drive but it never worked even after the install before I updated.


Also when I boot my drive, it says boot0: done, as if chameleon was loading, but then it loads BCD, from my Windows 7 installation.

Link to comment
Share on other sites

  • Administrators

Once booted, change your Hibernate mode to 0, either through EDP fixes or via Terminal command: "sudo pmset hibernate mode 0". You can then delete the sleepimage file.


For your Boot0: error, please do a search on the forum on 4k HDD. You'll find the way to fix it.

Link to comment
Share on other sites

  • Create New...